View Single Post
  #1  
Old 01.05.2021, 17:59
TomYam TomYam is offline
JD Alpha
 
Join Date: Dec 2019
Posts: 22
Default [Open in browser] and [Download from] do not show actual file link, but a post URL

I have encountered some of the following cases.
When grabbing multiple links from a forum post, LinkGrabber seems to collect all the link I selected on a post.
Then, when I send the links to Downloads queue, they look just fine.
However, when I try to open one of the links on my browser by selecting [Properties] [Open in browser], what is shown in the browser is not the file link, but the forum post from which I copied the file link. [Show Doanload URLs] shows the same URL.
If the forum post is the exact post with the file links, that is okay. But, sometimes it is just a forum search URL, from which I found the post. That URL does not really show the original post I found. So I have been screwed from time to time.

Internally, those file links seem to be stored in each queue, since the connection response when started is always correct (i.e. "Unsupported captcha..." message appears on filejoker links etc).
I made a DLC file to make sure if the stored link was retrieved into DLC file, but there was not.
When opening the queue in [Open Properties Panel], [Download from] shows also a forum post URL, not the file link. And this property cannot be changed. The same is true when opening the panel while the link is in LinkGrabber tab.

For one instance, the log is 27.04.21 21.19.54 <--> 01.05.21 11.53.26 jdlog://5831825302851/
The file links I want to download are **External links are only visible to Support Staff****External links are only visible to Support Staff** **External links are only visible to Support Staff****External links are only visible to Support Staff** and **External links are only visible to Support Staff****External links are only visible to Support Staff**
And the post is **External links are only visible to Support Staff****External links are only visible to Support Staff**
but I found it by searching the words in the post from here: **External links are only visible to Support Staff****External links are only visible to Support Staff**
(Please use the first line in the post to find it.)
Then select all the three links and push Ctrl+C, and LinkGrabber certainly grabs all three file links.
But, when the links are sent to Downloads, file links are not found in their properties.
I looked into the log files, and I only found the first one of the file links. I am not sure why the second and third links were also successfully grabbed by this procedures.

Edit: I understand that LinkGrabber certainly gets the exact file link when right clicking on the file link and then choosing Copy link URL on web browser. What I don't understand is even the link text is fully scripted, that is not shortened and the actual link URL and the text is the exact same, Ctrl+C does not sends the file link but the page URL instead, to JD2.

TIA

Last edited by TomYam; 01.05.2021 at 18:08. Reason: adding info
Reply With Quote