View Single Post
  #116  
Old 13.09.2019, 22:02
Derp Derp is offline
Black Hole
 
Join Date: Oct 2011
Posts: 268
Default

as Problem identifiziert.

Normalerweise checkt JD2 im Untertitel-XML nach diesem Eintrag im head:
Code:
<tt:metadata>
  <ebuttm:documentMetadata>
<ebuttm:documentEbuttVersion>v1.0</ebuttm:documentEbuttVersion>
  </ebuttm:documentMetadata>
</tt:metadata>
In hoster/ARDMediathek.java line 229 (und auch in hoster/ZdfDeMediathek.java line 198).

Bei den betroffenen Untertitel mit der 0Byte-Datei sieht es allerdings so aus:
Code:
<tt:metadata>
  <tts:documentMetadata>
<tts:documentEbuttVersion>v1.0</tts:documentEbuttVersion>
  </tts:documentMetadata>
</tt:metadata>
Ich habe dann die .class-Datei lokal testweise editiert (also den Check statt mit "<ebuttm:" mit "<tts:"), und die Untertitel-Datei wurde erfolgreich erstellt.

Wenn dieser Check also beide Arten akzeptieren würde, wäre das Problem behoben.

EDIT:
Dafür gibt es bei den Farben in der XML das gleiche Problem nur umgekehrt:

Bei den funktionierenden Untertitel:
Code:
<tt:styling>
  <tt:style xml:id="defaultStyle" tts:fontFamily="Verdana,Arial,Tiresias" tts:fontSize="160%" tts:lineHeight="125%"/>
  <tt:style xml:id="textBlack" tts:color="#000000" tts:backgroundColor="#000000c2"/>
  <tt:style xml:id="textRed" tts:color="#FF0000" tts:backgroundColor="#000000c2"/>
  <tt:style xml:id="textGreen" tts:color="#00FF00" tts:backgroundColor="#000000c2"/>
  <tt:style xml:id="textYellow" tts:color="#FFFF00" tts:backgroundColor="#000000c2"/>
  <tt:style xml:id="textBlue" tts:color="#0000FF" tts:backgroundColor="#000000c2"/>
  <tt:style xml:id="textMagenta" tts:color="#FF00FF" tts:backgroundColor="#000000c2"/>
  <tt:style xml:id="textCyan" tts:color="#00FFFF" tts:backgroundColor="#000000c2"/>
  <tt:style xml:id="textWhite" tts:color="#FFFFFF" tts:backgroundColor="#000000c2"/>
  <tt:style xml:id="textCenter" tts:textAlign="center"/>
  <tt:style xml:id="textLeft" tts:textAlign="left"/>
  <tt:style xml:id="textRight" tts:textAlign="right"/>
</tt:styling>
Bei den nicht funktionierenden Untertitel:
Code:
<tt:styling>
  <tt:style xml:id="defaultStyle" ebuttm:fontFamily="Verdana,Arial,Tiresias" ebuttm:fontSize="160%" ebuttm:lineHeight="125%"/>
  <tt:style xml:id="textBlack" ebuttm:color="#000000" ebuttm:backgroundColor="#000000c2"/>
  <tt:style xml:id="textRed" ebuttm:color="#FF0000" ebuttm:backgroundColor="#000000c2"/>
  <tt:style xml:id="textGreen" ebuttm:color="#00FF00" ebuttm:backgroundColor="#000000c2"/>
  <tt:style xml:id="textYellow" ebuttm:color="#FFFF00" ebuttm:backgroundColor="#000000c2"/>
  <tt:style xml:id="textBlue" ebuttm:color="#0000FF" ebuttm:backgroundColor="#000000c2"/>
  <tt:style xml:id="textMagenta" ebuttm:color="#FF00FF" ebuttm:backgroundColor="#000000c2"/>
  <tt:style xml:id="textCyan" ebuttm:color="#00FFFF" ebuttm:backgroundColor="#000000c2"/>
  <tt:style xml:id="textWhite" ebuttm:color="#FFFFFF" ebuttm:backgroundColor="#000000c2"/>
  <tt:style xml:id="textCenter" ebuttm:textAlign="center"/>
  <tt:style xml:id="textLeft" ebuttm:textAlign="left"/>
  <tt:style xml:id="textRight" ebuttm:textAlign="right"/>
</tt:styling>
Also haben die "kaputten" Untertitel tts wo ebuttm hingehört, und ebuttm wo tts hingehört.

Nach dem Anpassen von hoster/BrDe.java (line 186) (ebuttm: statt tts:) funktionierte auch das Einfärben der Untertitel

Last edited by Derp; 13.09.2019 at 22:52.
Reply With Quote