View Single Post
  #47  
Old 05.02.2012, 12:59
rekotc
Guest
 
Posts: n/a
Default working script for netgear DNG1000 (N-150)

this is the script im currently using for my netgear DGN1000 (N-150) firmware version V1.1.00.34_ww which is the "rest of the world" firmware version, give it a try

Spoiler:
[[[HSRC]]]
[[[STEP]]]
[[[REQUEST]]]
GET / HTTP/1.1
Host: %%%routerip%%%
[[[/REQUEST]]]
[[[/STEP]]]

[[[STEP]]]
[[[REQUEST]]]
GET / HTTP/1.1
Host: %%%routerip%%%
Authorization: Basic %%%basicauth%%%
[[[/REQUEST]]]
[[[/STEP]]]

[[[STEP]]]
[[[REQUEST]]]
GET /start.htm HTTP/1.1
Host: %%%routerip%%%
Authorization: Basic %%%basicauth%%%
[[[/REQUEST]]]
[[[/STEP]]]


[[[STEP]]]
[[[REQUEST]]]
GET /setup.cgi?next_file=wanstat.htm HTTP/1.1
Host: %%%routerip%%%
Authorization: Basic %%%basicauth%%%
[[[/REQUEST]]]
[[[/STEP]]]

[[[STEP]]]
[[[REQUEST]]]
GET /setup.cgi?next_file=st_poe.htm HTTP/1.1
Host: %%%routerip%%%
Authorization: Basic %%%basicauth%%%
[[[/REQUEST]]]
[[[/STEP]]]


[[[STEP]]]
[[[REQUEST]]]
POST /setup.cgi HTTP/1.1
Host: %%%routerip%%%
Authorization: Basic %%%basicauth%%%

todo=disconnect&this_file=st_poe.htm&next_file=st_poe.htm
[[[/REQUEST]]]
[[[/STEP]]]

[[[STEP]]]
[[[REQUEST]]]
GET /setup.cgi?next_file=st_poe.htm HTTP/1.1
Host: %%%routerip%%%
Authorization: Basic %%%basicauth%%%
[[[/REQUEST]]]
[[[/STEP]]]


[[[STEP]]]
[[[REQUEST]]]
POST /setup.cgi HTTP/1.1
Host: %%%routerip%%%
Authorization: Basic %%%basicauth%%%

todo=connect&this_file=st_poe.htm&next_file=st_poe.htm
[[[/REQUEST]]]
[[[/STEP]]]

[[[STEP]]]
[[[REQUEST]]]
GET /setup.cgi?next_file=st_poe.htm HTTP/1.1
Host: %%%routerip%%%
Authorization: Basic %%%basicauth%%%
[[[/REQUEST]]]
[[[/STEP]]]


[[[/HSRC]]]
Reply With Quote