View Single Post
  #37  
Old 17.01.2013, 22:34
Mister Floppy Mister Floppy is offline
Bandwidth Beast
 
Join Date: May 2009
Location: Erde
Posts: 149
Default Erfolg bei WLAN; bei Mobilfunk nun andere Fehlermeldung

Hallo,

erst einmal vielen Dank dafür, dass Du Dich meines Problems angenommen hast. Einen kleinen Teil-Erfolg konnte ich mit Deiner Hilfe jetzt schon verzeichnen: Per WLAN funktioniert es jetzt!

Beim Mobilfunk klappt es allerdings noch nicht.

Ich habe keine Software-Firewall installiert, und die Windows XP-interne Firewall habe ich über die Systemsteuerung komplett deaktiviert.

Ich habe zum Testen, ob ich grundsätzlich per Mobilfunk über den Port 54322 meinen Router erreichen kann, auf dem Smartphone die kostenlose App "Ping & DNS" aus dem Google Playstore heruntergeladen und installiert. Man kann damit über eine Drop-Down-Auswahl mit einer beliebigen IP-Adresse verschiedene Dinge anstellen, u. a. auch eine Port-Freigabe checken. Wenn ich hier als IP-Adresse diejenige meines Routers sowie als zu prüfenden Port eben jenen 54322 einstelle und den Test "Check Port" durch Klick auf "Go" starte, kommt bei laufender "Captcha Server starten.bat" die positive Meldung "Port 54322 on <aktuelle IP-Adresse des Routers>" is open".

Damit das funktioniert, muss ich in meinem Router folgende Einstellung vornehmen (wobei mein PC, auf dem die ""Captcha Server starten.bat" läuft, die feste IP-Adresse 192.168.0.1) hat:



Das heisst doch bis hierhin schonmal, dass vom Grundsatz her der Datenaustausch über Port 54322 möglich sein müsste, oder?

Deine App zeigt mir im Gegensatz zu "Ping & DNS" jedoch nur "Verbinde..." und nach einiger Zeit folgenden Fehler an:
java.net.unknownhostexception: Unable to resolve host <aktuelle IP-Adresse des Routers>": No adress associated with hostname"

Kannst Du mir bitte weiterhelfen, woran es liegen könnte? In Deiner PDF-Anleitung steht ja auch etwas von einer settings.cfg (die ich unverändert gelassen habe), liegt hier vielleicht der Hund begraben?

Danke für Dein Feedback im Voraus!

Gruß

Mister Floppy
Reply With Quote