Thread: [Script request] script for ZXHN F660 don't work
View Single Post
  #2  
Old 14.08.2017, 21:39
mspm89 mspm89 is offline
DSL Light User
 
Join Date: Feb 2012
Location: León, Nicaragua
Posts: 34
Default

I have a similar model, ZXHN H108N, and the reconnection script in JD2 just won't get done.

Windows 7 64-bit. This is the script:

Code:
[[[HSRC]]]
    [[[STEP]]]
        [[[REQUEST]]]
        GET / HTTP/1.1
        Host: %%%routerip%%%
        [[[/REQUEST]]]
    [[[/STEP]]]

    [[[STEP]]]
        [[[REQUEST]]]
        POST / HTTP/1.1
        Host: %%%routerip%%%

frashnum=&action=login&Frm_Logintoken=1&Username=admin&Password=c1%40r0
        [[[/REQUEST]]]
    [[[/STEP]]]

    [[[STEP]]]
        [[[REQUEST]]]
        GET /start.ghtml HTTP/1.1
        Host: %%%routerip%%%
        [[[/REQUEST]]]
    [[[/STEP]]]

    [[[STEP]]]
        [[[REQUEST]]]
        GET /top.gch HTTP/1.1
        Host: %%%routerip%%%
        [[[/REQUEST]]]
    [[[/STEP]]]

    [[[STEP]]]
        [[[REQUEST]]]
        GET /template.gch HTTP/1.1
        Host: %%%routerip%%%
        [[[/REQUEST]]]
    [[[/STEP]]]

    [[[STEP]]]
        [[[REQUEST]]]
        GET /getpage.gch?pid=1002&nextpage=net_tr069_basic_t.gch HTTP/1.1
        Host: %%%routerip%%%
        [[[/REQUEST]]]
    [[[/STEP]]]

    [[[STEP]]]
        [[[REQUEST]]]
        GET /getpage.gch?pid=1002&nextpage=manager_dev_conf_t.gch HTTP/1.1
        Host: %%%routerip%%%
        [[[/REQUEST]]]
    [[[/STEP]]]

    [[[STEP]]]
        [[[REQUEST]]]
        POST /getpage.gch?pid=1002&nextpage=manager_dev_conf_t.gch HTTP/1.1
        Host: %%%routerip%%%

IF_ACTION=devrestart&IF_ERRORSTR=SUCC&IF_ERRORPARAM=SUCC&IF_ERRORTYPE=-1&flag=1&_SESSION_TOKEN=1731146347548834
        [[[/REQUEST]]]
    [[[/STEP]]]

[[[/HSRC]]]

jdlog://6174314015941/

Last edited by mspm89; 14.08.2017 at 21:43. Reason: Log correction
Reply With Quote