View Single Post
  #1  
Old 13.10.2021, 12:20
Pisellao Pisellao is offline
Baby Loader
 
Join Date: Jan 2021
Posts: 7
Exclamation JD2 And alldebrid.com never worked well

Hello,
Using JD2 latest version (just updated), and AllDebrid premium account.
Trying downloading from mega and it never worked well. JD2 is bugged.
Author has always bounced me in these thread giving blaming Alldebrid but it's not. It's either JD2 or Alldebrid plugin, i don't know.

So, I added an Alldebrid premium account and it's connected successfully. Green check on JD2 and premium active.

Now, when I put various mega links, it downloads for a bit and then it starts throwing any sort of weird excuses to not download.

Sometimes is 509 Bandwith exceeded, Sometimes is Blocked by google, sometimes is Host under maintenance, Sometime is Skipped, missing account.

All lies.
I go to alldebrid site and use their link unlocker and everything works wonderfully.
I would totally dismiss JD2, IF, and this is a big IF, Alldebrid would maintain the folder structure of Mega, which it doesn't and you end up having thousand of links without a structure.

That said, I tried everything. It does't do its job.
I also set up a custom rule following the errors I made and which I posted about and JD2 author pointed me toward the right direction. But nothing changed.

You can see valid premium and current rules in attachment. I totally disabled free accounts but still no relevant result.

Now to the logs:

Quote:
------------------------Thread: 43061:mega.co.nz_jd.plugins.hoster.MegaConz_alldebrid.com-----------------------
--ID:43061TS:1634116433793-13/10/21 11.13.53 - [jd.controlling.downloadcontroller.DiskSpaceManager(handle)] -> DiskSpaceManager:Result:OK|File:D:\downloads\MY FILE FAKE NAME FOR POSTING ON THIS FORUM.mp4.part|Root(s):[D:\]|Requestor:null|RequestedSpace:155,11 MB|UsableSpace:58,80 GiB
------------------------Thread: 44660:mega.co.nz_jd.plugins.hoster.MegaConz_alldebrid.com-----------------------
--ID:44660TS:1634116438642-13/10/21 11.13.58 - [] -> Exception thrown at jd.controlling.downloadcontroller.SingleDownloadController.download(SingleDownloadController.java:43 8):
jd.plugins.PluginException: Host under maintenance or not available->ERROR_TEMPORARILY_UNAVAILABLE|Value:229056
at jd.plugins.components.MultiHosterManagement.runCheck(MultiHosterManagement.java:103)
at jd.plugins.hoster.AllDebridCom.handleMultiHost(AllDebridCom.java:457)
at jd.plugins.PluginForHost.handle(PluginForHost.java:1231)
at jd.controlling.downloadcontroller.SingleDownloadController.download(SingleDownloadController.java:43 3)
at jd.controlling.downloadcontroller.SingleDownloadController.run(SingleDownloadController.java:615)
I don't even know what ERROR_TEMPORARILY_UNAVAILABLE
means.
If I go to the link, and try downloading the file it works.
If I put the link on alldebrid website, it works.


Another one:
Quote:
--ID:43061TS:1634116604880-13/10/21 11.16.44 - [jd.controlling.downloadcontroller.DownloadWatchDog(setFinalLinkStatus)] -> DownloadCandidate:06-Mod_2_LESSON_6_PDF.pdf@mega.co.nz|Host mega.co.nz|Account:Plugin:alldebrid.com|Version:44795|Type:MULTI|Account:notmyrealaccount:null@allde brid.com=true Property: {lastKnownValidUntilTimeStamp=faketimestamp, IS_MULTI_HOSTER_ACCOUNT=true, ACCOUNT_TYPE=PREMIUM, lastKnownAccountType=PREMIUM, apiv4_apikey=yesyouwishileftthis, LATEST_VALID_TIMESTAMP=fakeagain, VALID_UNTIL=fakeagainitsvalid, APIKEY_CREATED_TIMESTAMP=surewhynot} AccInfo: Property: {multiHostSupport=[1fichier.com, 4shared.com, alfafile.net, alldebrid.com, anzfile.net, bayfiles.com, bdupload.asia, clicknupload.cc, cloudvideo.tv, cosmobox.org, dailyuploads.net, ddownload.com, douploads.net, drive.google.com, drop.download, dropgalaxy.in, dropmyfiles.com, file-up.org, file.al, file4safe.com, filebonus.net, filefactory.com, filerio.in, filespace.com, fileup.cc, fileupload.pw, filezip.cc, fireget.com, flashbit.cc, florenfile.com, fshare.vn, gigapeta.com, harefile.com, hexupload.net, highstream.tv, hitfile.net, inclouddrive.com, indishare.org, isra.cloud, jumploads.com, katfile.com, letsupload.io, load.to, mediafire.com, mega.co.nz, mixdrop.co, mixloads.com, nelion.me, pandafiles.com, prefiles.com, rapidgator.net, rapidrar.com, rarefile.net, scribd.com, sendit.cloud, sendspace.com, simfileshare.net, takefile.link, turbobit.net, ubiqfile.com, upload.ac, uploadbox.io, uploadboy.com, uploaded.to, uploader.link, uploadev.org, uploadrar.com, uppit.com, uptobox.com, userscloud.com, usersdrive.com, userupload.net, videobin.co, vidlox.me, vidoza.net, vipfile.cc, wdupload.com, wipfiles.net, world-files.com, worldbytez.com, wushare.com, zippyshare.com]}|Proxy:{
"proxy" : {
"proxy" : {
"username" : null,
"password" : null,
"port" : 80,
"address" : null,
"type" : "NONE",
"preferNativeImplementation" : false,
"resolveHostName" : false,
"connectMethodPrefered" : false
},
"rangeRequestsSupported" : true,
"filter" : null,
"pac" : false,
"reconnectSupported" : true,
"enabled" : true
},
"banlist" : "[]",
"class" : "jd.controlling.proxy.NoProxySelector"
}->FILE_UNAVAILABLE
Again, NO.
File can be downloaded manually from browser and can be activated on Alldebrid site.
It's NOT unavailable.

What is wrong?
Why it's not working
Attached Images
File Type: png ssss.png (119.3 KB, 1 views)
Reply With Quote