View Single Post
  #8  
Old 04.04.2019, 09:51
julien1530 julien1530 is offline
Baby Loader
 
Join Date: Jul 2018
Posts: 7
Default

wow, sounds you are familiar with apple programming

Unfortunately and unlike iOS, Apple does not offer simulators (or have anything like) to allow developers tests on previous macOS versions.

Instead, we are required to install macOS on virtual machines for testing. In addition, I have seen that some OS versions can't even more downloaded from the Mac App Store or the Apple Developer Portal.

All this makes backward compatibility difficult and uncomfortable.

Julian
Reply With Quote