View Single Post
  #1  
Old 08.09.2015, 11:53
firefranz firefranz is offline
Junior Loader
 
Join Date: Sep 2015
Posts: 11
Default TP Link Archer C7 v2 FW 3.14.3 Build 150427 Rel.36706n

Hi,

I already had a working script as batch file for my old TP Link Router

In the past I used this one:

Code:
curl.exe "**External links are only visible to Support Staff** > nul
curl.exe "**External links are only visible to Support Staff** > nul
If I log on to the Web Interface of my TP Link Archer C7 v2 (Firmware 3.14.3 Build 150427 Rel.36706n) the URL does always change after I logged on.

Sometime it is 192.168.1.1/JXIUMIMAWNHDPPLA/userRpm/Index.htm, next time for instance 192.168.1.1/PJLDWDFAGJKAVGEA/userRpm/Index.htm etc.

Due to this something like "192.168.1.1/userRpm/StatusRpm.htm?Disconnect=Disconnect&wan=1" is no longer working as there is this changing part of the URL.

Does anyone have any suggestion? Is there an option I may have overseen that gets rid of the variable part of the URL?

Currently I am helping myselfe with an Autohotkey Script playing around with the URL using Firefox which is my default browser (other browsers would work as well if ^l would be changed to the corresponding hotkey to focus the URL bar).

However I don't like the solution too much as it is error-prone.

Code:
run "**External links are only visible to Support Staff**
Sleep, 5000  ; Wait 5 seconds
Send username
Send {TAB}
Send password
Send {ENTER}
Sleep, 5000  ; Wait 5 seconds
Send ^l
Sleep, 5000  ; Wait 5 seconds
Send ^a
Sleep, 1000  ; Wait 1 seconds
Send ^c
URL_OLD = %clipboard%
StringReplace, URL_DISCONNECT, URL_OLD, userRpm/Index.htm ,userRpm/StatusRpm.htm?Disconnect=Disconnect&wan=1
StringReplace, URL_CONNECT, URL_OLD, userRpm/Index.htm ,userRpm/StatusRpm.htm?Connect=Connect&wan=1
Send %URL_DISCONNECT%
Send {ENTER}
Sleep, 5000  ; Wait 5 seconds
Send ^l
Send %URL_CONNECT%
Send {ENTER}
Sleep, 1000  ; Wait 1 seconds
Send ^w

Last edited by firefranz; 08.09.2015 at 19:33.
Reply With Quote