View Single Post
  #4  
Old 29.11.2018, 10:27
Jiaz's Avatar
Jiaz Jiaz is offline
JD Manager
 
Join Date: Mar 2009
Location: Germany
Posts: 67,320
Default

Quote:
Originally Posted by ananda96 View Post
java 8 wird OBSOLET ab januar und damit gefährlich!
Diese Aussage ist so falsch. Java 8 erhält weiterhin Backports und Security Fixes. Nur weil Oracle ab Januar weitere Updates an Java 8 nur noch gegen Supportverträge rausrückt, heisst das nicht das es keine Updates mehr gibt.
Alle genannten JVMs aus meinem ersten Post erhalten weiterhin die Backports und Security Fixes. Sofern können
wir oder der Nutzer selbst jederzeit einfach auf einen anderen Anbieter wechseln.

Ebenfalls ist der Einsatz von Java 8 oder älteren Java Versionen nicht *pauschal* gefährlich. Fast alle der Sicherheitsbedenklichen Probleme entstanden durch das Browser-Plugin, womit Lücken/Bugs jederzeit durch Webseiten ausgenutzt werden konnten. JDownloader kommt mit einer eigenen gebündelten JVM, welche nicht im System installiert ist. Auch kann der Nutzer jederzeit eine eigene/andere JVM nutzen.
Mir ist bis dato keine Sicherheitslücke bekannt welche durch den JDownloader ausnutzbar wäre. Aber auch mein Wissen ist nicht unendlich und so lasse ich mich gerne aufklären über Lücken welche durch den JDownloader ausnutzbar sind und dann prüfen wir diese und können entsprechende Anpassungen vornehmen.
__________________
JD-Dev & Server-Admin

Last edited by Jiaz; 29.11.2018 at 10:46.
Reply With Quote