View Single Post
  #7  
Old 29.11.2018, 10:40
Jiaz's Avatar
Jiaz Jiaz is offline
JD Manager
 
Join Date: Mar 2009
Location: Germany
Posts: 67,320
Default

Quote:
Originally Posted by ananda96 View Post
Warum passt ihr den JD nicht an die aktuelle Runtime an?
Natürlich passen wir JDownloader entsprechend an, damit er auch mit aktuellen Java Versionen läuft und da JDownloader von Java 1.6 bis Java 11 unterstützt, kann ich wohl davon ausgehen, das wir das auch ganz gut machen.
Wir (die Entwickler) machen derzeit keinen Gebrauch von neuren Java-Sprach-Features oder sehen in diesen einen zwingenden Grund zum Upgrade und sehen daher keinen Grund die mindest Java Version anhzuheben, denn dass wäre nötig wenn wir auf die neuen Sprach-Features zugreifen wollen.

Wichtig hierbei: Es ist ein Unterschied ob man eine Anwendung an eine Java Version anpasst oder kompatibel macht. Bei ersteren sperrt man automatisch alle Nutzer älterer Java Versionen aus und bei zweiterem bleiben alle Nutzer Happy.

JDownloader läuft auf so gut ALLEM was Java hat. Von normalen Computer(Linux,Mac,Linux,OS/2...X86, Sparc, Arm..) , NAS(Qnap, Synology, WD..),Routern, embedded Devices ...https://support.jdownloader.org/Know...bedded-devices
Zb gibt es noch eine treue MAC Nutzerbasis welche noch immer auf Java 1.6 Update 151 sitzt, weil die alte Hardware einfach keine Updates mehr erhält. Gleiches gilt für SEHR SEHR viele XP Nutzer.
__________________
JD-Dev & Server-Admin

Last edited by Jiaz; 29.11.2018 at 10:43.
Reply With Quote