Thread: [Solved] reCaptcha Stopped Working
View Single Post
Old 27.06.2018, 20:24
gandalf_grey91 gandalf_grey91 is offline
JD Alpha
Join Date: Sep 2014
Posts: 21
Default reCaptcha Stopped Working

Edit by Jiaz:

It seems google is having issues with Recaptcha. It's not limited to JDownloader/Extension but also happens in Browser. We can reproduce the issue on our own sites (eg signup in forum here) as well.

You will find more issue reports with search engine of your choice.
Maybe connected to

The issue is not caused by JDownloader as JDownloader has no influence on the RecaptchaV2 nor taking part in it in any way. All Captcha stuff happens directly in browser between browser and google. No JDownloader involved at all.

Either there are issues at Google side (would explain why same issues happen with normal websites as well) or they are working on Recaptcha/applied new updates/tightened up the security, we don't know.

Hi there,

As of this morning, I am no longer able to solve reCaptcha using the browser extension.

After ticking the "I'm not a robot" box, it loads the reCaptcha box, however when clicking on the images, they change really slowly, taking about 30 seconds each to change.

And no matter how I solve the reCaptcha, it always says it was incorrect and loads another reCaptcha.

I use the Firefox browser extension, I have updated FF to the latest version, that has not solved the problem.

It appears to make no difference which hoster the reCaptcha is sent from, it doesn't work.

I have had this problem before, and was stuck unable to use JDownloader, back when ReCaptcha changed (late 2017?), which seemed to take a few weeks to be resolve and has worked for most hosters since then.

I would really appreciate some help.

Kind regards

Last edited by Jiaz; 28.06.2018 at 17:32.
Reply With Quote