View Single Post
  #10  
Old 15.05.2010, 02:39
weblurker weblurker is offline
Linkgrabbing Monster
 
Join Date: Mar 2009
Posts: 85
Default

Quote:
Originally Posted by remi View Post
Thanks for reading and obeying the rules. You're a rare, but also logically thinking person. I like that.
I've been programming for a very long time and have received a lot of confusing and contradictory bug reports from end users. There's nothing wrong with that, most people aren't used to the need for precision and detail that a good bug report requires.

Quote:
Originally Posted by remi View Post
You're right, the Linkgrabber should say that the file can't be found, but it doesn't. It sees an http link and continues "Checking online availability...", even after I deleted the link. The abort feature works and I'm running a rather old JRE. The Sun's bugfixes link has the same problem. I think it'll be a minor bug in the Linkgrabber. The links contain special characters (@ and #).
It's good that you were able to reproduce the problem.

It appears that there are two bugs, one that the Linkgrabber never completes the online check and the other is that deleting the http links doesn't abort the checking process.

However, once my friend discovered that clicking on the abort button works, that easy workaround meant the problem became just a very minor annoyance.

Quote:
Originally Posted by remi View Post

I'm not going to discuss why jD is not compliant with JRE update 18, 19 and in some cases 20. I can only observe that most recent problems have been solved by returning to update 17. Some people are successfully running update 20. Update 18 probably had many bugs that weren't solved in update 19.
My friend and I have been running JRE v17, 18, 19 and now 20 with no problems, other than the Linkgrabber bug. OTOH, JD has a very broad range of support for file hosts and I only use a handful of file sources.

Hopefully the JD team will have time to get things tested and running under the most recent JRE. It's always a PITA for everyone involved to have to stick to an old version of a runtime system or library.
------------------------
Quote:
Originally Posted by drbits View Post
Thank you for the feedback. However, our tests show significant problems with Java 6u18-6u20. Sun is chasing after Windows "7" compatibility and appears to have added some serious problems. We will continue to test each new JRE version carefully.
Is there a list of those problems somewhere on this forum? I'd be very interested in see what kinds of bugs have been introduced by Sun with the later JREs.

Gosling has left Oracle/Sun and I've noticed that the Java libraries have slowly drifted downwards in quality. Maybe the JRE problems are consistent with the other problems with Java.

Quote:
Originally Posted by drbits View Post
I believe the problem you are describing has been fixed in the Nightly test release of JDownloader. I cannot recommend that you change to it right now, because there are some issues. However, if you could supply some more trouble links, I will test them in the Nightly release. Right now, I only have the link in message 7 update 3.
All the troublesome links are just minor variants of the link in update 3, so if the problem has been fixed in the nightly build, that should be the end of the issue.

Edit:

For the record, I didn't request that the double post be edited.

Last edited by weblurker; 16.05.2010 at 20:04. Reason: Removed double post at user request. ** I didn't request this change