Thread: [User feedback required] Problems updating on Raspberry Pi
View Single Post
  #1  
Old 06.05.2019, 14:49
Sinon Sinon is offline
Baby Loader
 
Join Date: Dec 2009
Posts: 7
Default Problems updating on Raspberry Pi

Hi,

I wasn't able to do a proper update for JDownloader on my old Pi 1 for ages, because I always get the same error at about 75%:
I start JDownloader via "java -jar JDownloader.jar"
Installed Java is
Code:
java version "1.7.0_60"
Java(TM) SE Runtime Environment (build 1.7.0_60-b19)
Java HotSpot(TM) Client VM (build 24.60-b09, mixed mode)
Error messages:

Code:
org.jdownloader.update.SelfUpdateException: Unexpected Selftest Result: FAILED org.jdownloader.update.lastchance.FailedException: java.lang.Exception: No Client set yet
	at org.jdownloader.update.SelfUpdateClient.validateSelfTestFile(SelfUpdateClient.java:478)
	at org.jdownloader.update.SelfUpdateClient.finishSelfUpdate(SelfUpdateClient.java:319)
	at org.jdownloader.update.UpdateManager.runFinishSelfUpdate(UpdateManager.java:917)
	at org.jdownloader.update.DefaultCallbackHandler.onResults(DefaultCallbackHandler.java:369)
	at org.jdownloader.update.UpdateManager.runUpdateLoop(UpdateManager.java:1276)
	at org.jdownloader.update.UpdateManager$4.run(UpdateManager.java:355)
	at java.lang.Thread.run(Thread.java:745)
This happens twice in a row, then I get
Code:
org.jdownloader.update.launcher.JDLauncherFailedException: java.lang.NoClassDefFoundError: org/jdownloader/startup/Main
	at org.jdownloader.update.launcher.SecondLevelLauncher.launchJDownloader(SecondLevelLauncher.java:760)
	at org.jdownloader.update.launcher.SecondLevelLauncher.init(SecondLevelLauncher.java:513)
	at org.jdownloader.update.launcher.SecondLevelLauncher.runMain(SecondLevelLauncher.java:247)
	at org.jdownloader.update.launcher.JDLauncherViaClassLoader.main(JDLauncherViaClassLoader.java:10)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:606)
	at org.jdownloader.update.launcher.JDLauncher.main(JDLauncher.java:79)
Caused by: java.lang.NoClassDefFoundError: org/jdownloader/startup/Main
	at org.jdownloader.update.launcher.SecondLevelLauncher.launchJDownloader(SecondLevelLauncher.java:700)
	... 8 more
Caused by: java.lang.ClassNotFoundException: org.jdownloader.startup.Main
	at java.net.URLClassLoader$1.run(URLClassLoader.java:366)
	at java.net.URLClassLoader$1.run(URLClassLoader.java:355)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.net.URLClassLoader.findClass(URLClassLoader.java:354)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:425)
	at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:308)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:358)
	... 9 more
I tried downloading a new Jdownloader.jar, deleting tmp and update folders, but to no avail. Any ideas?

Update: While writing this I had my Pi running "java -Djava.awt.headless=true -jar JDownloader.jar -norestart" which apparantly got through with all the updates. So this seems to be a GUI problem?
Reply With Quote