JDownloader Community - Appwork GmbH
 

 
 
Thread Tools Display Modes
  #1  
Old 24.06.2009, 19:24
dragonkings
Guest
 
Posts: n/a
Default the Mac Download is older version not new one

the main page has the windows version up to date but the two free hosters of your program for Mac os have two outdated older versions connected to the links.
They don't seem to work properly for some reason on my computer also, please fix.
I had new version, but this is older version that doesn't seem to load on to my mac properly just loads forever and refuses to reconnect after first use for some reason, could be on my end but...
the main page says version 0.6.193 but when you follow the links it goes to to older 0.5.917 version zip files.

Last edited by Jiaz; 25.06.2009 at 03:09.
  #2  
Old 24.06.2009, 19:29
gocsp
Guest
 
Posts: n/a
Default

Hi,

sorry for that.

**External links are only visible to Support Staff****External links are only visible to Support Staff**
  #3  
Old 24.06.2009, 19:30
dragonkings
Guest
 
Posts: n/a
Default

thank you
  #4  
Old 25.06.2009, 19:24
rotz
Guest
 
Posts: n/a
Default end of the line for PowerPC Macs?

I downloaded that version and copied it to the Applications folder. I am running MacOS 10.4.11 on a PowerPC machine. When I launch the new jdownloader, it gives the following error message:

"Could not launch the application because it requires a version of Java that is not installed. The application requires Java 1.6 or later, but only the following Java versions are installed: 1.5.0, 1.4.2, 1.3.1, 1.5, 1.3, 1.4. Updating to a newer version of MacOS X may resolve this."

However, it seems that Java 1.6 is not available for PowerPC Macs:
**External links are only visible to Support Staff****External links are only visible to Support Staff**
Quote:
06/15/2009, 4:50pm, EDT

Apple posts Java updates for Leopard, Tiger

Apple has has posted two new Java update patches, targeting Mac OS X Leopard and Tiger, respectively. The Leopard patch, Update 4, is said to improve the "reliability, security and compatibility" of Java by updating Java SE 6 to 1.6.0_13, J2SE 5.0 to 1.5.0_19, and J2SE 1.4.2 to 1.4.2_21. Mac OS X 10.5.7 is required, and Java SE 6 is only functional on Intel Macs, due to particular 64-bit code. The file is 158MB.

The 80.11MB Tiger patch is labeled Release 9, but offers similar fixes. J2SE 5.0 is upgraded to v1.5.0_19, while J2SE 1.4.2 migrates to v1.4.2_21. With either of the new Java distributions, Apple warns that all web browsers must be closed before installation.
So is this the end of the line for Jdownloader for PowerPC Mac owners? If so, it merits its own thread in the forum, I think.

What is the last version of jdownloader that will run on a PowerPC G4 Mac running MacOS 10.4.11, and where can it be downloaded?
  #5  
Old 27.06.2009, 03:25
Jiaz's Avatar
Jiaz Jiaz is offline
JD Manager
 
Join Date: Mar 2009
Location: Germany
Posts: 67,205
Default

we do our best to make/keep jd java 1.5 compatible. we only have 2 mac developers so its not easy to find all 1.5 bugs..will inform you when a fixed version is ready

meanwhile you could try the openjdk port for mac...it is java 1.6 compatible..maybe with this you can start jd in 1.6 mode?
__________________
JD-Dev & Server-Admin
  #6  
Old 27.06.2009, 11:22
rotz
Guest
 
Posts: n/a
Default

Thank you for the suggestion. I checked into it, and it only works on Intel Macs:

**External links are only visible to Support Staff****External links are only visible to Support Staff**

PowerPC Macs are still common so I hope that it will be possible to use jdownloader again soon on them. In the meantime, can you please link to the last working version of jdownloader for java 1.5? Thanks.
  #7  
Old 02.07.2009, 21:43
luvdatsol
Guest
 
Posts: n/a
Default

Yes. Please post downloader that works with MAC PPC OS 10.4.11.

THNX!
  #8  
Old 03.07.2009, 16:42
biff
Guest
 
Posts: n/a
Default

AFAIK this isn't a PPC vs Intel issue, it's a 10.4 Tiger vs 10.5 Leopard issue, or more specifically the Java VM versions that Apple include with those OSX versions:

10.4 Tiger includes Java 1.5 - there is no Apple supplied Java 1.6 update for 10.4 Tiger
10.5 Leopard includes Java 1.6

I've got an older version of JDownloader (0.5.949) on an Intel MacBookPro OSX 10.4.11 - works fine i.e. under Java 1.5 - but just downloaded the latest 0.6.193 version and it won't run on a PPC Mac 10.4.11 - get the same error message as rotz posted i.e that JD 0.6.193 now requires Java 1.6.

The download page says: "JDownloader requires Java Runtime Enviroment (jre/jdk) 1.5 or higher. If possible, you should use the latest Java version." which appears to be wrong for the latest version of JDownloader.

JDownloader Devs - Please, please, please make the latest version of JD Java 1.5 compatible if that's possible. That should mean it'll run under Mac OSX 10.4.x Tiger (PPC or Intel) as earlier versions of JD have done.

The other option is for Mac users to upgrade to OSX 10.5 Leopard to get Java 1.6, but that won't be an option for some, me included.
  #9  
Old 04.07.2009, 00:21
xcuneytx
Guest
 
Posts: n/a
Default

Does anyone have an older version that works on PPC Tiger.. Please help me out.. I need it very bad..
  #10  
Old 05.07.2009, 10:22
remi
Guest
 
Posts: n/a
Cool

Please, read http://board.jdownloader.org/showthread.php?t=4696
  #11  
Old 08.07.2009, 20:09
rotz
Guest
 
Posts: n/a
Default

Quote:
Originally Posted by biff View Post
AFAIK this isn't a PPC vs Intel issue, it's a 10.4 Tiger vs 10.5 Leopard issue, or more specifically the Java VM versions that Apple include with those OSX versions:

10.4 Tiger includes Java 1.5 - there is no Apple supplied Java 1.6 update for 10.4 Tiger
10.5 Leopard includes Java 1.6

I've got an older version of JDownloader (0.5.949) on an Intel MacBookPro OSX 10.4.11 - works fine i.e. under Java 1.5 - but just downloaded the latest 0.6.193 version and it won't run on a PPC Mac 10.4.11 - get the same error message as rotz posted i.e that JD 0.6.193 now requires Java 1.6.

The download page says: "JDownloader requires Java Runtime Enviroment (jre/jdk) 1.5 or higher. If possible, you should use the latest Java version." which appears to be wrong for the latest version of JDownloader.

JDownloader Devs - Please, please, please make the latest version of JD Java 1.5 compatible if that's possible. That should mean it'll run under Mac OSX 10.4.x Tiger (PPC or Intel) as earlier versions of JD have done.

The other option is for Mac users to upgrade to OSX 10.5 Leopard to get Java 1.6, but that won't be an option for some, me included.
Actually it is a PPC vs Intel issue. See **External links are only visible to Support Staff****External links are only visible to Support Staff**. Quoting Apple: "Java SE 6 is available on 64-bit, Intel-based Macs only." So even if you are running MacOS 10.5, if it's on PPC then you can't run java 1.6, which means you can't run the latest version of jdownloader.
  #12  
Old 09.07.2009, 16:22
biff
Guest
 
Posts: n/a
Default

Quote:
Originally Posted by rotz View Post
Actually it is a PPC vs Intel issue. See **External links are only visible to Support Staff****External links are only visible to Support Staff**. Quoting Apple: "Java SE 6 is available on 64-bit, Intel-based Macs only." So even if you are running MacOS 10.5, if it's on PPC then you can't run java 1.6, which means you can't run the latest version of jdownloader.
OK, I stand corrected - was half right tho'.

I'm still on 10.4.11 so knew Java 1.6 wasn't available for that, but thought it was for all 10.5 installs instead of being Intel only.
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

All times are GMT +2. The time now is 23:51.
Provided By AppWork GmbH | Privacy | Imprint
Parts of the Design are used from Kirsch designed by Andrew & Austin
Powered by vBulletin® Version 3.8.10 Beta 1
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.