JDownloader Community - Appwork GmbH
 

Reply
 
Thread Tools Display Modes
  #1  
Old 03.01.2022, 14:44
Temaps Temaps is offline
Modem User
 
Join Date: Sep 2021
Posts: 3
Default Can't use extraction (manually or automatically) if not admin

Hello,

I have a problem, I'm using linux mint and have installed JD with the script available on the website. It has created a shortcut : /bin/sh "/opt/jd2/JDownloader2".

If I run it, everything related to the extraction is either not here or grayed. The "tools" on top is grayed and in Parameters the extraction sub-menu is not here at all (really it just does not appears).

If I run the same command with sudo, everything is fine.

Someone got an idea ? I'd like to run JD as admin but I've read somewhere from someone that has the blue "admin" under the name that JD should not be run as admin.

edit : It's not admin but JD manager maybe... Anyway not important it was someone maybe linked to the team

The linux mint is freshly installed from yesterday (or the day before maybe)

Thanks

Edit 2 : Oh and for the bugreport, if I try to make a bugreport (without root) I can select the date/hour then click on continue and nothing happens. Have not tried using sudo.

Last edited by Temaps; 03.01.2022 at 15:46.
Reply With Quote
  #2  
Old 04.01.2022, 11:20
Jiaz's Avatar
Jiaz Jiaz is offline
JD Manager
 
Join Date: Mar 2009
Location: Germany
Posts: 76,252
Default

@Temaps: Do not install/run JDownloader as root if not required. Most likely you have installed it as root and now fails when you want to run as normal user.
Either fix the permissions/ownerhsip manually, eg
Quote:
sudo chown -R user:group /opt/jd2
and replace user and group
or remove and install normal/without root
__________________
JD-Dev & Server-Admin
Reply With Quote
  #3  
Old 04.01.2022, 14:46
Temaps Temaps is offline
Modem User
 
Join Date: Sep 2021
Posts: 3
Default

Solved, how dumb I am... this is why it was in the opt folder...

Everything written by Jiaz is right, I'm sure I've run the installer with sudo (what a mistake)

So basically for those who will have the same problem :
- Go to the folder where JD is installed (opt folder for me)
- Run the uninstaller as root (to remove everything) : sudo ./Uninstall\ JDownloader
- I had to remove manually the JD folder in opt (the uninstaller told me it was impossible for some reason probably permissions again)
- I had to remove manually the shortcut in the "start" menu.
- The installer did not put any shortcut on the desktop (even if I had chosen the option) then nothing to remove on the desktop for me
- Download the installer
- Run it. Be careful, if you run it as ./JD2Setup_x64.sh you might not have the permission, you might need to run it with /bin/sh ./JD2Setup_x64.sh
- Everything seems to work fine for now (haven't tried to download or extract yet but everything appears on the screen) except that I don't have the shortcut in the desktop again (even if I checked the option), don't know why but I made it myself.

Kinda impressed by the knowledge of Jiaz I have to admit...

Could it be possible to add a big warning for linux beginners at the beginning of the install like "You should not run this script as root, run it with /bin/sh" (to adapt of course).

Anyway thanks
Reply With Quote
  #4  
Old 04.01.2022, 15:51
Jiaz's Avatar
Jiaz Jiaz is offline
JD Manager
 
Join Date: Mar 2009
Location: Germany
Posts: 76,252
Default

@Temaps: Thanks for the feedback!
__________________
JD-Dev & Server-Admin
Reply With Quote
  #5  
Old 04.01.2022, 15:52
Jiaz's Avatar
Jiaz Jiaz is offline
JD Manager
 
Join Date: Mar 2009
Location: Germany
Posts: 76,252
Default

Quote:
Originally Posted by Temaps View Post
- Run it. Be careful, if you run it as ./JD2Setup_x64.sh you might not have the permission, you might need to run it with /bin/sh ./JD2Setup_x64.sh
You can either rightclick and set the executable permission or
use
Quote:
chmod +x JD2Setup_x64.sh
to set the executable permission
__________________
JD-Dev & Server-Admin
Reply With Quote
  #6  
Old 04.01.2022, 15:55
Jiaz's Avatar
Jiaz Jiaz is offline
JD Manager
 
Join Date: Mar 2009
Location: Germany
Posts: 76,252
Default

Quote:
Originally Posted by Temaps View Post
Could it be possible to add a big warning for linux beginners at the beginning of the install like "You should not run this script as root, run it with /bin/sh" (to adapt of course).
Very good idea! We will add such warning for the next version of installers we build!
__________________
JD-Dev & Server-Admin
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

All times are GMT +2. The time now is 13:16.
Provided By AppWork GmbH | Privacy | Imprint
Parts of the Design are used from Kirsch designed by Andrew & Austin
Powered by vBulletin® Version 3.8.10 Beta 1
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.