JDownloader Community - Appwork GmbH
 

Reply
 
Thread Tools Display Modes
  #4041  
Old 26.11.2020, 10:36
Trilandian Trilandian is offline
JD Fan
 
Join Date: Jan 2011
Posts: 72
Default

Same problem here.
Oddly enough, I tried it several times, and on one of those times it did grab the video name properly, as though during that moment, whatever the problem was went away, but right after that, it came back again.
Hasn't worked since.
Reply With Quote
  #4042  
Old 26.11.2020, 10:42
Jiaz's Avatar
Jiaz Jiaz is offline
JD Manager
 
Join Date: Mar 2009
Location: Germany
Posts: 70,222
Default

Please provide example links! And whats your geo location? Looks like some changes are getting rolled out slowly
__________________
JD-Dev & Server-Admin

Last edited by Jiaz; 26.11.2020 at 10:48.
Reply With Quote
  #4043  
Old 26.11.2020, 11:02
Trilandian Trilandian is offline
JD Fan
 
Join Date: Jan 2011
Posts: 72
Default

This is the video I grabbed that didn't work, then worked, then didn't: **External links are only visible to Support Staff****External links are only visible to Support Staff**

My location is Israel.
Reply With Quote
  #4044  
Old 26.11.2020, 11:07
Jiaz's Avatar
Jiaz Jiaz is offline
JD Manager
 
Join Date: Mar 2009
Location: Germany
Posts: 70,222
Default

Please create a debug log. Enable Settings->Advanced Settings->Log.debugmodeenabled
restart JDownloader. Do not download anyhing (keeps log small) try to add the link, once it fails to grab title, create log and post logID here, see https://support.jdownloader.org/Know...d-session-logs
__________________
JD-Dev & Server-Admin
Reply With Quote
  #4045  
Old 26.11.2020, 12:44
enjikari enjikari is offline
Vacuum Cleaner
 
Join Date: Feb 2018
Posts: 18
Default

Quote:
Originally Posted by Jiaz View Post
@mlp: please provide example links, no changes from our side
Here are 5 examples, but I ran down a list of subscriptions and tried several more (most of which I had already downloaded just an hour or so before my post):

**External links are only visible to Support Staff****External links are only visible to Support Staff**
**External links are only visible to Support Staff****External links are only visible to Support Staff**
**External links are only visible to Support Staff****External links are only visible to Support Staff**
**External links are only visible to Support Staff****External links are only visible to Support Staff**
**External links are only visible to Support Staff****External links are only visible to Support Staff**



So the "video title"(?) of the uploaded video is missing from YouTube videos in JD2. Hope this helps.

Last edited by Jiaz; 26.11.2020 at 18:26.
Reply With Quote
  #4046  
Old 26.11.2020, 12:55
Jiaz's Avatar
Jiaz Jiaz is offline
JD Manager
 
Join Date: Mar 2009
Location: Germany
Posts: 70,222
Default

Quote:
Originally Posted by Jiaz View Post
Please create a debug log. Enable Settings->Advanced Settings->Log.debugmodeenabled
restart JDownloader. Do not download anyhing (keeps log small) try to add the link, once it fails to grab title, create log and post logID here, see https://support.jdownloader.org/Know...d-session-logs
Please create logs like described, still unable to reproduce the issue
__________________
JD-Dev & Server-Admin
Reply With Quote
  #4047  
Old 26.11.2020, 12:55
Trilandian Trilandian is offline
JD Fan
 
Join Date: Jan 2011
Posts: 72
Default

It actually succeeded again in grabbing that video, along with another it wouldn't grab before, but it still doesn't work everywhere.

Log: 26.11.20 13.53.11 <--> 26.11.20 13.54.33 jdlog://0847425302851/
Reply With Quote
  #4048  
Old 26.11.2020, 13:04
enjikari enjikari is offline
Vacuum Cleaner
 
Join Date: Feb 2018
Posts: 18
Default

Quote:
Originally Posted by Jiaz View Post
Please create logs like described, still unable to reproduce the issue
26.11.20 06.01.59 <--> 26.11.20 06.02.44 jdlog://4847425302851/
Reply With Quote
  #4049  
Old 26.11.2020, 16:33
BillyCool BillyCool is offline
Junior Loader
 
Join Date: Sep 2016
Location: Australia
Posts: 13
Default

Just want to add that I'm experiencing the issue with missing filenames as well. From experience, this is not a new thing but now it happens the majority of the time. The issue appears to be with the pre-defined variables.

Example link: **External links are only visible to Support Staff****External links are only visible to Support Staff**

Some more info that might prove useful. I have an event script that automatically queries and downloads youtube videos using the JD API. For the past few weeks, I noticed that some links would randomly come through without a name. I tried to correct the issue myself by updating the name manually, but I then noticed that a lot of the time, that didn't work either, making me believe this is an issue with JD and not the plugin.

My filename format in the plugin is set to:
Code:
*CHANNELNAME* - *DATE[yyyy-MM-dd]* - *VIDEO_NAME*.*EXT*
And my filenames would sometimes come out as:
Code:
- -
As you can tell, the variables resolved to empty string.

These are 2 functions I wrote in my script to try and work around the issue:
Code:
function getNameSafe(link) {
    var newName = link.getName();
    var count = 0;

    // Try to avoid JD bug
    while (newName == "-  - " && count < 100) {
        newName = link.getName();
        count++;
    }

    return newName;
}

function setNameSafe(link, newName) {
    var count = 0;

    // Try to avoid JD bug
    while (getNameSafe(link) != newName && count < 100) {
        link.setName(newName);
        count++;
    }

    return newName;
}
The idea was to try up to 100 times to get/set the name correctly. But, teven this didn't work and my logs were very confusing. Here is another snippet of my script that is responsible for this renaming:

Code:
var newName = getNameSafe(crawledLink);
log("Setting new name to: " + newName);
setNameSafe(existingLinkByUrl, newName);
log("Done, name set to: " + existingLinkByUrl.getName());
The logs from that snippet made no sense sometimes, here's a recent one:
Code:
Setting new name to: vTuned garage - 2020-11-23 - Stripping the Interior on my McLaren 720s - Episode 6.mkv
Done, name set to: -  - .mkv
As you can see, the getNameSafe() function correctly got the proper filename but setNameSafe() failed to set it properly. I have also seen the reverse happen. These functions use the standard event scripter functions, so shouldn't be affected by the Youtube plugin itself. This is what led me to believe the bug was somewhere else.

Hope this helps, happy to provide any more info if needed.
Reply With Quote
  #4050  
Old 26.11.2020, 17:23
enjikari enjikari is offline
Vacuum Cleaner
 
Join Date: Feb 2018
Posts: 18
Default

Quote:
Originally Posted by enjikari View Post
26.11.20 06.01.59 <--> 26.11.20 06.02.44 jdlog://4847425302851/
Update:

Just tried grabbing about 10 YT videos, 5 or which I had the no-name issue with last night. All names are present now. Hopefully this was a one-off issue. I'll keep at it with different/new videos today and tomorrow. If the issue returns I'll reply in this thread.
Reply With Quote
  #4051  
Old 26.11.2020, 18:05
Jiaz's Avatar
Jiaz Jiaz is offline
JD Manager
 
Join Date: Mar 2009
Location: Germany
Posts: 70,222
Default

@All: Found the issue for missing title/xy and will be fixed with next update.
unfortunately I'm not finished with the changes yet so the update will be released by tomorrow. sorry for the delay
__________________
JD-Dev & Server-Admin

Last edited by Jiaz; 26.11.2020 at 18:26.
Reply With Quote
  #4052  
Old 26.11.2020, 18:10
enjikari enjikari is offline
Vacuum Cleaner
 
Join Date: Feb 2018
Posts: 18
Default

Quote:
Originally Posted by Jiaz View Post
Found the issue and will be fixed with next update. unfortunately I'm not finished with the changes yet so the update will be released by tomorrow
Understood, and thanks.

Was just about to post that I spoke too soon - tried to grand 2 new videos, but they grabbed with no names as well.

Glad a fix is coming. Thanks again for looking into it.
Reply With Quote
  #4053  
Old 26.11.2020, 18:24
Jiaz's Avatar
Jiaz Jiaz is offline
JD Manager
 
Join Date: Mar 2009
Location: Germany
Posts: 70,222
Default

Fix will come tomorrow morning, sorry for the delay :(
__________________
JD-Dev & Server-Admin
Reply With Quote
  #4054  
Old 26.11.2020, 19:59
rapido rapido is offline
JD Beta
 
Join Date: Aug 2009
Posts: 58
Angry Linksammler spinnt

Was habe ich falsch gemacht und wie kann ich das Problem lösen? Herzlichen Dank vorab!

Last edited by Jiaz; 26.11.2020 at 20:35.
Reply With Quote
  #4055  
Old 26.11.2020, 20:35
Jiaz's Avatar
Jiaz Jiaz is offline
JD Manager
 
Join Date: Mar 2009
Location: Germany
Posts: 70,222
Default

Siehe https://board.jdownloader.org/showpo...postcount=4051
Update kommt morgen im Laufe des Vormittags
__________________
JD-Dev & Server-Admin
Reply With Quote
  #4056  
Old 26.11.2020, 20:48
rapido rapido is offline
JD Beta
 
Join Date: Aug 2009
Posts: 58
Default

@Jiaz
Wie gut dass Du imstande bist alles zu fixen.
Herzlichen Dank!!!
Reply With Quote
  #4057  
Old 26.11.2020, 23:30
mz168 mz168 is offline
JD Alpha
 
Join Date: May 2019
Posts: 21
Default Title Tag Missing

Not seeing this being reported but it has gone on sporadically for a while and about yesterday it becomes completely wild.

This used to work:
1. *USER*-*CHANNEL*-*PLAYLIST_NAME*
2. *CHANNEL*_*DATE[yyyy/MM/dd]*_*TITLE* (*QUALITY*, *Duration[minutes]*).*EXT*

Now
1. *USER* still works
2. Now I get a bunch of these "__ (720p 30fps, ).mp4"

The tags aren't picked up. Either the tags handle changed? or JD failed to grab or pass the data???

It's incredibly hard to clean up a bunch of past grabbed links. This is pretty much a show stopper. Pls advice.

Last edited by Jiaz; 27.11.2020 at 10:17.
Reply With Quote
  #4058  
Old 27.11.2020, 02:29
Trilandian Trilandian is offline
JD Fan
 
Join Date: Jan 2011
Posts: 72
Default

Glad you have it figured out.
Less than a day is hardly a delay, so no worries.
Reply With Quote
  #4059  
Old 27.11.2020, 10:17
Jiaz's Avatar
Jiaz Jiaz is offline
JD Manager
 
Join Date: Mar 2009
Location: Germany
Posts: 70,222
Default

see https://board.jdownloader.org/showpo...postcount=4051
__________________
JD-Dev & Server-Admin
Reply With Quote
  #4060  
Old 27.11.2020, 19:51
maurigalarza maurigalarza is offline
DSL User
 
Join Date: Aug 2014
Posts: 35
Default

Quote:
Originally Posted by Jiaz View Post
Fix will come tomorrow morning, sorry for the delay :(
SOLVED!!!!! THANKS A LOT.-
:thumbup:
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

All times are GMT +2. The time now is 12:55.
Provided By AppWork GmbH | Privacy | Imprint
Parts of the Design are used from Kirsch designed by Andrew & Austin
Powered by vBulletin® Version 3.8.10 Beta 1
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.