JDownloader Community - Appwork GmbH
 

Reply
 
Thread Tools Display Modes
  #1  
Old 23.02.2016, 16:39
Kino Kino is offline
Fibre Channel User
 
Join Date: Nov 2010
Posts: 116
Default A question about Packager Rules.

I wish to make something in package naming. However there is something that I can not understand.

For testing purpose, I wish to rename a sample package as "TEST"
As a first case, if original package name includes "-"
For second case, if original package name not includes "-"

For the first case, I created a rule like this: (see rule1.png)
For the second case, I modified rule like this: (see rule2.png)

But for both case JD reacts same and renames the package.

I tried to generate a rule with "contains not" "-", but again in any case package is renamed.

This is the link in which package name contains "-" in it. I used this as sample.
**External links are only visible to Support Staff****External links are only visible to Support Staff**

Could you please have a look?

Thanks.
Attached Images
File Type: png rule1.png (43.3 KB, 62 views)
File Type: png rule2.png (46.5 KB, 59 views)
Reply With Quote
  #2  
Old 23.02.2016, 18:26
Jiaz's Avatar
Jiaz Jiaz is offline
JD Manager
 
Join Date: Mar 2009
Location: Germany
Posts: 66,134
Default

Will check and provide feedback tomorrow
__________________
JD-Dev & Server-Admin
Reply With Quote
  #3  
Old 25.02.2016, 13:44
Jiaz's Avatar
Jiaz Jiaz is offline
JD Manager
 
Join Date: Mar 2009
Location: Germany
Posts: 66,134
Default

Your second rule is identical to first rule. Both times it is *Packagename contains" ?!
__________________
JD-Dev & Server-Admin
Reply With Quote
  #4  
Old 25.02.2016, 14:10
Kino Kino is offline
Fibre Channel User
 
Join Date: Nov 2010
Posts: 116
Default

If you look at second attached picture you will see red arrow showing what I changed.
If this rule is active. Package always renamed, regardless of that packagename condition is satisfied or not.
Reply With Quote
  #5  
Old 25.02.2016, 14:41
Jiaz's Avatar
Jiaz Jiaz is offline
JD Manager
 
Join Date: Mar 2009
Location: Germany
Posts: 66,134
Default

Yes,and that is exactly what the rules says. It will match ALWAYS
If you want to no match then simply use *contains not*
__________________
JD-Dev & Server-Admin
Reply With Quote
  #6  
Old 25.02.2016, 18:50
Kino Kino is offline
Fibre Channel User
 
Join Date: Nov 2010
Posts: 116
Default Actually No!

There is something wrong.
Here is a reference link.
**External links are only visible to Support Staff****External links are only visible to Support Staff**

this is the rule: see a_rule_trial_1.png
preview is correct: preview_correct.png
but result is wrong: result_wrong.png

Could you please review this?
Attached Images
File Type: png a_rule_trial_1.png (45.0 KB, 51 views)
File Type: png preview_correct.png (30.8 KB, 58 views)
File Type: png result_wrong.png (48.6 KB, 49 views)
Reply With Quote
  #7  
Old 26.02.2016, 10:34
Jiaz's Avatar
Jiaz Jiaz is offline
JD Manager
 
Join Date: Mar 2009
Location: Germany
Posts: 66,134
Default

I cannot reproduce the Issue.Works fine for me. Do you have any other rule active? Maybe export all your rules and send to support@jdownloader.org ?
__________________
JD-Dev & Server-Admin
Reply With Quote
  #8  
Old 26.02.2016, 14:45
Kino Kino is offline
Fibre Channel User
 
Join Date: Nov 2010
Posts: 116
Default

OK then,
I create the rule which is attached, and make it active.

I copy this link into clipboard:
**External links are only visible to Support Staff****External links are only visible to Support Staff**

packagename is "Natalia Veshtiz"
There is no "-" character in it. Therefore rule should ignore this package.
But rule adds "test" string in front of package.

Actually rule preview (the play button) shows correct: No "text" string in packagename.
However, the result package includes "test" string which should not appear per rule.
Attached Files
File Type: zip pack_test.zip (599 Bytes, 25 views)
Reply With Quote
  #9  
Old 26.02.2016, 15:00
Jiaz's Avatar
Jiaz Jiaz is offline
JD Manager
 
Join Date: Mar 2009
Location: Germany
Posts: 66,134
Default

Cannot reproduce the issue. How do you add the link?
Copy/Clipboard, Copy/Paste, AddLinks Dialog?
__________________
JD-Dev & Server-Admin
Reply With Quote
  #10  
Old 26.02.2016, 15:07
Kino Kino is offline
Fibre Channel User
 
Join Date: Nov 2010
Posts: 116
Default

Copy/Clipboard

At the end is your packagename "Natalia Veshtiz" or "test Natalia Veshtiz"?
Reply With Quote
  #11  
Old 26.02.2016, 15:11
Jiaz's Avatar
Jiaz Jiaz is offline
JD Manager
 
Join Date: Mar 2009
Location: Germany
Posts: 66,134
Default

"Natalia Veshtiz"
I can offer you help via Teamviewer and we can check together?
__________________
JD-Dev & Server-Admin
Reply With Quote
  #12  
Old 26.02.2016, 15:26
Kino Kino is offline
Fibre Channel User
 
Join Date: Nov 2010
Posts: 116
Default

team viever is not possible I'm afraid.
Could you please guide me or advice in here?
Reply With Quote
  #13  
Old 26.02.2016, 16:09
Jiaz's Avatar
Jiaz Jiaz is offline
JD Manager
 
Join Date: Mar 2009
Location: Germany
Posts: 66,134
Default

Remove all Packagizer rules, then add the rule you send me and try again
so that your rule is the only active one (the default ones can be enabled too)
__________________
JD-Dev & Server-Admin
Reply With Quote
  #14  
Old 26.02.2016, 19:41
Kino Kino is offline
Fibre Channel User
 
Join Date: Nov 2010
Posts: 116
Default

I made another trial. I tried to show it in single picture. Please see 001.png.
Problem goes on.
Attached Images
File Type: png 001.png (206.6 KB, 46 views)
Reply With Quote
  #15  
Old 26.02.2016, 19:48
Jiaz's Avatar
Jiaz Jiaz is offline
JD Manager
 
Join Date: Mar 2009
Location: Germany
Posts: 66,134
Default

Okay, now I know what was wrong. You have disabled the linkcheck in Advanced Settings, right?
__________________
JD-Dev & Server-Admin
Reply With Quote
  #16  
Old 26.02.2016, 19:49
Jiaz's Avatar
Jiaz Jiaz is offline
JD Manager
 
Join Date: Mar 2009
Location: Germany
Posts: 66,134
Default

Will be fixed with next core update (or you enable Linkcheck)
__________________
JD-Dev & Server-Admin
Reply With Quote
  #17  
Old 26.02.2016, 20:00
Kino Kino is offline
Fibre Channel User
 
Join Date: Nov 2010
Posts: 116
Default

Dear Jiaz, you're great. Yes that's exactly what I did.:biggrin:

I prefer link check disabled. So I will wait for next update.
Thanks and thanks.:thumbup:
Reply With Quote
  #18  
Old 26.02.2016, 20:05
Jiaz's Avatar
Jiaz Jiaz is offline
JD Manager
 
Join Date: Mar 2009
Location: Germany
Posts: 66,134
Default

Nothing to thank me for, Thanks for the bugreport
MAybe update will come out tomorrow. I will inform you here
__________________
JD-Dev & Server-Admin
Reply With Quote
  #19  
Old 28.02.2016, 02:23
Kino Kino is offline
Fibre Channel User
 
Join Date: Nov 2010
Posts: 116
Default

Works perfect!
Thanks.
Reply With Quote
  #20  
Old 28.02.2016, 09:40
Jiaz's Avatar
Jiaz Jiaz is offline
JD Manager
 
Join Date: Mar 2009
Location: Germany
Posts: 66,134
Default

Thanks for the feedback!
__________________
JD-Dev & Server-Admin
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

All times are GMT +2. The time now is 11:46.
Provided By AppWork GmbH | Privacy | Imprint
Parts of the Design are used from Kirsch designed by Andrew & Austin
Powered by vBulletin® Version 3.8.10 Beta 1
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.