JDownloader Community - Appwork GmbH
 

Reply
 
Thread Tools Display Modes
  #1  
Old 09.03.2010, 05:06
sml
Guest
 
Posts: n/a
Post decryptor out of date: google books

after new update i get error decryptor out of date

my log:
Spoiler:

------------------------ Thread: 33 -----------------------
33 9/3/10 8:23:22 AM - INFO [java_downloader] -> Start new Download: books.google.com

------------------------ Thread: 55 -----------------------
55 9/3/10 8:23:22 AM - INFO [java_downloader] -> Start working on PA0001
55 9/3/10 8:23:32 AM - WARNING [java_downloader] -> Resumepoint not valid
55 9/3/10 8:23:32 AM - FINER [java_downloader] -> Connect...
55 9/3/10 8:23:34 AM - FINEST [java_downloader] -> Hoster Plugin Version: 10436
EXCEPTION 55 9/3/10 8:23:34 AM - SEVERE [java_downloader] -> SEVERE Exception occurred
java.lang.StringIndexOutOfBoundsException: String index out of range: -1
at java.lang.String.substring(Unknown Source)
at java.lang.String.substring(Unknown Source)
at jd.plugins.hoster.GoogleBooks.handleFree(GoogleBooks.java:81)
at jd.plugins.PluginForHost.handle(Unknown Source)
at jd.controlling.SingleDownloadController.handlePlugin(Unknown Source)
at jd.controlling.SingleDownloadController.run(Unknown Source)
55 9/3/10 8:23:34 AM - WARNING [java_downloader] ->
Error occured- latest: ERROR_PLUGIN_DEFECT
00100000010001000000000000000001 <Statuscode
00000000000000000000000000000001 |TODO
00000000000001000000000000000000 |PLUGIN_IN_PROGRESS
00000000010000000000000000000000 |ERROR_PLUGIN_DEFECT
00100000000000000000000000000000 |PLUGIN_ACTIVE
StatusText: Download
ErrorMessage: Error:String Index Out Of Bounds: String index out of range: -1

55 9/3/10 8:23:34 AM - WARNING [java_downloader] -> The Plugin for books.google.com seems to be out of date(rev10436). Please inform the Support-team http://jdownloader.org/support.
55 9/3/10 8:23:34 AM - WARNING [java_downloader] -> Error:String Index Out Of Bounds: String index out of range: -1
55 9/3/10 8:23:34 AM - FINEST [java_downloader] -> -->http://books.google.com/books?id=-6Z...eDoJIWuA&w=685
----------------Request------------------
GET /books?id=-6ZV3j65FFAC&pg=PA1&img=1&zoom=3&hl=de&sig=ACfU3U0SHY6t0WwNynr2NOo3oCeDoJIWuA&w=685 HTTP/1.1
Accept-Language: de, en-gb;q=0.9, en;q=0.8
Cookie: PREF=ID=19f286688b2b3942:TM=1268103208:LM=1268103209:S=YfwYHe9CKuYq9dU6
Host: books.google.com
Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7
Referer: http://books.google.com/books?id=-6ZV3j65FFAC&pg=PA1
Accept-Encoding:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en; rv:1.8) Gecko/19950508 Firefox/1.5
Connection: close
Accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
Pragma: no-cache
Cache-Control: no-cache

----------------Response------------------
HTTP/1.1 200 OK
Date: Tue, 09 Mar 2010 02:53:38 GMT
Content-Length: 42543
Expires: Tue, 09 Mar 2010 02:53:38 GMT
X-XSS-Protection: 0
Content-Type: image/png
Connection: close
Server: OFE/0.1
Cache-Control: private, max-age=86400
X-Content-Type-Options: nosniff


55 9/3/10 8:23:34 AM - FINEST [java_downloader] -> No htmlCode read


link:
http://books.google.com/books?id=-6Z...age&q=&f=false

jdownloader 0.9.579

java 6.0

Last edited by Jiaz; 23.06.2010 at 12:45.
Reply With Quote
  #2  
Old 09.03.2010, 05:45
drbits's Avatar
drbits drbits is offline
JD English Support (inactive)
 
Join Date: Sep 2009
Location: Physically in Los Angeles, CA, USA
Posts: 4,437
Default

Please restart JDownloader two times.

Please upload a log, following the instructions linked to in my signature. That will include OS details and Java details.

We need to check on the actual versions of things. For example, if you are using Windows "7" you should search for "java w7" in the board. There is an important OS patch to install.

You didn't really tell us the Java version. Because of bugs at both Microsoft and Sun, the best Java version to use is 32 bit 1.6.0_17. (the newest version, 18 crashes a lot). If you search the board for x7.to and Java you will find a link to easily download this version (it is available on the Sun site, but it is hidden).

Then, please try several links and let us know which work and which do not work.
__________________
Please, in each Forum, Read the Rules!.Helpful Links. Read before posting.
Reply With Quote
  #3  
Old 09.03.2010, 09:43
linxus
Guest
 
Posts: n/a
Default indeed; plugin out of date

I don't update the JD and I find this error, yesterday; then, I updated it thinking will be ok; the same situation. And I didn't change anything else on the conf. of my PC in the last month.
Reply With Quote
  #4  
Old 09.03.2010, 09:46
sml
Guest
 
Posts: n/a
Post

upload link is:
http://jdownloader.org/pastebin/7716...9b93acf782a6a6
i've found no working google book link!!
thx
Reply With Quote
  #5  
Old 09.03.2010, 12:24
remi
Guest
 
Posts: n/a
Default

Does it work now? Did you read drbit's post?
Reply With Quote
  #6  
Old 09.03.2010, 15:15
linxus
Guest
 
Posts: n/a
Default

I just try it again; still not function; I have XP and had java 32 bit 1.6.0_15; until 2 days ago it worked; now Iinstall 32 bit 1.6.0_17 but still doesn't work. I also reinstall JD and make all the updates.
Reply With Quote
  #7  
Old 09.03.2010, 15:45
pspzockerscene's Avatar
pspzockerscene pspzockerscene is online now
Community Manager
 
Join Date: Mar 2009
Location: Deutschland
Posts: 48,696
Default

Bugtracker ticket

GreeZ pspzockerscene
__________________

Ad-free installers || Werbefreie Installer
Windows Setup<--JD2 BETA-->Linux Setup x86 || Linux Setup x64 || Mac Setup
-----=>Support Chat<=-----
Spoiler:

A users' JD crashes and the first thing to ask is:
Quote:
Originally Posted by Jiaz View Post
Do you have Nero installed?
That's true James
Quote:
Originally Posted by James
Die Leute verstehen einfach nicht dass nur weil man mit einer Waffe auch auf Menschen schießen kann dass ein Schützenver​ein kein Ort für Amoklaufide​en ist
Reply With Quote
  #8  
Old 10.03.2010, 04:01
sml
Guest
 
Posts: n/a
Default

installed java 1.6.0_17 but get same error. my os is vista.
thx
Reply With Quote
  #9  
Old 11.03.2010, 12:12
remi
Guest
 
Posts: n/a
Default

Please, read Psp's bug tracker ticket.
Reply With Quote
  #10  
Old 11.03.2010, 12:16
pspzockerscene's Avatar
pspzockerscene pspzockerscene is online now
Community Manager
 
Join Date: Mar 2009
Location: Deutschland
Posts: 48,696
Default

@sml
Other java versions won't help.
The plugin is broken so you gotta wait till someone fixes it and releases it as an update!

GreeZ pspzockerscene
__________________

Ad-free installers || Werbefreie Installer
Windows Setup<--JD2 BETA-->Linux Setup x86 || Linux Setup x64 || Mac Setup
-----=>Support Chat<=-----
Spoiler:

A users' JD crashes and the first thing to ask is:
Quote:
Originally Posted by Jiaz View Post
Do you have Nero installed?
That's true James
Quote:
Originally Posted by James
Die Leute verstehen einfach nicht dass nur weil man mit einer Waffe auch auf Menschen schießen kann dass ein Schützenver​ein kein Ort für Amoklaufide​en ist
Reply With Quote
  #11  
Old 12.04.2010, 07:01
zerobyte zerobyte is offline
DSL User
 
Join Date: Jan 2010
Posts: 38
Default

hi guys (non-gender-specific),

just giving my support for this one again.

i realize, there are not that many people using this feature since g/b cut out a lot of pages permanently, but i still use it once in a while and find it quite useful.


00h
Reply With Quote
  #12  
Old 12.04.2010, 12:09
remi
Guest
 
Posts: n/a
Default

If you can find someone who can program in java, please let him/her read instructions for potential jD developers.
Reply With Quote
  #13  
Old 12.04.2010, 21:09
pspzockerscene's Avatar
pspzockerscene pspzockerscene is online now
Community Manager
 
Join Date: Mar 2009
Location: Deutschland
Posts: 48,696
Default

Support is there but it's broken and as always this means WAIT till someone fixes it!
We do all this for free...

GreeZ psp
__________________

Ad-free installers || Werbefreie Installer
Windows Setup<--JD2 BETA-->Linux Setup x86 || Linux Setup x64 || Mac Setup
-----=>Support Chat<=-----
Spoiler:

A users' JD crashes and the first thing to ask is:
Quote:
Originally Posted by Jiaz View Post
Do you have Nero installed?
That's true James
Quote:
Originally Posted by James
Die Leute verstehen einfach nicht dass nur weil man mit einer Waffe auch auf Menschen schießen kann dass ein Schützenver​ein kein Ort für Amoklaufide​en ist

Last edited by Think3r; 12.04.2010 at 22:01.
Reply With Quote
  #14  
Old 16.04.2010, 08:29
gloirom
Guest
 
Posts: n/a
Default

in the ticket the status changed to solved but at:
svn://svn.jdownloader.org/jdownloader/trunk/src/jd/plugins/hoster/GoogleBooks.java
(if this is the right one) nothing changed since 21.01.10

the download of books works as before but adding new books desn`t work
Reply With Quote
  #15  
Old 16.04.2010, 10:47
remi
Guest
 
Posts: n/a
Cool

Quote:
Originally Posted by gloirom View Post
in the ticket the status changed to solved
Which ticket are you referring to?

The work on "Bug #1422 - google books broken" has started and %Done = 10%.

BTW, the other link you give isn't valid or the page doesn't exist.
Reply With Quote
  #16  
Old 16.04.2010, 11:26
gloirom
Guest
 
Posts: n/a
Default

ok i missed a thing
the page your link refers to says "Status: Solved"
but it`s because "Resolution: Wont Fix"
Reply With Quote
  #17  
Old 16.04.2010, 12:16
remi
Guest
 
Posts: n/a
Default

Yes, you're right. anybee probably means that the plug-in works for 10%.

You can't download all page of a Gogol book when only a few pages are made available by the author. I think this plug-in will never work if Gogol doesn't make the other pages accessible to the public.
Reply With Quote
  #18  
Old 16.04.2010, 13:38
gloirom
Guest
 
Posts: n/a
Default

it`s still possible to download a whole book with jdownloader, but not at the same day!
probably only the number of pages of the same book is limited per day.
So every day a few pages are working.

Only adding new books isn`t possible anymore...
Reply With Quote
  #19  
Old 17.04.2010, 22:12
MocotoBugutinho
Guest
 
Posts: n/a
Default Google Books plugin error "out-of-date"

I got a plugin error "out-of-date" within google books:

Test link:
http://books.google.com/books?id=krI...page&q&f=false

JDownloader version: 0.9.579

Java version: 1.6.0_18

Log:

------------------------ Thread: 16 -----------------------
16 17/04/10 16:45:53 - INFO [java_downloader] -> DownloadWatchDog: start

------------------------ Thread: 17 -----------------------
17 17/04/10 16:45:53 - INFO [java_downloader] -> Start new Download: books.google.com

------------------------ Thread: 18 -----------------------
18 17/04/10 16:45:53 - INFO [java_downloader] -> Start working on PA0002
18 17/04/10 16:45:53 - WARNING [java_downloader] -> Resumepoint not valid
18 17/04/10 16:45:53 - FINER [java_downloader] -> Connect...
18 17/04/10 16:45:54 - FINEST [java_downloader] -> Hoster Plugin Version: 10436
EXCEPTION 18 17/04/10 16:45:54 - SEVERE [java_downloader] -> SEVERE Exception occurred
java.lang.StringIndexOutOfBoundsException: String index out of range: -1
at java.lang.String.substring(Unknown Source)
at java.lang.String.substring(Unknown Source)
at jd.plugins.hoster.GoogleBooks.handleFree(GoogleBooks.java:81)
at jd.plugins.PluginForHost.handle(Unknown Source)
at jd.controlling.SingleDownloadController.handlePlugin(Unknown Source)
at jd.controlling.SingleDownloadController.run(Unknown Source)
18 17/04/10 16:45:54 - WARNING [java_downloader] ->
Error occured- latest: ERROR_PLUGIN_DEFECT
00100000010001000000000000000001 <Statuscode
00000000000000000000000000000001 |TODO
00000000000001000000000000000000 |PLUGIN_IN_PROGRESS
00000000010000000000000000000000 |ERROR_PLUGIN_DEFECT
00100000000000000000000000000000 |PLUGIN_ACTIVE
StatusText: Download
ErrorMessage: Error:String Index Out Of Bounds: String index out of range: -1

18 17/04/10 16:45:54 - WARNING [java_downloader] -> The Plugin for books.google.com seems to be out of date(rev10436). Please inform the Support-team http://jdownloader.org/support.
18 17/04/10 16:45:54 - WARNING [java_downloader] -> Error:String Index Out Of Bounds: String index out of range: -1
18 17/04/10 16:45:54 - FINEST [java_downloader] -> -->http://books.google.com/books?id=krI...k4KWO52A&w=685
----------------Request------------------
GET /books?id=krIOAAAAQAAJ&pg=PA2&img=1&zoom=3&hl=de&sig=ACfU3U2xk49SUNdj4sw3Fz0ooLk4KWO52A&w=685 HTTP/1.1
Accept-Language: de, en-gb;q=0.9, en;q=0.8
Cookie: PREF=ID=893be4845a4c5aec:TM=1271533549:LM=1271533549:S=KCvKQcyJS2SjNm-5
Host: books.google.com
Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7
Referer: http://books.google.com/books?id=krIOAAAAQAAJ&pg=PA2
Accept-Encoding:
User-Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; .NET CLR 1.0.3705)
Connection: close
Accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
Pragma: no-cache
Cache-Control: no-cache

----------------Response------------------
HTTP/1.1 200 OK
Date: Sat, 17 Apr 2010 19:45:50 GMT
Content-Length: 77527
Expires: Sat, 17 Apr 2010 19:45:50 GMT
Content-Type: image/png
Connection: close
Server: OFE/0.1
Cache-Control: private, max-age=86400
X-Content-Type-Options: nosniff


18 17/04/10 16:45:54 - FINEST [java_downloader] -> No htmlCode read

------------------------ Thread: 17 -----------------------
17 17/04/10 16:45:55 - INFO [java_downloader] -> 4rounds left to start new downloads

------------------------ Thread: 19 -----------------------
19 17/04/10 16:45:55 - SEVERE [java_downloader] -> Webupdater offline or nothing to update

------------------------ Thread: 17 -----------------------
17 17/04/10 16:45:56 - INFO [java_downloader] -> 3rounds left to start new downloads
17 17/04/10 16:45:57 - INFO [java_downloader] -> 2rounds left to start new downloads
17 17/04/10 16:45:58 - INFO [java_downloader] -> 1rounds left to start new downloads
17 17/04/10 16:45:59 - INFO [java_downloader] -> 0rounds left to start new downloads
17 17/04/10 16:45:59 - INFO [java_downloader] -> DownloadWatchDog: stop

------------------------ Thread: 13 -----------------------
13 17/04/10 16:45:59 - INFO [java_downloader] -> Downloads stopped

------------------------ Thread: 20 -----------------------
20 17/04/10 16:46:30 - FINER [java_downloader] -> load plugin: jd.plugins.decrypter.GglBks

------------------------ Thread: 21 -----------------------
21 17/04/10 16:55:44 - INFO [java_downloader] -> ByteBufferController: Used: 0 B Free: 0 B
21 17/04/10 17:05:44 - INFO [java_downloader] -> ByteBufferController: Used: 0 B Free: 0 B
Reply With Quote
  #20  
Old 17.04.2010, 22:25
pspzockerscene's Avatar
pspzockerscene pspzockerscene is online now
Community Manager
 
Join Date: Mar 2009
Location: Deutschland
Posts: 48,696
Default

Merged Google Books Threads again!

GreeZ pspzockerscene
__________________

Ad-free installers || Werbefreie Installer
Windows Setup<--JD2 BETA-->Linux Setup x86 || Linux Setup x64 || Mac Setup
-----=>Support Chat<=-----
Spoiler:

A users' JD crashes and the first thing to ask is:
Quote:
Originally Posted by Jiaz View Post
Do you have Nero installed?
That's true James
Quote:
Originally Posted by James
Die Leute verstehen einfach nicht dass nur weil man mit einer Waffe auch auf Menschen schießen kann dass ein Schützenver​ein kein Ort für Amoklaufide​en ist
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

All times are GMT +2. The time now is 17:29.
Provided By AppWork GmbH | Privacy | Imprint
Parts of the Design are used from Kirsch designed by Andrew & Austin
Powered by vBulletin® Version 3.8.10 Beta 1
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.