JDownloader Community - Appwork GmbH
 

Reply
 
Thread Tools Display Modes
  #81  
Old 26.06.2013, 04:07
Tyler Tyler is offline
JD Legend
 
Join Date: Jul 2010
Posts: 582
Default

So how exactly do i make it so JD doesn't steal focus anymore?
Reply With Quote
  #82  
Old 26.06.2013, 05:06
Lram32's Avatar
Lram32 Lram32 is offline
Spanish Supporter
 
Join Date: Jul 2012
Location: Dark side of the moon
Posts: 9,908
Default

It worked for me:
GraphicalUserInterfaceSettings.mainframepopuptriggerwhennewlinkswereadded = never

and optional:
GraphicalUserInterfaceSettings.taskbarflashenabled = disabled
GraphicalUserInterfaceSettings.focustriggerforcaptchadialogs
Reply With Quote
  #83  
Old 27.06.2013, 23:02
Patr100 Patr100 is offline
JD VIP
 
Join Date: Jan 2010
Posts: 473
Default

I'm still having the same problem, the task bar is flashing but captchas are NOT stealing focus as they used to by default, and I want them to -



GraphicalUserInterfaceSettings.taskbarflashenabled = disabled

GraphicalUserInterfaceSettings.focustriggerforcaptchadialogs s
says "Action that will be performed when link grabbers adds new links"

(The description is not what the command says. One refers to captcvhas , the other to adding links? This is confusing.

Will setting the above enable captchas to steal focus as before?

Last edited by Patr100; 27.06.2013 at 23:18.
Reply With Quote
  #84  
Old 28.06.2013, 03:05
Patr100 Patr100 is offline
JD VIP
 
Join Date: Jan 2010
Posts: 473
Default

The above settings aren't working.
Again I ask
How do I enable captchas so they steal focus?
Reply With Quote
  #85  
Old 12.07.2013, 14:18
cremor cremor is offline
Mega Loader
 
Join Date: Feb 2013
Posts: 60
Default Prevent JDownloader from coming to the foreground after checking links

How do I prevent the JDownloader main window from coming to the foreground after it finished the online checking of all pasted links? That's very annoying

The only relevant settings I could find are:
1. "GraphicalUserInterfaceSettings: Focus Trigger For Captcha Dialogs" is set to "Mainwindow is not in tray". Setting it to "Never" doesn't change anything (except for the captcha dialog of course, but that one isn't my problem).
2. "GraphicalUserInterfaceSettings: Windows Request Focus On Activation" is set to false (default value). Setting it to true doesn't change anything. (Btw, that setting doesn't work, even if set to true the JDownloader main window does not have focus when it is brought to the foreground.)

I'm using Java 1.7.0_25 x86 on Windows 7 x64
Reply With Quote
  #86  
Old 12.07.2013, 15:35
Lram32's Avatar
Lram32 Lram32 is offline
Spanish Supporter
 
Join Date: Jul 2012
Location: Dark side of the moon
Posts: 9,908
Default

Quote:
Originally Posted by cremor View Post
How do I prevent the JDownloader main window from coming to the foreground after it finished the online checking of all pasted links? That's very annoying
Set "Never" in the advanced setting: GraphicalUserInterfaceSettings.mainframepopuptriggerwhennewlinkswereadded
Reply With Quote
  #87  
Old 12.07.2013, 15:39
cremor cremor is offline
Mega Loader
 
Join Date: Feb 2013
Posts: 60
Default

Thanks!
I tried a few different search words but didn't think about "popup"
Reply With Quote
  #88  
Old 26.07.2013, 14:27
the3ye
Guest
 
Posts: n/a
Default

Looks like the options to disable focus are gone in new update.
I can't make JD to stop stealing focus without disabling linkgrabber to be shown after adding links.

There are:
GraphicalUserInterfaceSettings: Linkgrabber Auto Tab Switch (UI)
and
GraphicalUserInterfaceSettings: Switch To Linkgrabber Tab On New Links Added (GUI)

Disabling them = no switching to linkgrabber tab after adding links in background. However, it's not stealing focus anymore.

Both options on + "(...)&steal the focus" in "User Interface" options make linkgrabber to show without stealing focus...weird.

Last edited by the3ye; 26.07.2013 at 14:33.
Reply With Quote
  #89  
Old 26.07.2013, 15:25
Lram32's Avatar
Lram32 Lram32 is offline
Spanish Supporter
 
Join Date: Jul 2012
Location: Dark side of the moon
Posts: 9,908
Default

Please try with:
Settings > User Interface > Window Management
Reply With Quote
  #90  
Old 31.07.2013, 00:16
wahooo wahooo is offline
Banned
 
Join Date: Aug 2011
Posts: 94
Default

Quote:
Originally Posted by Lram32 View Post
Please try with:
Settings > User Interface > Window Management
Thanks, this works for most.

But ryushare picture captchas still pop to the front, its annoying because some games don't take nicely to having focus being stolen, I crash out of borderlands 2 everytime that happens, not good to happen in such a game where progress is lost:(
Reply With Quote
  #91  
Old 31.07.2013, 00:24
Lram32's Avatar
Lram32 Lram32 is offline
Spanish Supporter
 
Join Date: Jul 2012
Location: Dark side of the moon
Posts: 9,908
Default

Please, post some example links to check how the focus works with kind of captchas. Thanks,
Reply With Quote
  #92  
Old 31.07.2013, 00:34
raztoki's Avatar
raztoki raztoki is offline
English Supporter
 
Join Date: Apr 2010
Location: Australia
Posts: 16,143
Default

It's because keycaptcha has its own dialog. I'll talk to coalado tomorrow about it. I know we fixed one issue the other day with it not displaying at all, and I added sound support also. Which was result of custom code outside of JD2 core captcha handling. Lot of the new captcha support is implemented within plugins as we need backward capability for older versions of JDownloader.

raztoki
__________________
raztoki @ jDownloader reporter/developer
http://svn.jdownloader.org/users/170

Don't fight the system, use it to your advantage. :]
Reply With Quote
  #93  
Old 31.07.2013, 09:39
coalado's Avatar
coalado coalado is offline
JD Manager
 
Join Date: Feb 2009
Posts: 1,981
Default

Please try the silent mode if you are gaming. During the silentmode, jd should not steal any focus at all.
__________________
Reply With Quote
  #94  
Old 15.09.2013, 13:20
Aprendiz_de_Brujo
Guest
 
Posts: n/a
Default Request captchas: focus

Hello:

When using the old version of JD and had minimized the program in the notification area of the taskbar, I asked the captcha and the pointer is placed directly into the box where you enter this captcha. Now with JD2 I have to do is click in the box every time I have to enter a captcha, may seem silly, but this is quite uncomfortable when you do many downloads.

Greetings.
Reply With Quote
  #95  
Old 15.09.2013, 13:33
pspzockerscene's Avatar
pspzockerscene pspzockerscene is offline
Community Manager
 
Join Date: Mar 2009
Location: Deutschland
Posts: 48,574
Default

Hi
You can customize this behavior under settings -> User Interface

GreeZ psp
__________________

Ad-free installers || Werbefreie Installer
Windows Setup<--JD2 BETA-->Linux Setup x86 || Linux Setup x64 || Mac Setup
-----=>Support Chat<=-----
Spoiler:

A users' JD crashes and the first thing to ask is:
Quote:
Originally Posted by Jiaz View Post
Do you have Nero installed?
That's true James
Quote:
Originally Posted by James
Die Leute verstehen einfach nicht dass nur weil man mit einer Waffe auch auf Menschen schießen kann dass ein Schützenver​ein kein Ort für Amoklaufide​en ist
Reply With Quote
  #96  
Old 15.09.2013, 21:26
Aprendiz_de_Brujo
Guest
 
Posts: n/a
Default

Ok. Thanks.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

All times are GMT +2. The time now is 03:08.
Provided By AppWork GmbH | Privacy | Imprint
Parts of the Design are used from Kirsch designed by Andrew & Austin
Powered by vBulletin® Version 3.8.10 Beta 1
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.