JDownloader Community - Appwork GmbH
 

Reply
 
Thread Tools Display Modes
  #1  
Old 07.09.2017, 11:27
vindex vindex is offline
Modem User
 
Join Date: Sep 2017
Posts: 2
Default JD2 MyJDownloader Proxy does not work

Hi,
i use JDownloader2 headless on my server.
To manage downloads I use MyJDownloader (WebInterface).
I want JD2 to use a proxy server.
So I go to the WebInterface -> settings -> advanced settings -> InternetConnectionSettings: Custom Proxy List
But when I try to enter my configuration an error occurs: Sorry, failed to set new value.

This is my configuration.
Spoiler:
Code:
[ {
  "proxy" : {
    "username" : MYUSERNAME,
    "password" : MYPASSWORD,
    "port" : MYPORT,
    "address" : SERVERADDRESS,
    "type" : "SOCKS5",
    "preferNativeImplementation" : false,
    "connectMethodPrefered" : false
  },
  "rangeRequestsSupported" : true,
  "filter" : null,
  "pac" : false,
  "reconnectSupported" : true,
  "enabled" : true
} ]


Please help me. Thanks!
Reply With Quote
  #2  
Old 07.09.2017, 11:31
Jiaz's Avatar
Jiaz Jiaz is offline
JD Manager
 
Join Date: Mar 2009
Location: Germany
Posts: 72,107
Default

Works fine when I set correct values!

MYUSERNAME,MYPASSWORD,SERVERADDRESS are "Strings"
MYPORT is a Number
__________________
JD-Dev & Server-Admin
Reply With Quote
  #3  
Old 07.09.2017, 11:31
Jiaz's Avatar
Jiaz Jiaz is offline
JD Manager
 
Join Date: Mar 2009
Location: Germany
Posts: 72,107
Default

You should also set exclude filter for api.jdownloader.org so JDownloader doesnt use proxy for MyJDownloader itself
__________________
JD-Dev & Server-Admin
Reply With Quote
  #4  
Old 07.09.2017, 11:32
Jiaz's Avatar
Jiaz Jiaz is offline
JD Manager
 
Join Date: Mar 2009
Location: Germany
Posts: 72,107
Default

Easiest configuration is to use a JDownloader with GUI, setup all in Settings-Connections and then copy/paste the advanced settings value
__________________
JD-Dev & Server-Admin
Reply With Quote
  #5  
Old 07.09.2017, 11:56
vindex vindex is offline
Modem User
 
Join Date: Sep 2017
Posts: 2
Default

It worked now.
I had to write "myuser", "mypass", "serveraddress" and "type" in "".

Spoiler:
Code:
[ {
  "proxy" : {
    "username" : "myuser",
    "password" : "mypass",
    "port" : myport,
    "address" : "serveraddress",
    "type" : "SOCKS5",
    "preferNativeImplementation" : false,
    "connectMethodPrefered" : false
  },
  "rangeRequestsSupported" : true,
  "filter" : null,
  "pac" : false,
  "reconnectSupported" : false,
  "enabled" : true
} ]

Last edited by vindex; 07.09.2017 at 12:01.
Reply With Quote
  #6  
Old 07.09.2017, 12:04
Jiaz's Avatar
Jiaz Jiaz is offline
JD Manager
 
Join Date: Mar 2009
Location: Germany
Posts: 72,107
Default

Syntax is JSon
__________________
JD-Dev & Server-Admin
Reply With Quote
  #7  
Old 01.06.2020, 16:25
billouetaudrey billouetaudrey is offline
Junior Loader
 
Join Date: Mar 2020
Posts: 11
Default

Hi,

Is it possible to check if Jdownloader use proxy properly with MyJdownloader ?
Reply With Quote
  #8  
Old 02.06.2020, 12:08
Jiaz's Avatar
Jiaz Jiaz is offline
JD Manager
 
Join Date: Mar 2009
Location: Germany
Posts: 72,107
Default

@billouetaudrey: You should setup JDownloader that way, that MyJDownloader/Updates don't use proxy and downloads do. That way you will notice failing proxy with failing downloads Use board-search how to setup proxy settings in such a configuration
__________________
JD-Dev & Server-Admin
Reply With Quote
  #9  
Old 01.12.2020, 21:00
billouetaudrey billouetaudrey is offline
Junior Loader
 
Join Date: Mar 2020
Posts: 11
Default

Quote:
Originally Posted by Jiaz View Post
@billouetaudrey: You should setup JDownloader that way, that MyJDownloader/Updates don't use proxy and downloads do. That way you will notice failing proxy with failing downloads Use board-search how to setup proxy settings in such a configuration
Thanks, do I need to add before my proxy :

Quote:
[{"proxy":{"username":null, "password":null, "port":80, "address":null, "type":"NONE", "preferNativeImplementation":false, "resolveHostName":false, "connectMethodPrefered":false}, "rangeRequestsSupported":true, "filter":null, "pac":false, "reconnectSupported":true, "enabled":false},
Or not need ?

Thanks

Example of my proxy ::

Quote:
{"proxy":{"username":"***", "password":"***", "port":8080, "address":"proxych1.vpnsecure.me", "type":"HTTP", "preferNativeImplementation":false, "resolveHostName":false, "connectMethodPrefered":false}, "rangeRequestsSupported":true, "filter":null, "pac":false, "reconnectSupported":false, "enabled":true},

Last edited by billouetaudrey; 02.12.2020 at 10:36.
Reply With Quote
  #10  
Old 03.12.2020, 12:37
Jiaz's Avatar
Jiaz Jiaz is offline
JD Manager
 
Join Date: Mar 2009
Location: Germany
Posts: 72,107
Default

@billouetaudrey
see pastebin.com/KXrFeMxr
it contains settings to make JD use proxy for downloading and direct connection ONLY for JDownloader.
__________________
JD-Dev & Server-Admin
Reply With Quote
  #11  
Old 03.12.2020, 14:41
billouetaudrey billouetaudrey is offline
Junior Loader
 
Join Date: Mar 2020
Posts: 11
Default

Quote:
Originally Posted by Jiaz View Post
@billouetaudrey
see pastebin.com/KXrFeMxr
it contains settings to make JD use proxy for downloading and direct connection ONLY for JDownloader.
Thanks lemme try :D

Seem to be working thanks :D

Last edited by billouetaudrey; 03.12.2020 at 15:07.
Reply With Quote
  #12  
Old 07.12.2020, 17:58
billouetaudrey billouetaudrey is offline
Junior Loader
 
Join Date: Mar 2020
Posts: 11
Default

Hi,

Again a question, do I need to enable this please :

" InternetConnectionSettings: Proxy Vole Autodetection"

and this :

"Reconnect: IPCheck Uses Proxy"
Reply With Quote
  #13  
Old 07.12.2020, 18:31
Jiaz's Avatar
Jiaz Jiaz is offline
JD Manager
 
Join Date: Mar 2009
Location: Germany
Posts: 72,107
Default

Quote:
Originally Posted by billouetaudrey View Post
" InternetConnectionSettings: Proxy Vole Autodetection"
just checks your environment for proxies and auto adds them. You can leave them on but also may disable them.

Quote:
Originally Posted by billouetaudrey View Post
"Reconnect: IPCheck Uses Proxy"
Only use this if you use a Proxy Only environment. leave it disabled as default.
__________________
JD-Dev & Server-Admin
Reply With Quote
  #14  
Old 08.12.2020, 12:58
billouetaudrey billouetaudrey is offline
Junior Loader
 
Join Date: Mar 2020
Posts: 11
Default

Ok because when I disable one of both, don't remember which, but I think it's " IPCheck "
Download speed is very slow ... 2/3mb/sec with Ipcheck tick, 30mb/sec without

I just want be sure JDL use proxy
Reply With Quote
  #15  
Old 08.12.2020, 13:30
Jiaz's Avatar
Jiaz Jiaz is offline
JD Manager
 
Join Date: Mar 2009
Location: Germany
Posts: 72,107
Default

IPCheck has no influence on speed at all. Pure coincidence
__________________
JD-Dev & Server-Admin
Reply With Quote
  #16  
Old 08.12.2020, 13:31
Jiaz's Avatar
Jiaz Jiaz is offline
JD Manager
 
Join Date: Mar 2009
Location: Germany
Posts: 72,107
Default

Quote:
Originally Posted by billouetaudrey View Post
I just want be sure JDL use proxy
With correct black/whitelist, JDownloader will only be able to use the proxy.
Enter a wrong proxy server address in configuration and downloads must all fail
__________________
JD-Dev & Server-Admin
Reply With Quote
  #17  
Old 08.12.2020, 15:11
billouetaudrey billouetaudrey is offline
Junior Loader
 
Join Date: Mar 2020
Posts: 11
Default

Quote:
Originally Posted by Jiaz View Post
With correct black/whitelist, JDownloader will only be able to use the proxy.
Enter a wrong proxy server address in configuration and downloads must all fail
I don't add any black/whitelist, because I want use JDL for everything
Reply With Quote
  #18  
Old 08.12.2020, 15:28
Jiaz's Avatar
Jiaz Jiaz is offline
JD Manager
 
Join Date: Mar 2009
Location: Germany
Posts: 72,107
Default

Quote:
Originally Posted by billouetaudrey View Post
I don't add any black/whitelist, because I want use JDL for everything
I mean whitelist JDownloader/MyJDownloader only for direct connection, rest is Blacklisted to use Proxy
__________________
JD-Dev & Server-Admin
Reply With Quote
  #19  
Old 09.12.2020, 09:46
billouetaudrey billouetaudrey is offline
Junior Loader
 
Join Date: Mar 2020
Posts: 11
Default

**External links are only visible to Support Staff****External links are only visible to Support Staff**

This is my settings, I think all is good
Reply With Quote
  #20  
Old 09.12.2020, 11:52
Jiaz's Avatar
Jiaz Jiaz is offline
JD Manager
 
Join Date: Mar 2009
Location: Germany
Posts: 72,107
Default

You should modify it to make use of white/blacklisting to make sure that JDownloader/MyJDownloader uses direct/non proxy and rest will always use proxy.
In doubt, send me the configuration to support@jdownloader.org and I will modify it for you
__________________
JD-Dev & Server-Admin
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

All times are GMT +2. The time now is 11:44.
Provided By AppWork GmbH | Privacy | Imprint
Parts of the Design are used from Kirsch designed by Andrew & Austin
Powered by vBulletin® Version 3.8.10 Beta 1
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.