JDownloader Community - Appwork GmbH
 

Reply
 
Thread Tools Display Modes
  #1  
Old 17.08.2009, 19:42
zeroz
Guest
 
Posts: n/a
Default Socket Timeout error

Hello,
I am using JDownloader 0.6.193 under Linux and it's being a great product. But there're some annoying problems. One of them is that after some errors the program wouldn't reconnect. The most often example of such an error is the error "Socket Timeout: read timed out" I get when downloading from Rapidshare premium account. My connection is not very stable and sometimes this error appears pretty much every minute. It is a problem, as it wouldn't reconnect automatically and I have to resume the downloads by hand. When I do, they usually continue normally. But I can't sit all the day resuming my downloads! Can anyone advice something for me to at least automate the reconnection? I saw there's a similar thread in German section, but I don't understand German well enough to understand what the solution was.

Last edited by Jiaz; 29.06.2010 at 09:14.
Reply With Quote
  #2  
Old 18.08.2009, 12:22
remi
Guest
 
Posts: n/a
Cool

Can you download these files with your browser?

If not, then the problem is not jD, but your connection to the Internet. I would contact my internet provider in order to detect the cause of these timeouts.

Do you have a dynamic IP address?

When a host supports resume, your file won't be downloaded several times.

Reduce the number of simultaneous downloads, the max. number of connections and chunks.

In Configuration -> Download/Network -> Internet & Network Settings you can increase the Read and Connect Timeout values.
Reply With Quote
  #3  
Old 18.08.2009, 18:08
zeroz
Guest
 
Posts: n/a
Default

Yes, I can download the files with browser, albeit slowly. The browser, and also DownThemAll and such, don't throw the "Socket timeout" error. In fact, jD is the only program in which I saw this kind of error.

I have a static IP.

Again, the problem is NOT that I can't resume the download. The problem is that jD doesn't do it automatically for me after "Socket timeout" error.

I already reduced the number of downloads and chunks to 1 and 1, it doesn't help. In fact it makes the matters worse, as if there's only one file downloading and then it gets "Socket timeout", the downloads stop altogether.

Again, the time between reconnects does not impact on the problem, as after "Socket timeout" it DOES NOT reconnect at all!
Reply With Quote
  #4  
Old 19.08.2009, 10:32
remi
Guest
 
Posts: n/a
Cool

I don't see the purpose of reconnecting if you have a static IP address. Please, disable this feature.

My diagnosis is that indeed jD should automatically retry erroneous downloads. It has been reported many times and is implemented in other download tools. I don't know the current status of this requirement.

Did you exclude javaw.exe and java.exe from your firewall blocking list? If this is the case the bad news for you is that your connection isn't the best one in the world. It could be due to a hardware failure. Please, discuss this issue with your Internet provider.

Last edited by remi; 09.11.2009 at 11:17. Reason: PC => IP address
Reply With Quote
  #5  
Old 19.08.2009, 15:37
zeroz
Guest
 
Posts: n/a
Default

Which feature? All I know is that after particular error the downloads wouldn't resume. I couldn't find any configuration options responsible for this. And yes, I know that my internet connection is not good, especially with rapidshare. I am trying to contact both my ISP and rapidshare support about this, but there's a problem with particular error in jD. Maybe somebody of the developers can comment on this?
Reply With Quote
  #6  
Old 19.08.2009, 16:03
remi
Guest
 
Posts: n/a
Cool

You can find the reconnect feature next to the clipboard monitoring icon in the task bar of jD.

If your Internet connection is bad no developer can do anything about it. If they don't reply then that's because they have more urgent issues to deal with.
Reply With Quote
  #7  
Old 20.08.2009, 11:15
zeroz
Guest
 
Posts: n/a
Default

I prefer to take things to the people who are responsible for them. The problems with my ISP I take to my ISP, as it's their domain of responsibility. But this "Socket timeout" thing is a problem of jD and nothing else. In my opinion, it's a blocker, as it effectively prevents me from using the software fruitfully. If the developers think it is "unimportant", then pray tell me what is.
Reply With Quote
  #8  
Old 20.08.2009, 13:25
remi
Guest
 
Posts: n/a
Cool

Can't you show any logs? It might attract some devs

What's yout JRE (Java) version?

Last edited by remi; 20.08.2009 at 13:29.
Reply With Quote
  #9  
Old 20.08.2009, 13:40
zeroz
Guest
 
Posts: n/a
Default

Code:
$ java -version
java version "1.6.0_14"
Java(TM) SE Runtime Environment (build 1.6.0_14-b08)
Java HotSpot(TM) Server VM (build 14.0-b16, mixed mode)
I hope it helps something. And where do I find the logs from jD?
Reply With Quote
  #10  
Old 20.08.2009, 13:50
remi
Guest
 
Posts: n/a
Cool

In Configuration -> Main -> Logging you can choose the logging level.

In the left pane there should be a log entry. There you can save or upload your log.
Reply With Quote
  #11  
Old 08.11.2009, 22:01
PhireBird
Guest
 
Posts: n/a
Default It is the Firewall

I have had the same problem, I noticed that the chunks I was connecting to in jDownloader to my megaupload account was on average 2/10 and they would soon disconnect and there would be a socket timeout error.
I had Kaspersky Internet Security enabled as the only firewall present javaw.exe/jDownloader were both set to trusted.
As soon as I disabled the firewall all chunks maxed out and the speed increased and was stable.:thumbup:
Reply With Quote
  #12  
Old 29.12.2009, 12:19
Kilroy
Guest
 
Posts: n/a
Default The problem is from Kaspersky

I use Kaspersky Antivirus (not the full internet security package).
I also use the normal Windows 7 firewall.

I had the same problem and tested the following configurations:
  • Windows firewall disabled, Kaspersky AV operative => still socket timeouts
  • Windows firewall enabled, Kaspersky AV disabled => works fine
So it definitely has something to do with Kaspersky blocking or slowing down some of the download processes used by JDownloader.
It works fine when downloading from a web browser, even with Kaspersky AV enabled.
Reply With Quote
  #13  
Old 30.12.2009, 14:48
remi
Guest
 
Posts: n/a
Cool

You must configure your Windoze defence software properly.

Allow java.exe and javaw.exe in your firewall and virus software. Also disable html/web scanner in your virus software.
Reply With Quote
  #14  
Old 18.04.2010, 01:26
smartal
Guest
 
Posts: n/a
Default

I confirm that the reason is Kaspersky (I use KIS 2010) and only after reading your thread tested (as I have Win firewall turned off) that KIS was cousing this error that was driving me crazy!:whistling:
Reply With Quote
  #15  
Old 28.04.2010, 08:42
collions
Guest
 
Posts: n/a
Default

Quote!
For the second time you saved me from the "mental home"..

It's KIS 2010 for me too. Disable it (pause protection) and all works good!
Reply With Quote
  #16  
Old 09.05.2010, 13:09
southstorm
Guest
 
Posts: n/a
Default

If anyone is still having this problem, this is how I fixed the problem using KIS 2010 by excluding javaw.exe:


1. Open Kaspersky and open “Settings”.

2. In the left hand column click on “Threats and exclusions”.

3. Now on the right side, under “Exclusions”, click on “Settings…”.

4. In the “Trusted zone” window, click on the “trusted applications” tab.

5. When in the “Trusted applications” tab, click on “Add” near the left bottom of the window then “Browse ….”

6. Navigate to “Javaw.exe” (C:\Program Files(x86)\Java\jre6\bin\javaw.exe) in the case of Windows 7.

7. Click on “javaw.exe” file, the click on “Open”.

8. Put a check mark in the following two places:
“Do not scan network traffic”
“Do not monitor application activity” And click “OK”.

9. Click “OK” on the windows that appears.

10. Click “Apply” then “OK” on the next window and exit Kaspersky.
Reply With Quote
  #17  
Old 29.06.2010, 08:32
dingflot
Guest
 
Posts: n/a
Default Thanks southstorm

I should have thought of the firewall... it's often the problem in many situations. I love Jdownloader, love kaspersky, love windows 7 & love rapidshare. Thanks for this tip southstorm and all you others for posting.
Reply With Quote
  #18  
Old 19.10.2010, 02:35
mrbongo
Guest
 
Posts: n/a
Default Working for me:)

Quote:
Originally Posted by southstorm View Post
If anyone is still having this problem, this is how I fixed the problem using KIS 2010 by excluding javaw.exe:


1. Open Kaspersky and open “Settings”.

2. In the left hand column click on “Threats and exclusions”.

3. Now on the right side, under “Exclusions”, click on “Settings…”.

4. In the “Trusted zone” window, click on the “trusted applications” tab.

5. When in the “Trusted applications” tab, click on “Add” near the left bottom of the window then “Browse ….”

6. Navigate to “Javaw.exe” (C:\Program Files(x86)\Java\jre6\bin\javaw.exe) in the case of Windows 7.

7. Click on “javaw.exe” file, the click on “Open”.

8. Put a check mark in the following two places:
“Do not scan network traffic”
“Do not monitor application activity” And click “OK”.

9. Click “OK” on the windows that appears.

10. Click “Apply” then “OK” on the next window and exit Kaspersky.

This is working for me:) I have KIS and I did everything above, and it's working 100% thank you:)
Reply With Quote
  #19  
Old 26.10.2010, 14:39
lucaluca
Guest
 
Posts: n/a
Default

Yep, KIS was the culprit.

Thanks for the tip. It worked for me.

The problem is solved by adding javaw to the Trusted zone in KIS and checking “Do not scan network traffic”
“Do not monitor application activity”

see above for more details.
Reply With Quote
  #20  
Old 10.03.2011, 11:45
NitrofishStudios
Guest
 
Posts: n/a
Default

Ummm correct me if I am wrong, but doesn't adding these to the exclude list and turning off scanning of network traffic put you at risk of being infected with viruses, malware, etc? What is the point of having network security if you disable to get an application to work? I can tell you several rougue Websites have tried to use JAVAW.exe to infect my PC and having KIS stopped it.

The fact is I have been using JDownloader for a long time and before some recent JDownloader updates I never had these timeout errors and everything worked fine, so in my view this is a developer problem and I do not accept the workaround of disabling my protection to stop these timeout errors. Lazy programmers develop applications that are full of security holes and I see this as a perfect example.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

All times are GMT +2. The time now is 16:11.
Provided By AppWork GmbH | Privacy | Imprint
Parts of the Design are used from Kirsch designed by Andrew & Austin
Powered by vBulletin® Version 3.8.10 Beta 1
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.