JDownloader Community - Appwork GmbH
 

Reply
 
Thread Tools Display Modes
  #1  
Old 21.07.2022, 22:57
Jorktown Jorktown is offline
Modem User
 
Join Date: May 2020
Posts: 4
Post JDownloader 2 auf den Stand der Zeit bringen ein Versuch.

Wenn ihr JDownloader 2 nutzt könnt ihr in JDownloader 2 über Hilfe zum Über JDownloader gelangen.

Dort könnt ihr sehen ob eurer JDownloader 2 aktuell ist oder eben nicht.

Es gibt hier verschieden Punkte:

1. Java sollte die 1.8.0_341 sein wenn nicht siehe weiter unten.
2. JNA Sollte eigentlich 5.12.1 oder neuer sein. = ein Update wäre gut.
3. 7ZipJBindings (16.02.-2.01/Windows) wenn nicht siehe weiter unten.
4. Zip4J = ein Update wäre gut.

5. Es gibt noch den FFMpeg im JD2 den seht ihr da nicht, aber er ist da siehe weiter unten.

Euer JDownloader 2 weicht von den oben genannten ab und ihr möchtet Updaten:

Ganz einfach das JD2.Extern Update Downloaden und entpacken mit 7Zip (22.01) oder WinRar (Aktuelle Version).

1 Erstellt euch eine Kopie eures JD2 in einen anderen Ordner zur Sicherheit.
2. Im JDownloader 2 Ordner den Ordner JRE entfernen, wenn vorhanden.
2. alle Ordner die im JD.Extern.Update sind in das Haupt Verzeichnis von JDownloader 2 Kopieren.
--ggf. Überschreiben lassen.
Fertig.

Jetzt einfach JDownloader 2 wieder Starten und Kontrollieren über Hilfe, zum Über JDownloader.
Ob ihr jetzt die Aktuelle Version habt.

Die Punkte 2 + 4 sollten die Hersteller von JDownloader 2 bitte Schnell Updaten auf den Letzten stand.

Punkt 1 + 2 sind Sicherheits Relevant.

Änderungen natürlich immer auf eingene gefahr hin.

PS: Sollte das Thema nicht gewünscht sein:
Bitte den JD2 Vernünftig Updaten,
denn ich habe eine alternativ ohne diese änderungen und das ist nicht Ok der Aktuelle Stand.

Edit by Jiaz: Link lautet
file-upload.net/download-14971823/JD.Extern.Update.7z.html

Last edited by Jiaz; 22.07.2022 at 10:51.
Reply With Quote
  #2  
Old 22.07.2022, 09:52
Jiaz's Avatar
Jiaz Jiaz is offline
JD Manager
 
Join Date: Mar 2009
Location: Germany
Posts: 77,851
Default

Quote:
Originally Posted by Jorktown View Post
1. Java sollte die 1.8.0_341 sein wenn nicht siehe weiter unten.
Es besteht keine wirkliche Notwendigkeit hier auf die neuste Java Version zu wechseln. JDownloader nutzt keinerlei Java Mechanismen /zb RMI oder sonstige welche extern verfügbar sind. Je nach genutztem Installer und Umgebung und Installation nutzt der Launcher wahlweise das im Installer gebundelete Java (welches wir regelmäßig aktualisieren) oder das im System installierte Java.
Du kannst wahlweise das gebundelte Java selbstständig aktualisieren (befindet sich im JDownloader Unterordner) oder jenes löschen, sodass der Launcher das Java deines Systems nutzt. Hierbei unbedingt auf die richtige Bitness Acht geben, da ein 32bit Launcher nur mit 32bit Java läuft. Entsprechend benötigt ein 64bit Java einen 64bit Launcher. Siehe https://jdownloader.org/jdownloader2

Hier könnte man über ein Funktion für ein optionales/manuelles aktualisieren der JRE nachdenken. Zusätzlich noch einen Artikel in https://support.jdownloader.org/ der beschreibt wie man von Hand die JRE aktualisieren kann
__________________
JD-Dev & Server-Admin

Last edited by Jiaz; 22.07.2022 at 10:14.
Reply With Quote
  #3  
Old 22.07.2022, 09:54
Jiaz's Avatar
Jiaz Jiaz is offline
JD Manager
 
Join Date: Mar 2009
Location: Germany
Posts: 77,851
Default

Quote:
Originally Posted by Jorktown View Post
2. JNA Sollte eigentlich 5.12.1 oder neuer sein. = ein Update wäre gut.
Wird entsprechend mit einem der nächsten Core Updates aktualisiert. Aber da das Changelog keinerlei Security Fixes beinhaltet, sehe ich hier kein Problem wenn ein Update nicht zeitnahe erfolgt.

Wird aber mit nächstem Core Update ebenfalls hochgezogen sein.
__________________
JD-Dev & Server-Admin

Last edited by Jiaz; 22.07.2022 at 10:09.
Reply With Quote
  #4  
Old 22.07.2022, 10:00
Jiaz's Avatar
Jiaz Jiaz is offline
JD Manager
 
Join Date: Mar 2009
Location: Germany
Posts: 77,851
Default

Quote:
Originally Posted by Jorktown View Post
3. 7ZipJBindings (16.02.-2.01/Windows) wenn nicht siehe weiter unten.
Hierbei handelt es sich um das folgende Projekt github.com/borisbrodski/sevenzipjbinding/commits/master.Der Entwickler Boris wird, sofern er Zeit/Unterstützung findet, hier auch ein Binding/Update für die neuere Version versuchen. Aber auch hier besteht aktuell keine Veranlassung für ein Update, da mit dem aktuellen Binding keine sicherheitstechnische Probleme bekannt sind.

Du meintest in deinem Text wahrscheinlich 16.02-2.02? Weil das die aktuelle Version ist. Ein Update hierauf ist aber nicht nötig, da lediglich folgender Fix enthalten/neu ist:
Quote:
Bugfix #5 RandomAccessFileOutStream should implement Closeable
Was für den JDownloader unerheblich ist, da die Streams immer bewusst geschlossen werden.
__________________
JD-Dev & Server-Admin

Last edited by Jiaz; 22.07.2022 at 10:31.
Reply With Quote
  #5  
Old 22.07.2022, 10:06
Jiaz's Avatar
Jiaz Jiaz is offline
JD Manager
 
Join Date: Mar 2009
Location: Germany
Posts: 77,851
Default

Quote:
Originally Posted by Jorktown View Post
4. Zip4J = ein Update wäre gut.
Gut ja, aber würde zum einen die Kompatibilität zu Java 1.6 brechen (ja, es gibt noch JDownloader Nutzer welche auf Java 1.6 *gefangen* sind) und zum anderen gibt es auch hier keinen wirklichen Grund. Im Changelog sind keine Security Fixes enthalten. Und nur ein Update um des Updates Willen mit gleichzeitigem Verlust der Kompatibilität, wozu? Aber einen kleinen Update Hoffnungsschimmer kann ich dir geben. Ich habe bereits erste Versuche mit alter und neuer Version der Library (je nach Java Version) gemacht. Aber hierzu benötige ich mehr Zeit, welche ich derzeit nicht habe.
Soweit ich sehen konnte hat sich mit dem Versionssprung von 1.x auf 2.x viel an der API geändert, weshalb eine gleichzeitige Unterstützung von 1.x und 2.x mit mehr Aufwand verbunden ist.
__________________
JD-Dev & Server-Admin

Last edited by Jiaz; 22.07.2022 at 10:46.
Reply With Quote
  #6  
Old 22.07.2022, 10:41
Jiaz's Avatar
Jiaz Jiaz is offline
JD Manager
 
Join Date: Mar 2009
Location: Germany
Posts: 77,851
Default

Quote:
Originally Posted by Jorktown View Post
5. Es gibt noch den FFMpeg im JD2 den seht ihr da nicht, aber er ist da siehe weiter unten.
Sofern auf dem System bereits ein ffmpeg vorhanden ist oder durch den Nutzer ein eigenes ffmpeg eingerichtet wurde, siehe
Einstellungen->Profieinstellungen->FFmpegSetup.binarypathprobe
Einstellungen->Profieinstellungen->FFmpegSetup.binarypath
wird von JDownloader ein unterstütztes ffmpeg Packet installiert.
Wer hier immer auf der neusten Version sein will, so kann er von ffmpeg.org/download.html diese entsprechend laden
und selbst im JDownloader hinterlegen. Bei Zeiten werde ich hier mal die gebundelten Builds aktualisieren
__________________
JD-Dev & Server-Admin

Last edited by Jiaz; 22.07.2022 at 10:44.
Reply With Quote
  #7  
Old 22.07.2022, 10:54
Jiaz's Avatar
Jiaz Jiaz is offline
JD Manager
 
Join Date: Mar 2009
Location: Germany
Posts: 77,851
Default

Quote:
Originally Posted by Jorktown View Post
PS: Sollte das Thema nicht gewünscht sein
Nein, alles Gut. Sind ja durchaus berechtigte Themen!
Ich habe die aufgeführten Punkte kommentiert und Tickets verlinkt.
__________________
JD-Dev & Server-Admin
Reply With Quote
  #8  
Old 25.07.2022, 01:29
Jorktown Jorktown is offline
Modem User
 
Join Date: May 2020
Posts: 4
Default

@Jiaz,
Erst ein mal ein Großes DANKE, damit habe ich echt nicht gerechnet.

Die änderungen Betreffend Java waren bei Windows 11, am 05.02.2022 notwendig.
Erst damit Lief JD2 wieder Problemlos.
Eine Installation von Java im Windows 11 hatte keinen Erfolg.

Eine änderung wie von dir beschrieben auf System Java Crash unter Windows 11.
Liegt vielleicht drann das ich sehr Spezielle zusatz sachen im System habe.


7ZipJBinding:
Das ist das was ich gefunden habe: sevenzipjbinding-16.02-2.01-Windows-x86.zip 2020-02-19
neuere einen Link wäre Super.

Grüße
Jorktown..
alias MTechlerin..
alias Masterlecherin..
Reply With Quote
  #9  
Old 10.08.2022, 18:05
Jiaz's Avatar
Jiaz Jiaz is offline
JD Manager
 
Join Date: Mar 2009
Location: Germany
Posts: 77,851
Default

@Jorktown: Entschuldige die späte Antwort/Reaktion. Da musst dich nicht für bedanken!
Die von dir gefundene/genannte 7ZipJBinding ist jene Version welche auch derzeit im JDownloader zum Einsatz kommt.
Boris hat Pläne hier ein Update auf neuere p7zip Versionen zu machen, aber fand bisher auch noch nicht die Zeit. Da sich die neueren Versionen intern teils stark unterscheiden ist hier entsprechend auch mehr Aufwand/Zeit nötig.
__________________
JD-Dev & Server-Admin

Last edited by Jiaz; 10.08.2022 at 18:08.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

All times are GMT +2. The time now is 17:05.
Provided By AppWork GmbH | Privacy | Imprint
Parts of the Design are used from Kirsch designed by Andrew & Austin
Powered by vBulletin® Version 3.8.10 Beta 1
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.