JDownloader Community - Appwork GmbH
 

Reply
 
Thread Tools Display Modes
  #1  
Old 15.12.2017, 19:40
cygnusx-1 cygnusx-1 is offline
Super Loader
 
Join Date: Sep 2010
Posts: 25
Default JD2 generates wrong files/folders names (accents are missing) when extracts ZIP files

Title says by itself, first screenshot shows the file extracted by jd2 (accent in "missão" and "módulo" is missing). Second screenshot shows the files extracted with another program. Folder name is correct, it includes the accents.

To test, download "módulo 14.zip" file from the link below
https://drive.google.com/drive/folde...Q-2Wf78qbrFpHz

password to extract: NoUs3r

Extract the file using jd2 and another software.
Attached Images
File Type: png missing accents.png (16.9 KB, 3 views)
File Type: png accents included.png (17.0 KB, 3 views)
Reply With Quote
  #2  
Old 15.12.2017, 19:57
cygnusx-1 cygnusx-1 is offline
Super Loader
 
Join Date: Sep 2010
Posts: 25
Default

I forgot to say that this problem happens on linux.
No problem on windows 7.
Reply With Quote
  #3  
Old 15.12.2017, 20:36
Jiaz's Avatar
Jiaz Jiaz is offline
JD Manager
 
Join Date: Mar 2009
Location: Germany
Posts: 59,611
Default

You have to specify the correct LOCALE
export LC_CTYPE="en_US.UTF-8"
export LANG="en_US.UTF-8"
export LC_COLLATE="C"
java -jar JDownloader.jar ....
I guess on your linux system the wrong locale is set
__________________
JD-Dev & Server-Admin
Reply With Quote
  #4  
Old 15.12.2017, 20:53
cygnusx-1 cygnusx-1 is offline
Super Loader
 
Join Date: Sep 2010
Posts: 25
Default

Where should I specify the locale?
My system locale is LANG=pt_BR.UTF-8 and I see no problem with other softwares.
The problem described here affects two systems:
Arch Linux and KDE Neon.
Reply With Quote
  #5  
Old 15.12.2017, 20:59
Jiaz's Avatar
Jiaz Jiaz is offline
JD Manager
 
Join Date: Mar 2009
Location: Germany
Posts: 59,611
Default

Java uses several environment variables for correct char mapping.
I suggest to try out this first and see if that helps
open terminal, enter those commands and then start JDownloader within the same terminal

That way we know if the issue is caused by this or something else
__________________
JD-Dev & Server-Admin
Reply With Quote
  #6  
Old 15.12.2017, 21:00
Jiaz's Avatar
Jiaz Jiaz is offline
JD Manager
 
Join Date: Mar 2009
Location: Germany
Posts: 59,611
Default

Ah sorry, please try this one first
https://board.jdownloader.org/showthread.php?t=71069

Forgot that in old library there was this issue. Sorry
__________________
JD-Dev & Server-Admin
Reply With Quote
  #7  
Old 15.12.2017, 21:21
cygnusx-1 cygnusx-1 is offline
Super Loader
 
Join Date: Sep 2010
Posts: 25
Default

Quote:
Originally Posted by Jiaz View Post
Ah sorry, please try this one first
**External links are only visible to Support Staff**...

Forgot that in old library there was this issue. Sorry
Same bug.
Reply With Quote
  #8  
Old 15.12.2017, 21:38
Jiaz's Avatar
Jiaz Jiaz is offline
JD Manager
 
Join Date: Mar 2009
Location: Germany
Posts: 59,611
Default

Can you please provide a logfile? https://support.jdownloader.org/Know...d-session-logs
__________________
JD-Dev & Server-Admin
Reply With Quote
  #9  
Old 15.12.2017, 21:39
Jiaz's Avatar
Jiaz Jiaz is offline
JD Manager
 
Join Date: Mar 2009
Location: Germany
Posts: 59,611
Default

okay, found the ticket

Updated library that has this bug fixed, will come beginning of next year
__________________
JD-Dev & Server-Admin
Reply With Quote
  #10  
Old 15.12.2017, 21:47
cygnusx-1 cygnusx-1 is offline
Super Loader
 
Join Date: Sep 2010
Posts: 25
Default

ok, I will wait for it.
Thank you Jiaz.
Reply With Quote
  #11  
Old 15.12.2017, 21:50
Jiaz's Avatar
Jiaz Jiaz is offline
JD Manager
 
Join Date: Mar 2009
Location: Germany
Posts: 59,611
Default

Contact me via support@jdownloader.org and tell me if you need 32/64bit, then I will provide test library.
I will respond to your email next week
__________________
JD-Dev & Server-Admin
Reply With Quote
  #12  
Old 26.12.2018, 15:38
cygnusx-1 cygnusx-1 is offline
Super Loader
 
Join Date: Sep 2010
Posts: 25
Default

The bug persists on linux.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

All times are GMT +2. The time now is 09:15.
Provided By AppWork GmbH | Privacy | Imprint
Parts of the Design are used from Kirsch designed by Andrew & Austin
Powered by vBulletin® Version 3.8.10 Beta 1
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.