JDownloader Community - Appwork GmbH
 

Reply
 
Thread Tools Display Modes
  #4121  
Old 28.11.2020, 13:47
Jiaz's Avatar
Jiaz Jiaz is offline
JD Manager
 
Join Date: Mar 2009
Location: Germany
Posts: 79,128
Default

@raptor2003: JD can set some meta data, eg video URL to final file with this option enabled

@mz168: I will look into USER/USERNAME failing. Does it happe for all files? Other tags work correct? Looks like I've missed at least this one/stupid copy/paste mistake. I cannot reproduce, so please provide example links
__________________
JD-Dev & Server-Admin

Last edited by Jiaz; 28.11.2020 at 15:01.
Reply With Quote
  #4122  
Old 28.11.2020, 17:46
jondavis jondavis is offline
Junior Loader
 
Join Date: Nov 2020
Posts: 12
Default Lost My Video File Name?

Youtube Video File Name Pattern is set as:

*3D* *360* *VIDEO_NAME* (*H*p_*FPS*fps_*VIDEO_CODEC*-*AUDIO_BITRATE*kbit_*AUDIO_CODEC*).*EXT*


I'm pretty sure *VIDEO_NAME* means that I should receive that.
Yet when I copy a video and it appears in jdownloader I only see something like this:
(906p_24fps_H264-128kbit_AAC).mp4

How do I get the Video Name back under the name column?
Is there a reset button somewhere to go back to default settings?
Or What else should I check to fix this?

Last edited by jondavis; 28.11.2020 at 17:50.
Reply With Quote
  #4123  
Old 28.11.2020, 17:47
maissaz maissaz is offline
Modem User
 
Join Date: Nov 2020
Posts: 4
Default help me plz

Quote:
Originally Posted by Jiaz View Post
Update is live
Go Natural English channel has over 562 videos. But, linkgrabber is grabbing only 100.
Why
Reply With Quote
  #4124  
Old 28.11.2020, 19:25
plip plip is offline
Wind Gust
 
Join Date: Jun 2016
Posts: 44
Default

Even after updating again a few seconds ago there's still some videos that aren't showing up in linkgrabber. Examples:
**External links are only visible to Support Staff****External links are only visible to Support Staff**

**External links are only visible to Support Staff****External links are only visible to Support Staff**

28.11.20 11.21.49 <--> 28.11.20 11.23.56 jdlog://2128425302851/
Reply With Quote
  #4125  
Old 28.11.2020, 22:54
mz168 mz168 is offline
JD Alpha
 
Join Date: May 2019
Posts: 21
Default

Quote:
Originally Posted by Jiaz View Post
@mz168: I will look into USER/USERNAME failing. Does it happe for all files? Other tags work correct? Looks like I've missed at least this one/stupid copy/paste mistake. I cannot reproduce, so please provide example links
Does not happen to all files, for instance, this is ok.
gameranxTV-gameranx
**External links are only visible to Support Staff****External links are only visible to Support Staff**

But not this:
UCVLN0tY51ewH44wUtx3YZTA-Tech Spurt
**External links are only visible to Support Staff****External links are only visible to Support Staff**
Reply With Quote
  #4126  
Old 29.11.2020, 01:08
elvis_ef's Avatar
elvis_ef elvis_ef is offline
JD Addict
 
Join Date: Oct 2019
Location: Polska
Posts: 155
Unhappy 100 links - waiting for any changes...

Quote:
Originally Posted by JDmurphy View Post
@elvis_ef : Was the issue resolved for you or why didn't you inquire any further?


I'm currently encountering the same limit, while playlists/channels with >100 items weren't a problem a few weeks ago, even with the Windows client.

Can you describe the difference between the two links you posted? (Links are only visible for staff and yourself) That could be very helpful as long as the issue itself isn't taken care of! thanks
Hey,

sorry for the delay, but I didn't check the forum till now.

I thougth that the two links are different, but... as I see now, the issue still happens. And what else ? I see that after my post there were a few other issues with 100 links.

Alright, so the links differs from the start:

1st - youtube.com/channel/<channel_name> (channel name is an ID here: UCJEIhoaCwZgLsZ4rRVdrFjQ)
2nd - youtube.com/c/<channel_name> (channel name is a channel "title" here: DetektywPrawdyTV)

If You use these information provided, You will see that these links shows the same channel.

So far, I remember that one is when You click just the channel name in the search.

The second link was... hmm, maybe from the subscription list if You're signed in.

Cannot remember exactly, where it was I clicked it. But I see the issue persists and there's even a bug numbered: 89006. Hope someone fixes this soon because there are channels I would like to download videos from, with more than hundred videos...
Reply With Quote
  #4127  
Old 29.11.2020, 02:17
jondavis jondavis is offline
Junior Loader
 
Join Date: Nov 2020
Posts: 12
Default

Well the problem seems to have fixed itself.
I'm guessing the reboot fixed it.
If I had to guess what caused it, it might of been either a windows update that I did just recently, or maybe playing around with the settings.
Either way it's working now.
Reply With Quote
  #4128  
Old 29.11.2020, 05:36
Ney Ney is offline
I will play nice!
 
Join Date: Nov 2020
Posts: 2
Default

Hi,

I came here from a link I found on google which took me to page 132 of this thread which talks about problem getting over 100 videos from a channel.

I'm also trying to download all the videos from a youtube channel with over 300 videos and the link grabber only finds the first 100 videos in the channel.

Channel link: **External links are only visible to Support Staff****External links are only visible to Support Staff**

Hope the problem can be solved soon
Reply With Quote
  #4129  
Old 29.11.2020, 21:03
interceptorchamp interceptorchamp is offline
Modem User
 
Join Date: Jul 2018
Posts: 1
Default YouTube name no longer working

Hello,
it seems that during the last updates (2 - 3 days ago) something happened to the YouTube plugin.
I used to save the videos with the following pattern:
*USERNAME*(*CHANNEL_ID*),*VIDEO_NAME* (*H*p),*DATE[dd.MM.yyyy]*.*EXT*

Now the name is saved with the channel id instead of the username prior the brackets, essentially:
*CHANNEL_ID*(*CHANNEL_ID*),*VIDEO_NAME* (*H*p),*DATE[dd.MM.yyyy]*.*EXT*

This makes it hard to recognize the username without knowing the respective channel id (e. g. UCetAQCYoN2AoufQ1XeSpd2A = "Goal Deutschland") ...

I already restartet Jdownloader2, but it didn´t change anything.

Is there a way to revert the updates to the prior state where it worked?

I already checked the known bugs, but without success.

Every help is much appreciated, it prevents me from renaming the saved files afterwards ...
Reply With Quote
  #4130  
Old 30.11.2020, 00:59
rezad rezad is offline
JD Adviser
 
Join Date: Jan 2014
Posts: 109
Default

somewhat longish post.

there is an issue that I noticed before but didn't care about that happens with youtube plugin.
the issue is produced with these steps.

I have set my default youtube quality to 720p.

I add a youtube link that had 1080p max resolution. and then try to add another variant from "additional variant" menu in right click

I left click on one of the file selection menus like "type filetype image/video resultion or fps" then select additional formats, like deselecting 1080p video, so that they are not shown in the list below the menus . and I see that that video only has 720 max in the list below. so far so good.

repeat the same process but this time select the 1080p so that it is show in the list below.

add another link that I know has, for example, 4k resolution.

try again to add additional variant from this video (that has 4k) I see that 4k is now selected.

I select it. so that it is show in the list below .

go again and repeat the part about first link video and deselect 1080p.

and then try to add the 4k video and then the its variants.
I see that 4k is deselcted.

this is the bug.

so every time a user changes a selective from youtube plugin it deselects all the formats that that particular video doesn't support so they are not show for that video.

but this causes the user to have to re-enable them for other videos that DO support them.

and this happens all the time ( a re-producible bug).

how can I set it so that when I change for example removing the h264 option from a video selections for a video that only support vp9 and h264 ( so the result is only vp9 for that video) then next time I add another video that for example supports av1 I dont have to go and re-enable that av1 option that got disabled in that last video selection?

I hope it was somewhat clear what I typed.
Reply With Quote
  #4131  
Old 30.11.2020, 01:22
enjikari enjikari is offline
Super Loader
 
Join Date: Feb 2018
Posts: 29
Default JD2 Not Grabbing YT Videos?

< deleted >

Issue was just me.

Last edited by enjikari; 30.11.2020 at 02:03.
Reply With Quote
  #4132  
Old 30.11.2020, 15:35
pspzockerscene's Avatar
pspzockerscene pspzockerscene is offline
Community Manager
 
Join Date: Mar 2009
Location: Deutschland
Posts: 70,796
Default

Merged YT threads.
__________________
JD Supporter, Plugin Dev. & Community Manager

Erste Schritte & Tutorials || JDownloader 2 Setup Download
Spoiler:

A users' JD crashes and the first thing to ask is:
Quote:
Originally Posted by Jiaz View Post
Do you have Nero installed?
Reply With Quote
  #4133  
Old 30.11.2020, 19:54
Jiaz's Avatar
Jiaz Jiaz is offline
JD Manager
 
Join Date: Mar 2009
Location: Germany
Posts: 79,128
Default

@interceptorchamp:
@mz168:
I'm sorry but I made a misstake with USER/USERNAME tag.
sorry for the inconvenience. will be fixed with next update

@Ney:
@maissaz:
currently broken, see https://board.jdownloader.org/showpo...postcount=3980
__________________
JD-Dev & Server-Admin

Last edited by Jiaz; 30.11.2020 at 19:57.
Reply With Quote
  #4134  
Old 30.11.2020, 20:17
Ney Ney is offline
I will play nice!
 
Join Date: Nov 2020
Posts: 2
Default

Quote:
Originally Posted by Jiaz View Post
@Ney:
@maissaz:
currently broken, see **External links are only visible to Support Staff**...
Thank you for your answer I understand better where the problem comes from. Is it not possible to have a link directing to page 2 of the playlist in order to download the videos starting with video 101?

Something like:

youtube.com/c/myyoutubechannel/videos = videos 1 to 100
youtube.com/c/myyoutubechannel/videos/page/2 = videos 101 to 201

I don't necessarily want to download the whole channel at once, I just wish I didn't have to download each video one by one.
Reply With Quote
  #4135  
Old 30.11.2020, 20:28
Jiaz's Avatar
Jiaz Jiaz is offline
JD Manager
 
Join Date: Mar 2009
Location: Germany
Posts: 79,128
Default

@Ney: no, that's not possible because the pagination is broken, that means grabbing the next few items. I will look into that soon
__________________
JD-Dev & Server-Admin
Reply With Quote
  #4136  
Old 30.11.2020, 20:38
Jiaz's Avatar
Jiaz Jiaz is offline
JD Manager
 
Join Date: Mar 2009
Location: Germany
Posts: 79,128
Default

Update that fixes USER/USERNAME tag is live
__________________
JD-Dev & Server-Admin
Reply With Quote
  #4137  
Old 30.11.2020, 22:47
esszeh esszeh is offline
Modem User
 
Join Date: Apr 2020
Posts: 4
Default

I have currenty an issue with some videos. I can`t download some videos, my linkgrabber doesn even show them.

Example:

**External links are only visible to Support Staff****External links are only visible to Support Staff**
Reply With Quote
  #4138  
Old 01.12.2020, 11:36
Jiaz's Avatar
Jiaz Jiaz is offline
JD Manager
 
Join Date: Mar 2009
Location: Germany
Posts: 79,128
Default

@esszeh: Please create a debug log. Enable Settings->Advanced Settings->Log.debugmodeenabled
restart JDownloader, recreate issue and create log, see https://support.jdownloader.org/Know...d-session-logs
and post shown logID here
__________________
JD-Dev & Server-Admin
Reply With Quote
  #4139  
Old 01.12.2020, 18:26
esszeh esszeh is offline
Modem User
 
Join Date: Apr 2020
Posts: 4
Default

Here is my log after an unsuccesful try to grab the video:

01.12.20 17.25.13 <--> 01.12.20 17.26.00 jdlog://1409425302851/
Reply With Quote
  #4140  
Old 01.12.2020, 18:58
Jiaz's Avatar
Jiaz Jiaz is offline
JD Manager
 
Join Date: Mar 2009
Location: Germany
Posts: 79,128
Default

@esszeh:
Have you changed your plugin settings? Settings->Plugins->youtube, try to reset
create new log with next update, I've added more debug infos
__________________
JD-Dev & Server-Admin
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

All times are GMT +2. The time now is 23:48.
Provided By AppWork GmbH | Privacy | Imprint
Parts of the Design are used from Kirsch designed by Andrew & Austin
Powered by vBulletin® Version 3.8.10 Beta 1
Copyright ©2000 - 2024, Jelsoft Enterprises Ltd.