JDownloader Community - Appwork GmbH
 

Reply
 
Thread Tools Display Modes
  #1  
Old 24.08.2011, 08:36
ScorpionBlack
Guest
 
Posts: n/a
Default Problem with Java 7 on Ubuntu

Recently updated version of Java on a Windows PC to version 7 and JDownloader works great. Then update Java 7 on Ubuntu, but when you try running them JUpdate JDownloader or crashes. And is not executed. Shows a problem of lack of a file in the installation of Java. I run other Java applications and work perfectly. The funny thing is that in Windows works perfectly JDownloader. The version of Java 6 did not present that problem. I hope I can say it is. Not to return to Java 6. Thank you.

Last edited by Jiaz; 24.08.2011 at 17:23.
Reply With Quote
  #2  
Old 24.08.2011, 09:37
remi
Guest
 
Posts: n/a
Default

JRE (1.)7 isn't stable yet. Replace it with a more stable version, like JRE (1.)6 update 21. See "**External links are only visible to Support Staff**.

Before you revert to a working version of java, please also provide a complete and detailed log.
Reply With Quote
  #3  
Old 24.08.2011, 09:49
Jiaz's Avatar
Jiaz Jiaz is offline
JD Manager
 
Join Date: Mar 2009
Location: Germany
Posts: 59,535
Default

use the latest version of 1.7 and it works perfectly fine
make sure not to use 1.7 b66!
what does the hs_err files contain?
__________________
JD-Dev & Server-Admin
Reply With Quote
  #4  
Old 24.08.2011, 17:14
ScorpionBlack
Guest
 
Posts: n/a
Default

This is the Exception thats shows in terminal.


------------------------ Thread: 16 -----------------------
16 24/08/11 09:12:41 AM - INFO [jd.gui.swing.laf.LookAndFeelController(setUIManager)] -> Use Look & Feel: org.jvnet.substance.skin.SubstanceCremeLookAndFeel
16 24/08/11 09:12:42 AM - INFO [jd.JDClassLoader(getResources)] -> [jar:file:/media/Victor/JDownloader/libs/laf/substance-swingx.jar!/META-INF/substance-plugin.xml, jar:file:/media/Victor/JDownloader/libs/laf/substance.jar!/META-INF/substance-plugin.xml, jar:file:/media/Victor/JDownloader/libs/laf/substance-swingx.jar!/META-INF/substance-plugin.xml, jar:file:/media/Victor/JDownloader/libs/laf/substance.jar!/META-INF/substance-plugin.xml]
16 24/08/11 09:12:45 AM - WARNING [jd.http.Browser(init)] -> Installed JS Hotfix
Exception in thread "AWT-EventQueue-0" java.security.ProviderException: Library /usr/lib/libsoftokn3.so does not exist
at sun.security.pkcs11.SunPKCS11.<init>(SunPKCS11.java:292)
at sun.security.pkcs11.SunPKCS11.<init>(SunPKCS11.java:103)
at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:57)
at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)
at java.lang.reflect.Constructor.newInstance(Constructor.java:525)
at sun.security.jca.ProviderConfig$2.run(ProviderConfig.java:224)
at sun.security.jca.ProviderConfig$2.run(ProviderConfig.java:206)
at java.security.AccessController.doPrivileged(Native Method)
at sun.security.jca.ProviderConfig.doLoadProvider(ProviderConfig.java:206)
at sun.security.jca.ProviderConfig.getProvider(ProviderConfig.java:187)
at sun.security.jca.ProviderList.getProvider(ProviderList.java:232)
at sun.security.jca.ProviderList.getIndex(ProviderList.java:262)
at sun.security.jca.ProviderList.getProviderConfig(ProviderList.java:246)
at sun.security.jca.ProviderList.getProvider(ProviderList.java:252)
at java.security.Security.getProvider(Security.java:474)
at jd.http.XTrustProvider.install(XTrustProvider.java:70)
at jd.http.Browser.init(Browser.java:1330)
at jd.JDInit.initBrowser(Unknown Source)
at jd.JDInit.init(Unknown Source)
at jd.Main.go(Unknown Source)
at jd.Main.access$0(Unknown Source)
at jd.Main$3.run(Unknown Source)
at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:251)
at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:705)
at java.awt.EventQueue.access$000(EventQueue.java:101)
at java.awt.EventQueue$3.run(EventQueue.java:666)
at java.awt.EventQueue$3.run(EventQueue.java:664)
at java.security.AccessController.doPrivileged(Native Method)
at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:675)
at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:211)
at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:128)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:117)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:113)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:105)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:90)
Reply With Quote
  #5  
Old 24.08.2011, 17:23
Jiaz's Avatar
Jiaz Jiaz is offline
JD Manager
 
Join Date: Mar 2009
Location: Germany
Posts: 59,535
Default

broken java installation
Library /usr/lib/libsoftokn3.so does not exist
this is not a jdownloader/java error. the system library is missing
__________________
JD-Dev & Server-Admin
Reply With Quote
  #6  
Old 25.08.2011, 07:42
ScorpionBlack
Guest
 
Posts: n/a
Default

Thank you.

I researched and if this version of Java was wrong. I set Java and runs fine now JDownloader.

Sorry, and thanks again.

Greetings.
Reply With Quote
  #7  
Old 25.08.2011, 09:28
Jiaz's Avatar
Jiaz Jiaz is offline
JD Manager
 
Join Date: Mar 2009
Location: Germany
Posts: 59,535
Default

thanks for feedback
__________________
JD-Dev & Server-Admin
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

All times are GMT +2. The time now is 04:11.
Provided By AppWork GmbH | Privacy | Imprint
Parts of the Design are used from Kirsch designed by Andrew & Austin
Powered by vBulletin® Version 3.8.10 Beta 1
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.