JDownloader Community - Appwork GmbH
 

Reply
 
Thread Tools Display Modes
  #1  
Old 17.10.2021, 03:34
Nagrand Nagrand is offline
Modem User
 
Join Date: Oct 2021
Posts: 1
Default Cannot set Direct Gateway for two different interfaces (connection manager)

Hello,

I have a raspberry pi with raspbian onboard
Code:
pi@raspberrypi:~ $ cat /etc/os-release 
PRETTY_NAME="Raspbian GNU/Linux 10 (buster)"
Code:
pi@raspberrypi:~ $ java -version
openjdk version "11.0.9.1" 2020-11-04
OpenJDK Runtime Environment (build 11.0.9.1+1-post-Raspbian-1deb10u2)
OpenJDK Server VM (build 11.0.9.1+1-post-Raspbian-1deb10u2, mixed mode)
My network setup:
First internet provider accessible via eth1 interface
Second internet provider accessible by wlan0 interface

Code:
pi@raspberrypi:~ $ ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether b8:27:eb:c4:e2:3d brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.2/24 brd 192.168.1.255 scope global dynamic noprefixroute eth0
       valid_lft 64072sec preferred_lft 53272sec
    inet6 fe80::f68f:be19:9d64:6b8f/64 scope link 
       valid_lft forever preferred_lft forever
3: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether b8:27:eb:91:b7:68 brd ff:ff:ff:ff:ff:ff
    inet 192.168.2.166/24 brd 192.168.2.255 scope global dynamic noprefixroute wlan0
       valid_lft 41127sec preferred_lft 35727sec
    inet6 fe80::ee71:5e63:2491:6617/64 scope link 
       valid_lft forever preferred_lft forever
4: docker0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default 
    link/ether 02:42:8d:ab:46:f6 brd ff:ff:ff:ff:ff:ff
    inet 172.17.0.1/16 brd 172.17.255.255 scope global docker0
       valid_lft forever preferred_lft forever
    inet6 fe80::42:8dff:feab:46f6/64 scope link 
       valid_lft forever preferred_lft forever
6: veth30e4056@if5: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master docker0 state UP group default 
    link/ether 96:1e:64:26:79:65 brd ff:ff:ff:ff:ff:ff link-netnsid 0
    inet 169.254.24.176/16 brd 169.254.255.255 scope global noprefixroute veth30e4056
       valid_lft forever preferred_lft forever
    inet6 fe80::941e:64ff:fe26:7965/64 scope link 
       valid_lft forever preferred_lft forever
Code:
pi@raspberrypi:~ $ ip r
default via 192.168.1.1 dev eth0 proto dhcp src 192.168.1.2 metric 202 
default via 192.168.2.1 dev wlan0 proto dhcp src 192.168.2.166 metric 303 mtu 1500 
169.254.0.0/16 dev veth30e4056 scope link src 169.254.24.176 metric 206 
172.17.0.0/16 dev docker0 proto kernel scope link src 172.17.0.1 
192.168.1.0/24 dev eth0 proto dhcp scope link src 192.168.1.2 metric 202 
192.168.2.0/24 dev wlan0 proto dhcp scope link src 192.168.2.166 metric 303 mtu 1500
I want to use both of them from JDownloader. I fallowed instruction from https://board.jdownloader.org/showpo...82&postcount=2
My exported proxies list is:
Code:
none://
direct://wlan0
direct://eth0
"no proxy" is disabled, eth0 is enabled, wlan0 also is enabled.
Unfortunately wlan0 is going red right after first try of downloading by it:


No idea how to fix it :(

Logs: 17.10.21 02.07.23 <--> 17.10.21 02.27.49 jdlog://7739825302851/

issue seems to be similar with: https://board.jdownloader.org/showth...direct+gateway
Attached Images
File Type: png Selection_178.png (79.7 KB, 5 views)
Reply With Quote
  #2  
Old 18.10.2021, 12:01
Jiaz's Avatar
Jiaz Jiaz is offline
JD Manager
 
Join Date: Mar 2009
Location: Germany
Posts: 72,936
Default

Does network work fine when you disable the lan/eth0 connection and just use wlan connectivity?
disable lan/eth0 and just use none in JDownloader and check if it all works as expected and correct network/gateway is used.
Also please try to use direct://IPofNetworkDevice instead of name
also check routing table as there must be a routing table entry for 0.0.0.0 for the wlan0 network
__________________
JD-Dev & Server-Admin
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

All times are GMT +2. The time now is 07:04.
Provided By AppWork GmbH | Privacy | Imprint
Parts of the Design are used from Kirsch designed by Andrew & Austin
Powered by vBulletin® Version 3.8.10 Beta 1
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.