JDownloader Community - Appwork GmbH
 

Reply
 
Thread Tools Display Modes
  #1  
Old 05.03.2017, 13:24
officiallyme officiallyme is offline
Junior Loader
 
Join Date: Feb 2017
Posts: 12
Default Weird extraction behaviour on arm server

Hi,
I am experiencing some weird behaviour during extraction. I am running jDownloader on a Zyxel NAS (NSA325v2) with ARM processor.

For some reason the filename and pathname are lost during extraction.

Instead of "filename.mkv" it creates "SJDKEOJ~.mkv" etc.

I cannot see any logic in the weird naming of the files. And some files work and some do not. Even though they are from the same source, so using the same original archiving software.
It seems completely random which files are extracted properly and which are not.

I have enabled hash checking. And it seems that all the files are still intact. They simply have weird names so I have no idea what they are and I have to check each individual file and countercheck what it could be :-D

Anybody have any ideas?

Is it possible that the ARM version has problems extracting files with German etc. or maybe has problems with file names containing spaces or something?

Last edited by officiallyme; 05.03.2017 at 13:32.
Reply With Quote
  #2  
Old 06.03.2017, 13:27
Jiaz's Avatar
Jiaz Jiaz is offline
JD Manager
 
Join Date: Mar 2009
Location: Germany
Posts: 51,063
Default

You have set wrong/invalid LOCALE. Java relies on correct locale environment settings.
~ happens when it is wrong, for example https://board.jdownloader.org/showth...=export+locale

# set locales
export LC_ALL=de_DE.UTF-8
export LANG=de_DE.UTF-8
export LANGUAGE=de_DE.UTF-8
java -jar JDownloader.jar.....
__________________
JD-Dev & Server-Admin
Reply With Quote
  #3  
Old 06.03.2017, 17:58
officiallyme officiallyme is offline
Junior Loader
 
Join Date: Feb 2017
Posts: 12
Default

Hi,
thank you for your reply. Unfortunately I get an error:
Quote:
root@NSA325:/e-data# ./jd2start.sh start
./jd2start.sh: line 3: warning: setlocale: LC_ALL: cannot change locale (de_DE.UTF-8)
Starting JDownloader 2 Headless: JDownloader2.
root@NSA325:/e-data#
Do I need to change something else too?

Code:
#!/ffp/bin/sh
# set locales
export LC_ALL=de_DE.UTF-8
export LANG=de_DE.UTF-8
export LANGUAGE=de_DE.UTF-8
DESC="JDownloader 2 Headless"
NAME=JDownloader2
PIDFILE=/e-data/jd2/JDownloader.pid
USER=admin
RUN_AS=admin
COMMAND="/e-data/java/jre/bin/java -- -jar /e-data/jd2/JDownloader.jar"

d_start() {
sleep 10
start-stop-daemon --start --quiet --background --pidfile $PIDFILE --user $USER --chuid $RUN_AS --exec $COMMAND
}

d_stop() {
start-stop-daemon --stop --quiet --pidfile $PIDFILE
sleep 10
if [ -e $PIDFILE ]
then rm $PIDFILE
fi
}

case $1 in
start)
echo -n "Starting $DESC: $NAME"
d_start
echo "."
;;
stop)
echo -n "Stopping $DESC: $NAME"
d_stop
echo "."
;;
restart)
echo* -n "Restarting $DESC: $NAME"
d_stop
sleep 10
d_start
echo ":"
;;
*)
echo "usage: $NAME [start|stop|restart]"
exit 1
;;
esac


exit

Last edited by officiallyme; 06.03.2017 at 18:10.
Reply With Quote
  #4  
Old 06.03.2017, 18:04
Jiaz's Avatar
Jiaz Jiaz is offline
JD Manager
 
Join Date: Mar 2009
Location: Germany
Posts: 51,063
Default

instead of de_DE use en_EN then
you should avoid using start-stop deamin as it might cause IO activity that keeps the disk alive.

try with changed locale and it should work. but I'm not sure if start-stop-deamon forward environment variables
__________________
JD-Dev & Server-Admin
Reply With Quote
  #5  
Old 06.03.2017, 18:11
officiallyme officiallyme is offline
Junior Loader
 
Join Date: Feb 2017
Posts: 12
Default

Hi,
same error message.

If I manually call the export commands, only the LC_ALL fails. I wanted to check the locale settings but the command just returned "locale: command not found"
Reply With Quote
  #6  
Old 06.03.2017, 18:16
Jiaz's Avatar
Jiaz Jiaz is offline
JD Manager
 
Join Date: Mar 2009
Location: Germany
Posts: 51,063
Default

don't use start-stop-daemon and start JDownloader directly or
use a startscript, something like

#!/bin/bash
export LC_ALL=de_DE.UTF-8
export LANG=de_DE.UTF-8
export LANGUAGE=de_DE.UTF-8
/e-data/java/jre/bin/java -jar /e-data/jd2/JDownloader.jar &

chmod +x the script
and then start this script from your start-stop script
__________________
JD-Dev & Server-Admin
Reply With Quote
  #7  
Old 06.03.2017, 18:22
officiallyme officiallyme is offline
Junior Loader
 
Join Date: Feb 2017
Posts: 12
Default

I can do that but the problem remains that

export LC_ALL=de_DE.UTF-8

results in an

-sh: warning: setlocale: LC_ALL: cannot change locale (de_DE.UTF-8)

This is independent of how JDownloader is called
Reply With Quote
  #8  
Old 06.03.2017, 18:23
Jiaz's Avatar
Jiaz Jiaz is offline
JD Manager
 
Join Date: Mar 2009
Location: Germany
Posts: 51,063
Default

It's just a warning. Important part is that JDownloader is started with those variables set.
__________________
JD-Dev & Server-Admin
Reply With Quote
  #9  
Old 06.03.2017, 18:24
officiallyme officiallyme is offline
Junior Loader
 
Join Date: Feb 2017
Posts: 12
Default

OK. Is there a way to check if JDownloader receiver the variables properly? Or will I have to wait for a few more extraction and see if they work properly?
Reply With Quote
  #10  
Old 06.03.2017, 18:48
Jiaz's Avatar
Jiaz Jiaz is offline
JD Manager
 
Join Date: Mar 2009
Location: Germany
Posts: 51,063
Default

You can also do a simple download with special chars
for example cdn8.appwork.org/Test.
__________________
JD-Dev & Server-Admin
Reply With Quote
  #11  
Old 07.03.2017, 19:31
officiallyme officiallyme is offline
Junior Loader
 
Join Date: Feb 2017
Posts: 12
Default

:-D
Cannot even add that to the download list via my.jdownloader.org.
It does not recognize it as a downloadlink :-D

Tried a file I found online (**External links are only visible to Supporters****External links are only visible to Supporters**) but it is not working.

It is extracted as JSI2F0~T.PDF

Last edited by officiallyme; 07.03.2017 at 19:36.
Reply With Quote
  #12  
Old 07.03.2017, 19:49
Jiaz's Avatar
Jiaz Jiaz is offline
JD Manager
 
Join Date: Mar 2009
Location: Germany
Posts: 51,063
Default

I suggest we do a teamviewer session so we can check/fix it together. Just send me an e-mail to support@jdownloader.org.

The proper testurl is
cdn8.appwork.org/Test%C3%9C%C3%96%C3%84%C3%BC%C3%B6%C3%A4.%C3%BC%C3%BC%C3%BC

;)
__________________
JD-Dev & Server-Admin
Reply With Quote
  #13  
Old 17.03.2017, 12:21
officiallyme officiallyme is offline
Junior Loader
 
Join Date: Feb 2017
Posts: 12
Default

I just wanted to post the solution in case someone else had the same issue (ony Uyxel NSA325v2 or similar).
Mister XY from the Zyxelforum suggested to use the following, which then worked:

Code:
export LANG="de_DE.UTF-8"
export LC_COLLATE="C"
Nothing else needed. No export LANG or LANGUAGE.

:)
Reply With Quote
  #14  
Old 20.03.2017, 18:06
Jiaz's Avatar
Jiaz Jiaz is offline
JD Manager
 
Join Date: Mar 2009
Location: Germany
Posts: 51,063
Default

I posted in zyxelforum as well. I think difference is between sh/bash
export key=value
export key="value"

Thanks for the feedback!
__________________
JD-Dev & Server-Admin
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

All times are GMT +2. The time now is 14:53.
Provided By AppWork GmbH | Privacy | Imprint
Parts of the Design are used from Kirsch designed by Andrew & Austin
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.