JDownloader Community - Appwork GmbH
 

Reply
 
Thread Tools Display Modes
  #1  
Old 04.12.2011, 14:05
MainScreen
Guest
 
Posts: n/a
Default Probleme mit "CRC Fehler" und "Verbindung verloren"

Guten Tag zusammen


Seit geraumer Zeit habe ich mit dem Jdownloader das Problem, dass es bei jedem Hoster (Netload, Uploaded, Share-Online und Megaupload) bei etwa jedem zweiten Download Link nach dem Download ein CRC Fehler festgestellt wird. Bei den Links von Rapidshare bricht der Download dauernd ab ("Verbindung verloren") und diese Links deaktivieren sich nach einigen Sekunden automatisch. Danach steht dort "Keine Schreiberechte auf der Festplatte".

Nach einigen Malen manuellen zurücksetzens (teilweise braucht es nur einen Anlauf, teilweise mehrere) gelingt es dann doch, die Files runterzuladen. Doch nur mit dauerndem Kontrollieren der Links und für das habe ich keine Zeit.

Ich habe schon alles mögliche versucht: Von einem anderen Computer, via W-LAN, die Netzwerkkarte deaktiviert und wieder aktiviert, Jdownloader und Java deinstalliert und danach wieder frisch installiert, von der Nightly Version auf die normale Versoin umgestiegen, ohne Antivirus (normalerweise benutze ich KIS 2011), auf eine SSD Festplatte heruntergeladen, und, und, und...
Doch leider hat das alles überhaupt nichts gebracht.

PS. Eine Professionelle/Hardware Firewall benutze ich nicht. Der Name meines Routers lautet "Thomson TWG 870".
Ich verwende Windows 7 Enterprise x64, habe es jedoch auch schon auf einem Computer mit Windows 7 Enterprise x86 versucht.

Ich habe dieses Problem seit mindestens ein bis zwei Monaten. Doch in den letzten Tagen wurde es immer schlimmer: Jetzt gelingt es nur noch bei der Hälfte der Links, diese zu downloaden ohne dass ein Fehler auftritt. Und daher suche ich mal hier, bei den Machern des Programmes, um Hilfe.

Und hier noch das Logfile:


Ich Hoffe, Ihr könnt mir weiterhelfen


Grüsse, MainScreen

Last edited by Jiaz; 15.12.2011 at 17:01.
Reply With Quote
  #2  
Old 04.12.2011, 19:29
pspzockerscene's Avatar
pspzockerscene pspzockerscene is offline
Community Manager
 
Join Date: Mar 2009
Location: Deutschland
Posts: 48,758
Default

Nutzt du nen Proxy?
Wie viele max. Verbindungen/Downloads haste eingestellt?
Ansonsten müssen hier Entwickler antworten, viel kann ich dazu nicht sagen.

GreeZ pspzockerscene
__________________

Ad-free installers || Werbefreie Installer
Windows Setup<--JD2 BETA-->Linux Setup x86 || Linux Setup x64 || Mac Setup
-----=>Support Chat<=-----
Spoiler:

A users' JD crashes and the first thing to ask is:
Quote:
Originally Posted by Jiaz View Post
Do you have Nero installed?
That's true James
Quote:
Originally Posted by James
Die Leute verstehen einfach nicht dass nur weil man mit einer Waffe auch auf Menschen schießen kann dass ein Schützenver​ein kein Ort für Amoklaufide​en ist
Reply With Quote
  #3  
Old 04.12.2011, 23:09
MainScreen
Guest
 
Posts: n/a
Default

Einen Proxy nutz' ich nicht, nein.
Verbindungen: 1 (hab's aber auch schon mit mehreren versucht. Einerseits bringts nicht wirklich viel, andererseits verbrauche ich sonst viel zu viel Traffic)
Downloads: Unterschiedlich. Teilweise 20, im Moment 10.

Ach ja. Meine Internetverbindung: 100 MBit (=12.5 Mbyte) via Kabel. Ich musste die maximale Geschwindigkeit auf etwa 10.7 MByte setzen, da ich sonst einerseits nicht mehr gut surven konnte, andererseits brach sonst teilweise die Internetverbindung zusammen.
Reply With Quote
  #4  
Old 05.12.2011, 00:27
Xavyer
Guest
 
Posts: n/a
Default

Setze mal testweise Downloadspeed auf vielleicht 200kB/s und nur einen oder zwei Downloads.
Router mal für ein paar Minuten vom Strom getrennt?
Hast du mal von nicht OCHs downloads durchgeführt.
Reply With Quote
  #5  
Old 05.12.2011, 01:39
eisbaer's Avatar
eisbaer eisbaer is offline
Ehrenmitglied
 
Join Date: Mar 2009
Posts: 3,588
Default

also das mit rapidshare kann ich bestätigen, das kommt in letzter zeit öfters vor.
sobald es bei mir wieder vorkommt, poste ich ein log.
Reply With Quote
  #6  
Old 05.12.2011, 22:43
MainScreen
Guest
 
Posts: n/a
Default

Quote:
Originally Posted by Xavyer View Post
Setze mal testweise Downloadspeed auf vielleicht 200kB/s und nur einen oder zwei Downloads.
Teste ich gerade. Gebe morgen mal ein Feedback...
EDIT: Bringt nicht viel. Auf 200 kb brachen die Downloads ständig ab (share-online). Also hat das fast mehr Fehler verursacht als ich bis anhin hatte. Nun sauge ich mit 5 MB/Sek. und es treten ständig, wie bis anhin, CRC Fehler auf.

Quote:
Originally Posted by Xavyer View Post
Router mal für ein paar Minuten vom Strom getrennt?
Ja, das habe ich schon öfters in den letzten zwei Monaten gemacht.

Quote:
Originally Posted by Xavyer View Post
Hast du mal von nicht OCHs downloads durchgeführt.
Ich habe jetzt testweise folgende Dateien geladen:
http://www.chip.de/downloads/Ubuntu-..._22592231.html
**External links are only visible to Support Staff****External links are only visible to Support Staff** (alle drei Links)

Ob es CRC-Fehler hat, wird vom JD leider nicht überprüft. Ich habe nun jedoch die ISO Dateien mit WinRAR mal entpackt. Entpackfehler habe ich bei keiner Datei gefunden. Wenn ich jedoch Dateien mit WinRAR entpacke, welche in WinRAR mit einem CRC-Fehler gekennzeichnet sind, dann gibt es auch in WinRAR CRC-Fehler. Es kann also nicht an der Überempfindlichkeit von JD leigen.

Last edited by MainScreen; 05.12.2011 at 23:02.
Reply With Quote
  #7  
Old 05.12.2011, 22:58
eisbaer's Avatar
eisbaer eisbaer is offline
Ehrenmitglied
 
Join Date: Mar 2009
Posts: 3,588
Default

hattest du die probleme nur bei dateien, wo ISO sind?
wenn ja, so ist das ein bug von jd.
JD hat probleme mit ISo im allgemeinem mit image abbildern.
Reply With Quote
  #8  
Old 05.12.2011, 23:07
MainScreen
Guest
 
Posts: n/a
Default

Nein, überhaupt nicht. Ich habe die Probleme bei rar Dateien, da ich ausschliesslich rar Dateien Downloade. Zu Testzwecken habe ich nun einmal von einer regulären Website (kein OCH) mehrere Image Dateien heruntergeladen (siehe oben. Die links sind nicht sichtbar, ist aber nicht weiter wichtig). Diese habe ich dann mit WinRAR entpackt: Es kamen keine CRC-Fehler zum Vorschein.
Reply With Quote
  #9  
Old 06.12.2011, 00:11
eisbaer's Avatar
eisbaer eisbaer is offline
Ehrenmitglied
 
Join Date: Mar 2009
Posts: 3,588
Default

ist ja auch logisch...
deine image sind ja nicht in rar gepackt, sondern nicht gepackt.
was ich meinte, sind die rar dateien wo du ladest, am ende (nach dem auspacken) image abbilder?
Reply With Quote
  #10  
Old 07.12.2011, 01:12
MainScreen
Guest
 
Posts: n/a
Default

Aber beim entpacken mit WinRAR der Test Downloads (nicht gepackte ISO Dateien) hätten der Regel nach trotzdem CRC-Fehler auftreten sollen...

Nein, die entpackten Dateien sind keine ISO Files sondern mkv (Matroska) und avi Dateien.
Reply With Quote
  #11  
Old 08.12.2011, 22:48
eisbaer's Avatar
eisbaer eisbaer is offline
Ehrenmitglied
 
Join Date: Mar 2009
Posts: 3,588
Default

Quote:
Originally Posted by eisbaer View Post
also das mit rapidshare kann ich bestätigen, das kommt in letzter zeit öfters vor.
sobald es bei mir wieder vorkommt, poste ich ein log.
ist zwar nicht verbindung verloren, aber dafür hoster offline.
das passiert mir heute zum zweiten mal. hier mein log
http://jdownloader.org/pastebin/63558
Reply With Quote
  #12  
Old 12.12.2011, 04:04
MainScreen
Guest
 
Posts: n/a
Default

Ich muss meine Aussage korrigieren:
Ich habe nun mal die Downloadgeschwindigkeit auf 50kb/s gedrosselt, da ich im Moment einige 200MB grossen RAR Dateien am herunterladen bin und es bei diesen zu 90% einen CRC Fehler gab. Mit den eingestellten 500kb/s sind es möglicherweise etwa 5-10%, wo es einen CRC Fehler gibt. Dazu noch einige "Download Unvollständig", jedoch ist das nicht nennenswert viel.

Also: Das Problem mit den CRC Fehlern hat eindeutig mit der Downloadgeschwindigkeit zu tun!
Reply With Quote
  #13  
Old 15.12.2011, 16:57
Jiaz's Avatar
Jiaz Jiaz is offline
JD Manager
 
Join Date: Mar 2009
Location: Germany
Posts: 66,053
Default

Welche Firewall/Av nutzt du?
Es gibt router die bei schnellen speed crc verursachen (muss ich aber auch erst die boardsuche heranziehen). Ich würde hier mal firewall/av im router checken
__________________
JD-Dev & Server-Admin
Reply With Quote
  #14  
Old 17.12.2011, 13:26
MainScreen
Guest
 
Posts: n/a
Default

Eine Professionelle Firewall nutze ich noch keine.
Als AV benutze ich Kaspersky Internet Security 2011.
Und als Router benutze ich den "Thomson TWG 870".
Aber wie schon gesagt: Ich hatte bis vor etwa 2-3 Monaten nie Probleme mit den CRC-Fehlern. Und damals verwendete ich genau den selben Router.
Reply With Quote
  #15  
Old 17.12.2011, 23:22
MainScreen
Guest
 
Posts: n/a
Default

Ich habe das Problem lösen können!

Also:
Nach einigen Tagen hat sich nun endlich mein Internetanbieter (Cablecom) zurückgemeldet. Das Problem liegt an der Firmware des Routers und ich bin scheinbar nicht der einzige Betroffene.
Die Lösung:
- Im Router Menu (192.168.0.1) unter "Switch Mode" auf "Disable Mode" stellen und "Apply" drücken.
- Danach startet der Router neu.
- Nach etwa zwei Minuten ist man wieder mit dem Internet verbunden und ab sofort funktioniert auch das Downloaden wieder ordnungsgemäss
- Der Router bekommt durch diese Änderung eine neue IP-Adresse: 192.168.100.1

Ich hoffe, ich konnte dem einen oder anderen Cablecom Kunden hiermit helfen. Laut dem Support sollte bald ein Firware-Update erscheinen, das diesen Fehler behebt...
PS: Durch diese Änderung funktioniert das WLAN nicht mehr richtig. Ich werde mich morgen nochmals bei der Cablecom erkundigen, wie man das WLAN unter den geänderten Einstellungen zum laufen bekommt.

Last edited by MainScreen; 17.12.2011 at 23:25.
Reply With Quote
  #16  
Old 18.12.2011, 09:43
Jiaz's Avatar
Jiaz Jiaz is offline
JD Manager
 
Join Date: Mar 2009
Location: Germany
Posts: 66,053
Default

danke für das feedback. sofern du mehr infos hast, wären evtl auch links und screenshots hilfreich. dann können wir das in unser wiki aufnehmen
danke
__________________
JD-Dev & Server-Admin
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

All times are GMT +2. The time now is 19:18.
Provided By AppWork GmbH | Privacy | Imprint
Parts of the Design are used from Kirsch designed by Andrew & Austin
Powered by vBulletin® Version 3.8.10 Beta 1
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.