JDownloader Community - Appwork GmbH
 

Reply
 
Thread Tools Display Modes
  #1  
Old 09.01.2020, 02:19
user7 user7 is offline
Modem User
 
Join Date: Jan 2020
Posts: 1
Default I cannot set the correct locale for creating directory and file names in utf8

Hi. I need help with correct encoding / environment setup
I added link like this:

Link: **External links are only visible to Support Staff****External links are only visible to Support Staff**
Package name: Čarovnř
Subfolder by package: checked
Expected filename: Veronika Rabada - V tichu _ Titulnß pieseň k rozprßvke ČAROVNŢ KAMIENOK..mp4

I created link, restart jDownloader and after start, jDownloader create this directory and file (with question mark instead of local accent letters): /home/osmc/download/\?arovn\?/Veronika\ Rabada\ -\ V\ tichu\ _\ Tituln\?\ piese\?\ k\ rozpr\?vke\ \?AROVN\?\ KAMIENOK..mp4\ _\ on-line\ video.mp4

Log from this run is uploaded.
This is my log id: jdlog://9266330900751

If I create folder "čarovnř" using the console then it ls created correctly and I see everywhere (console, ui, kodi) "čarovnř".

jDownloader is in version Rev: #41643.System information:
Code:
-- REMOTE SYSTEM -------------------------------------------
OS: Linux (LINUX 32Bit) (arm 32Bit)
JAVA: 1.8.0_232-8u232-b09-1~deb9u1-b09 *(32Bit) *(headless)
Oracle Corporation
OpenJDK Client VM
JAVA HEAP: 31.54 MB / 42.05 MB / 259.52 MB
STARTUP TIME: 00h 09m 07s (startup time: 09.01.20 00:47)
Running script for start jDownloader is systemd service.
Locales are set in environment part of the service.
File: /etc/systemd/system/jdownloader.service

Code:
[Unit]
Description=JDownloader2 headless service
After=network.target

[Service]
# User=osmc # not all jDownloader services working with non root user
Type=simple
Environment=JD_HOME=/opt/JDownloader LANG="en_US.UTF-8" LC_CTYPE="en_US.UTF-8" LC_COLLATE="C"
WorkingDirectory=/opt/JDownloader
ExecStart=/usr/bin/java -Dsun.jnu.encoding=UTF-8 -Dfile.encoding=UTF-8 -Djava.awt.headless=true -jar /opt/JDownloader/JDownloader.jar
RemainAfterExit=yes
Restart=on-failure
RestartSec=10s

[Install]
WantedBy=multi-user.target
My hardware is Vero 4k and system locale settings are:
Code:
root@a:/home/osmc# locale
LANG=en_US.UTF-8
LANGUAGE=en_US
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=
root@a:/home/osmc# localectl
* *System Locale: LANG=en_US.UTF-8
* * * * * * * * * LANGUAGE=en_US
* * * *VC Keymap: n/a
* * * X11 Layout: n/a
Can you please help me to configure jDownloader (or maybe the system) to create correct directory and file names?
I read several articles here but in no way I couldn't set up jDownloader or the system correctly.

Thank you in advance for your help with this setup.

u7
Reply With Quote
  #2  
Old 09.01.2020, 04:13
raztoki's Avatar
raztoki raztoki is offline
English Supporter
 
Join Date: Apr 2010
Location: Australia
Posts: 16,567
Default

please wait for jiaz to respond
__________________
raztoki @ jDownloader reporter/developer
http://svn.jdownloader.org/users/170

Don't fight the system, use it to your advantage. :]
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

All times are GMT +2. The time now is 02:03.
Provided By AppWork GmbH | Privacy | Imprint
Parts of the Design are used from Kirsch designed by Andrew & Austin
Powered by vBulletin® Version 3.8.10 Beta 1
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.