JDownloader Community - Appwork GmbH
 

Reply
 
Thread Tools Display Modes
  #1  
Old 07.07.2016, 12:46
charonme charonme is offline
Mega Loader
 
Join Date: Feb 2012
Posts: 61
Default how to stop asking for captchas when AFK

I'm not sitting at my computer all day long, I often leave the computer and sometimes when this happens, the next queued file for download is requested, a captcha is shown, timeouts because I'm AFK, next file is requested, captcha timeouts and so on for all the queued files.

Is there a setting I could use that would stop JDownloader asking for more captchas if the previous captcha timed out and wait for me instead?

Thanks!
Reply With Quote
  #2  
Old 07.07.2016, 12:58
raztoki's Avatar
raztoki raztoki is offline
English Supporter
 
Join Date: Apr 2010
Location: Australia
Posts: 16,195
Default

enable, silent mode and minimise to the tray when away ?
else enable CES provider in captcha settings.

raztoki
__________________
raztoki @ jDownloader reporter/developer
http://svn.jdownloader.org/users/170

Don't fight the system, use it to your advantage. :]
Reply With Quote
  #3  
Old 07.07.2016, 13:49
Jiaz's Avatar
Jiaz Jiaz is offline
JD Manager
 
Join Date: Mar 2009
Location: Germany
Posts: 65,398
Default

Settings-Advanced Settings-CaptchaSettings.captchamode and set SKIP_ALL.
JDownloader will not try / ask for captchas then
__________________
JD-Dev & Server-Admin
Reply With Quote
  #4  
Old 07.07.2016, 14:06
charonme charonme is offline
Mega Loader
 
Join Date: Feb 2012
Posts: 61
Default

I tried enable silent mode, but after the first captcha timeout the file got skipped and the next file captcha was requested, so this didn't help.

I didn't see any "CES provider" setting in captcha settings, so I couldn't try that.

I tried setting captchamode to SKIP_ALL, but all the queued files are now marked "skipped" and can't even be resumed. In an hour or so I'll see what happens when the current file download will finish, but I doubt the next queued file will be requested since they are all marked as "skipped" now.
Reply With Quote
  #5  
Old 07.07.2016, 14:22
raztoki's Avatar
raztoki raztoki is offline
English Supporter
 
Join Date: Apr 2010
Location: Australia
Posts: 16,195
Default

bottom right hand corner of jd, has skipped disk you can right click on that and clear all the skipped status, or you can also do it via right click context.
__________________
raztoki @ jDownloader reporter/developer
http://svn.jdownloader.org/users/170

Don't fight the system, use it to your advantage. :]
Reply With Quote
  #6  
Old 07.07.2016, 14:39
Jiaz's Avatar
Jiaz Jiaz is offline
JD Manager
 
Join Date: Mar 2009
Location: Germany
Posts: 65,398
Default

Hmm? What do you want to happen?
SKIP_ALL -> no Downloads that need captcha will start
Or you have to answer Captcha Dialogs. Silent Mode will only prevent Captcha Popup but you will still have to solve them remotely or the download will skip too
__________________
JD-Dev & Server-Admin
Reply With Quote
  #7  
Old 07.07.2016, 14:43
charonme charonme is offline
Mega Loader
 
Join Date: Feb 2012
Posts: 61
Default

I set the CaptchaSettings.captchamode to SKIP_ALL and after a file finished downloading the whole JDownloader stopped and didn't even request the next queued file. This doesn't help and is not what I asked.

It would be much more useful if after a captcha timeout JDownloader wouldn't request following files, but instead would display a message/popup/dialog which I would click at when I return to the computer and the same queued file would be requested again.
Reply With Quote
  #8  
Old 07.07.2016, 14:46
Jiaz's Avatar
Jiaz Jiaz is offline
JD Manager
 
Join Date: Mar 2009
Location: Germany
Posts: 65,398
Default

At the bottom right you can simply unskip all skipped links. with a single click
Or a simple start/play button will also unskip those skipped links.
__________________
JD-Dev & Server-Admin
Reply With Quote
  #9  
Old 07.07.2016, 15:26
charonme charonme is offline
Mega Loader
 
Join Date: Feb 2012
Posts: 61
Default

Current JD behavior: when JD requests a queued file a captcha dialog pops up and if there is no activity on the computer the timeout expires. After that:

Current behavior I'd like to change: the file is marked as "skipped" and immediately the next queued file is requested, repeating this behavior until all the queued files get skipped or I return to the computer.

What I have to do now when I return to the computer:
I have to cancel current captcha dialog, because that's not the file I want to download (it's out of order). Resume previous skipped files, cancel other captcha windows which don't belong to the first file in the queue and finally wait for the first resumed file in queue to be requested.

How I'd like JD to behave:
After a captcha timeout expires, don't request the next file. Don't skip any files, don't retry, just wait for user interaction. After user returns to computer he can click a button and continue where he left off.

Maybe I found a workaround: I found a setting "CaptchaSettings: Skip Download Link On Captcha Timeout" and turned it off. I'll see in the next couple of days if this works.

Other possibility could be setting a very long timeout for captchas, but the settings I found which appear to do this have a very low max value (only 300sec)
Reply With Quote
  #10  
Old 07.07.2016, 16:18
charonme charonme is offline
Mega Loader
 
Join Date: Feb 2012
Posts: 61
Default

Quote:
Originally Posted by charonme View Post
I found a setting "CaptchaSettings: Skip Download Link On Captcha Timeout" and turned it off. I'll see in the next couple of days if this works.
well this didn't work either. The timeout still expires after about ~5 minutes, the file is skipped and the next file is requested :(
Reply With Quote
  #11  
Old 07.07.2016, 16:46
Jiaz's Avatar
Jiaz Jiaz is offline
JD Manager
 
Join Date: Mar 2009
Location: Germany
Posts: 65,398
Default

There is no such function yet because with your logic, no download at all would start. Imagine not every download needs a captcha. Or you have a premium account and one other host requires a captcha -> blocks all future premium downloads. Customer comes back at pc only finding a captcha dialog and no finished downloads at all.
__________________
JD-Dev & Server-Admin
Reply With Quote
  #12  
Old 07.07.2016, 16:48
Jiaz's Avatar
Jiaz Jiaz is offline
JD Manager
 
Join Date: Mar 2009
Location: Germany
Posts: 65,398
Default

We could add a Skip all Captchas . Then all captcha downloads will not try to start, all non captcha downloads will run. You come back and only have to hit start again (automatic unskip those captcha skipped ones)
__________________
JD-Dev & Server-Admin
Reply With Quote
  #13  
Old 07.07.2016, 17:30
charonme charonme is offline
Mega Loader
 
Join Date: Feb 2012
Posts: 61
Default

Quote:
Originally Posted by Jiaz View Post
Imagine not every download needs a captcha. Or you have a premium account and one other host requires a captcha
that's why this would be an optional configurable setting only for those who want it and of course working separately per each filehost!

If it was at least possible to set the captcha timeout to a big number, this would effectively solve the problem

The problem would also be solved if disabling the setting "CaptchaSettings: Skip Download Link On Captcha Timeout" worked
Reply With Quote
  #14  
Old 07.07.2016, 17:41
dabrown dabrown is offline
Black Hole
 
Join Date: Jun 2015
Location: North America
Posts: 254
Default

That would be helpful. I tried disabling all the manual solvers so that it wouldn't ruin the captcha reputation by trying every file when I'm not present, but that simply made all the downloads (including the non-captcha ones) stop trying, not just the captcha ones. I used to use the MyJDownloader automatic captchasolver but that was apparently turned off on the server end in April or May, so I have no need for it to try captcha links when I'm not at the computer.
Reply With Quote
  #15  
Old 07.07.2016, 18:11
mgpai mgpai is offline
Script Master
 
Join Date: Sep 2013
Posts: 611
Default

@charonme

CaptchaSettings.skipdownloadlinkoncaptchatimeoutenabled works correctly as described.

"If the Dialog Countdown is reached, the link will be skipped. Disable this option to retry instead"

It keeps retrying the same link.

1 min. duration screen grab with the setting disabled.




@dabrown

Enable silent mode and set

SilentModeSettings.oncaptchaduringsilentmodeaction -> Skip the Captcha

Note: Silent mode can be triggered automatically. Check advanced setting for those options.
Reply With Quote
  #16  
Old 08.07.2016, 10:20
charonme charonme is offline
Mega Loader
 
Join Date: Feb 2012
Posts: 61
Default

Quote:
Originally Posted by mgpai View Post
CaptchaSettings.skipdownloadlinkoncaptchatimeoutenabled works correctly as described.

"If the Dialog Countdown is reached, the link will be skipped. Disable this option to retry instead"

It keeps retrying the same link.
I have this option disabled, but when I don't enter the captcha the link gets skipped and the next link is requested.

08.07.16 09.58.16 <--> 08.07.16 10.16.10 jdlog://7156871887641/
Reply With Quote
  #17  
Old 08.07.2016, 15:58
Jiaz's Avatar
Jiaz Jiaz is offline
JD Manager
 
Join Date: Mar 2009
Location: Germany
Posts: 65,398
Default

Should be working with next core update
__________________
JD-Dev & Server-Admin
Reply With Quote
  #18  
Old 08.07.2016, 16:09
Jiaz's Avatar
Jiaz Jiaz is offline
JD Manager
 
Join Date: Mar 2009
Location: Germany
Posts: 65,398
Default

With next update you can change
CaptchaTimeoutAction
to SKIP,ASK,RETRY
__________________
JD-Dev & Server-Admin

Last edited by Jiaz; 08.07.2016 at 16:47.
Reply With Quote
  #19  
Old 08.07.2016, 16:46
Jiaz's Avatar
Jiaz Jiaz is offline
JD Manager
 
Join Date: Mar 2009
Location: Germany
Posts: 65,398
Default

After next core update. set it to ASK and then there should be a dialog asking to retry/skip
__________________
JD-Dev & Server-Admin
Reply With Quote
  #20  
Old 15.07.2016, 10:22
charonme charonme is offline
Mega Loader
 
Join Date: Feb 2012
Posts: 61
Default

Great, thanks, it works now

Also, I see the "resume" function which I often used to enable disabled links now doesn't enable disabled links any more, but I see a new "enable" function
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

All times are GMT +2. The time now is 10:18.
Provided By AppWork GmbH | Privacy | Imprint
Parts of the Design are used from Kirsch designed by Andrew & Austin
Powered by vBulletin® Version 3.8.10 Beta 1
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.