JDownloader Community - Appwork GmbH
 

Reply
 
Thread Tools Display Modes
  #121  
Old 24.01.2017, 01:42
snickers2k snickers2k is offline
Mega Loader
 
Join Date: Oct 2015
Posts: 69
Default

omg.. neustes Flexget Update hat das serienXY-RSS.py plugin zerschossen. Würde mich riesig freuen wenn sich das mal jemand anschauen könnte. Habe die config bereitgestellt, gibt genug Leute die Ahnung von Plugins und PHP haben, aber außer cengoism beteiligt sich ja leider niemand...

Last edited by snickers2k; 24.01.2017 at 02:12.
Reply With Quote
  #122  
Old 24.01.2017, 18:24
CENGOiSM CENGOiSM is offline
JD Beta
 
Join Date: Jun 2015
Posts: 51
Default

Quote:
Originally Posted by snickers2k View Post
omg.. neustes Flexget Update hat das serienXY-RSS.py plugin zerschossen. Würde mich riesig freuen wenn sich das mal jemand anschauen könnte. Habe die config bereitgestellt, gibt genug Leute die Ahnung von Plugins und PHP haben, aber außer cengoism beteiligt sich ja leider niemand...
Mein eigener Code sollte wohl in erster Linie von mir selbst gepflegt werden. :D
Kann mich während der Klausurphase leider wieder weniger damit beschäftigen, und brauche noch eine Alternative zum Zyxel-NAS ala BPi.

BPi + Amazon Cloud klingt ganz cool, aber werden die Daten nicht durchleuchtet, da fallen doch sicher Filme etc. auf? Verschlüsselst du das ganze vorher? Wenn ja, wie? Schon von Cryptomator gehört?
Reply With Quote
  #123  
Old 26.01.2017, 20:20
sveni_lee sveni_lee is offline
DSL User
 
Join Date: Oct 2016
Posts: 39
Default

Quote:
Originally Posted by snickers2k View Post
omg.. neustes Flexget Update hat das serienXY-RSS.py plugin zerschossen. Würde mich riesig freuen wenn sich das mal jemand anschauen könnte. Habe die config bereitgestellt, gibt genug Leute die Ahnung von Plugins und PHP haben, aber außer cengoism beteiligt sich ja leider niemand...
was genau geht denn nicht mehr? bei mir läuft das noch ohne Fehler durch...
Reply With Quote
  #124  
Old 12.02.2017, 23:30
snickers2k snickers2k is offline
Mega Loader
 
Join Date: Oct 2015
Posts: 69
Default

Nach dem neusten Update waren einige Änderungen an der Config nötig. Serien funktionieren zwar noch, aber ohne Search - also nur per crawler. Movies geht leider auch immer noch nicht wieder. Ich bin zwar dran, aber vermutlich werde ich nachdem wieder alles funktioniert, von Leuten, die sich nicht beteiligt haben, ein paar Euro für die jeweils aktuellen Config's nehmen (falls Interesse besteht), da leider zu viel Arbeit und Zeit an mir hängen bleibt.
Reply With Quote
  #125  
Old 16.02.2017, 17:59
Trubadix Trubadix is offline
Modem User
 
Join Date: Feb 2017
Posts: 4
Default

Hi Leute,

ich habe mir jetzt auch mal ein Testsystem aufgesetzt, der abgleich mit Trakt wäre schon was feines.
JD und Filebot laufen perfekt, meldung vom Plex an Trakt auch aber Flexget bekomme ich einfach nicht zum laufen... Hätte mal jemand die aktuelle Config und Secret für mich? Suchen und ersetzen hat leider nicht gereicht.
Rest müsste ja nur install pip und Flexget sein oder?

Wegen der suche mit den PHP Dateien habe ich mal bissel gespielt.
Wurden hier früher die Anfragen als richtiges RSS (XML) ausgegeben? Aktuelle werden lauf Quelltext die Filme noch gesucht, nur nicht als RSS sondern als HTML ausgegeben.
Ich habe es mal zum richtigen RSS gemacht, vielleicht möchte es mal jemand testen.
Hier ein Link für HDA (wird schon nach einem Film mit blauen Aliens gesucht für die secret den Film durch
Quote:
{{search_term}}
ersetzen):

http://bit.ly/2lm8fcx
Reply With Quote
  #126  
Old 17.02.2017, 04:04
snickers2k snickers2k is offline
Mega Loader
 
Join Date: Oct 2015
Posts: 69
Default

Hey. Ja, tatsächlich habe ich eine aktuelle Version am laufen. Werde ich die Tage an Crack00r zum testen schicken und dann auch gerne an dich (als danke für die Mitarbeit). Dein HDA Script werde ich mal übers WE testen. Könntest du das Plugin mit deinen Änderungen bitte als PM an mich schicken oder als Pull-Request auf github? Danke dafür.

Last edited by snickers2k; 17.02.2017 at 04:13.
Reply With Quote
  #127  
Old 17.02.2017, 10:59
Trubadix Trubadix is offline
Modem User
 
Join Date: Feb 2017
Posts: 4
Default

Wenn dein Feedback damit positiv ist lade ich es gerne hoch. Sonst muss ich den Fehler woanders suchen.
Ich weiss nicht ob es bereits in eurem Script eingebaut ist aber ich habe mal noch eine Suche für HDW gemacht. Diese zeigt, wenn nichts gefunden wurde, keine Links zum Usen** an.

http://bit.ly/2ldNai2
Reply With Quote
  #128  
Old 17.02.2017, 17:36
Trubadix Trubadix is offline
Modem User
 
Join Date: Feb 2017
Posts: 4
Default

hmm also ich gebe erstmal auf...
immer wenn ich die trakt auth machen will rattert gleich das sy-plugin los.
flexget check versucht und immer das gleiche.
alle zusätzlichen plugins ausm ordner und flexget debug laufen gelassen.

Code:
pi@downloader:~ $ flexget --debug
2017-02-17 16:32 DEBUG    manager                       Figuring out config load paths
2017-02-17 16:32 DEBUG    manager                       Found config: /home/pi/.flexget/config.yml
2017-02-17 16:32 DEBUG    manager                       Config file /home/pi/.flexget/config.yml selected
2017-02-17 16:32 DEBUG    manager                       sys.defaultencoding: ascii
2017-02-17 16:32 DEBUG    manager                       sys.getfilesystemencoding: UTF-8
2017-02-17 16:32 DEBUG    manager                       flexget detected io encoding: utf-8
2017-02-17 16:32 DEBUG    manager                       os.path.supports_unicode_filenames: False
2017-02-17 16:32 DEBUG    plugin                        Trying to load plugins from: [u'/home/pi/.flexget/plugins', '/usr/local/lib/python2.7/dist-packages/flexget/plugins']
2017-02-17 16:32 DEBUG    plugin                        (u'Plugin `%s` requires `%s` to load.', u'memusage', u'ext lib `guppy`')
2017-02-17 16:32 DEBUG    plugin                        Plugins took 9.67 seconds to load. 271 plugins in registry.
usage: flexget [-h] [-V] [--test] [-c CONFIG] [--logfile LOGFILE]
               [--loglevel LEVEL] [--bugreport] [--profile [OUTFILE]] [--cron]
               [--debug-warnings] [--debug-db-sessions]
               <command> ...
flexget: error: too few arguments
2017-02-17 16:32 DEBUG    manager                       Removed /home/pi/.flexget/.config-lock
wenn ich nur flexget trakt auth user mache kommt dies, obwohl die config utf-8 ist

Code:
2017-02-17 16:13 CRITICAL manager                       Config file must be UTF-8 encoded.
2017-02-17 16:13 CRITICAL manager                       Failed to load config file: Config file is not UTF-8 encoded
Reply With Quote
  #129  
Old 19.02.2017, 16:34
snickers2k snickers2k is offline
Mega Loader
 
Join Date: Oct 2015
Posts: 69
Default

Ich wüsste nicht, warum dein Script nicht funktionieren sollte. Werde es aber die Tage testen.
Ich bin zwar auch kein Raspberry Profi, aber "sys.defaultencoding: ascii" sagt ja im Grunde alles. Kleine google suche ergab, dass python3 UTF-8 als standard nutzt. Also würde ich es damit versuchen (python2 evtl vorher deinstallieren). Oder du änderst den "sys.defaultencoding" .. aber kp wie das geht.
Ich hatte ein Ähnliches Problem mit flexget als cronjob unter Ubuntu. Abhilfe geschafft hat:
Quote:
Environment variable LANGUAGE = de
Environment variable LANG = de_DE.UTF-8
Das klingt aber auch nicht schlecht: PYTHONIOENCODING="UTF-8"

Was mir noch eingefallen ist, wäre der Versuch über: "sudo raspi-config" und dort dann unter Language de_DE.UTF-8 auszuwählen.

Interessant wäre noch die Frage, welche Distribution du nutzt. Raspbian? Dieser ganze Xbian etc. (Kodi) quatsch ist zu abgespeckt. Ggf. würde ich dir ein Banana-Pi mit Ubuntu empfehlen - da sollten weniger Probleme entstehen.

Last edited by snickers2k; 20.02.2017 at 01:43.
Reply With Quote
  #130  
Old 22.02.2017, 17:42
Trubadix Trubadix is offline
Modem User
 
Join Date: Feb 2017
Posts: 4
Default

Weil es ja nur "richtiges" XML statt HTML ausgibt ;-)

Mein Problem mit dem UTF-8 war wirklich das extreme Raspian - Lite.
Alle configs angepasst aber Python 2.7 war nicht bereit das UTF-8 zu nutzen.
Ich habe mal das normale installiert und folgendes ausgeführt:

Code:
sudo pip3 install -U pip
sudo pip3 install -U setuptools
Nun läuft es endlich mit allen Plugins. Nur diese alte vermurkste Config bekomme ich einfach nicht zum laufen. Da gibt es immer neue Fehlermeldungen wenn ich eine andere beseitigt habe. Dachte erst es liegt an mir aber ein kleines Testscript läuft ohne Probleme durch:

Code:
tasks:
  serienxxxkies.org:
    rss: http://serienxxxkies.org/xml/feeds/episoden.xml
    accept_all: no
    series:
      720p:
        - The Walking Dead
    serienxxxkies:
      language: german
      hoster: ul
    exec: 
      - echo text={{url}} >> "/home/pi/Downloads/{{title}}.crawljob"
      - echo downloadFolder=/home/pi/Downloads/{{title}} >> "/path/to/folderwatch/{{title}}.crawljob"
Da holt er die aktuelle Folge und legt brav ein crawljob an.

Wenn eure config schon läuft, gerne her damit ;-)
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

All times are GMT +2. The time now is 00:02.
Provided By AppWork GmbH | Privacy | Imprint
Parts of the Design are used from Kirsch designed by Andrew & Austin
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.