JDownloader Community - Appwork GmbH
 

Reply
 
Thread Tools Display Modes
  #1  
Old 25.03.2019, 18:03
rockwater rockwater is offline
Mega Loader
 
Join Date: Oct 2011
Location: Netherlands
Posts: 60
Default ffmpeg.exe has stopped working

Hi,

When trying to download videos from YouTube through JD2 I always get this error message in Windows Vista:

ffmpeg.exe has stopped working

At the same time JD2 gives these messages in the Status column:

- For the package: An Error occurred! (youtube.com)
- For the m4a and the mp4 files: Try restarting this link (plugin outdated?)

This has been going on for months now. Never had this problem before this started to be a problem. I always install the latest JD2 update before starting downloading.

Can somebody please help me with this problem?
Reply With Quote
  #2  
Old 26.03.2019, 12:27
Jiaz's Avatar
Jiaz Jiaz is offline
JD Manager
 
Join Date: Mar 2009
Location: Germany
Posts: 63,945
Default

We've released a ffmpeg update on 05.10.2018. ffmpeg dropped support for Windows older than Windows 7 and you have to either find a newer version that still supports older Windows versions and setup path to binary in settings-advanced settings-search for ffmpeg and ffprobe
This is the old working version, mega.nz/#!LYNm0ARD!U8_xvNRchJkdJdH1uCHmeMc1WCao6mFwJ7KdonsM2Sk
__________________
JD-Dev & Server-Admin
Reply With Quote
  #3  
Old 31.03.2019, 12:44
rockwater rockwater is offline
Mega Loader
 
Join Date: Oct 2011
Location: Netherlands
Posts: 60
Default

Thank you very much!
Reply With Quote
  #4  
Old 01.04.2019, 11:41
Jiaz's Avatar
Jiaz Jiaz is offline
JD Manager
 
Join Date: Mar 2009
Location: Germany
Posts: 63,945
Default

You're welcome
__________________
JD-Dev & Server-Admin
Reply With Quote
  #5  
Old 22.05.2019, 15:02
SorryForMyEN SorryForMyEN is offline
Baby Loader
 
Join Date: May 2019
Posts: 6
Default

JDownloader has always worked for years to download YouTube videos. But now I get a warning to update ffmpeg that will join audio and video.

I have JDownloader and K-Lite Codec Pack always updated. Windows 10, built 1809. Even so, if I click the button to update JDownloader and wait for up to date, nothing changes. All other types of downloads work perfectly in JD, only YouTube downloads continue to give the same error warning.

Please, is there any solution? Thanks
Reply With Quote
  #6  
Old 22.05.2019, 15:11
Jiaz's Avatar
Jiaz Jiaz is offline
JD Manager
 
Join Date: Mar 2009
Location: Germany
Posts: 63,945
Default

K-Lite Codec Pack has nothing to do with JDownloader nor with ffmpeg. JDownloader makes use of ffmpeg command line tool to mux audio/video streams for dash.
what exactly happens? what error is shown?
__________________
JD-Dev & Server-Admin
Reply With Quote
  #7  
Old 22.05.2019, 15:45
SorryForMyEN SorryForMyEN is offline
Baby Loader
 
Join Date: May 2019
Posts: 6
Default

Sorry, it is in Portuguese, but I think you recognize this



When clicking "install FFmpeg", there is a load, Jd is restarted but the error warning returns when trying to download a video from YouTube.
Reply With Quote
  #8  
Old 22.05.2019, 15:52
Jiaz's Avatar
Jiaz Jiaz is offline
JD Manager
 
Join Date: Mar 2009
Location: Germany
Posts: 63,945
Default

What OS are you using? I would suggst to do the following.
Close JDownloader and delete the Core.jar file and the tmp and update folders. That makes JDownloader update itself to latest available version. then try again, in case the dialog still shows up again and again, please report back
__________________
JD-Dev & Server-Admin
Reply With Quote
  #9  
Old 22.05.2019, 16:13
SorryForMyEN SorryForMyEN is offline
Baby Loader
 
Join Date: May 2019
Posts: 6
Default

Will deleting core.jar and tmp cause a loss of download-config history, or skins?

I use Winodws 10 Pro, version 1809, build 17763.316.
Reply With Quote
  #10  
Old 22.05.2019, 16:19
Jiaz's Avatar
Jiaz Jiaz is offline
JD Manager
 
Join Date: Mar 2009
Location: Germany
Posts: 63,945
Default

no, all settings /accounts/links are stored within cfg. Your configuration are untouched by this.
In doubt, simply create a backup of the complete cfg folder
__________________
JD-Dev & Server-Admin
Reply With Quote
  #11  
Old 22.05.2019, 16:33
SorryForMyEN SorryForMyEN is offline
Baby Loader
 
Join Date: May 2019
Posts: 6
Default

I followed your guidelines and downloading videos is working perfectly now. It remains to know what caused this, perhaps these complicated security restrictions of Windows 10...

Many thanks!

Last edited by Jiaz; 22.05.2019 at 16:47.
Reply With Quote
  #12  
Old 22.05.2019, 16:47
Jiaz's Avatar
Jiaz Jiaz is offline
JD Manager
 
Join Date: Mar 2009
Location: Germany
Posts: 63,945
Default

Thanks for the feedback. To be able to tell you more about why/what happened I would have to check your local installation more (eg via Teamviewer) but I guess sort of *thinks ffmpeg is installed but it is not* issue
__________________
JD-Dev & Server-Admin
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

All times are GMT +2. The time now is 18:11.
Provided By AppWork GmbH | Privacy | Imprint
Parts of the Design are used from Kirsch designed by Andrew & Austin
Powered by vBulletin® Version 3.8.10 Beta 1
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.