JDownloader Community - Appwork GmbH
 

Reply
 
Thread Tools Display Modes
  #1  
Old 13.06.2012, 03:11
jorbjo
Guest
 
Posts: n/a
Default JDownloader steals focus

When i right click on a link in my browser and select "copy shortcut"

JDownloader moves its window ontop my browser and displays this link in the linkgrabber.

I cannot find a setting to disable this behaviour.

I want to copy a number of links from my browser and have them "silently" added to the linkgrabber. When I have selected all the links that I want I manually switch to the JDownloader window and add them to the download queue.

Last edited by Jiaz; 13.06.2012 at 09:42.
Reply With Quote
  #2  
Old 13.06.2012, 09:42
Jiaz's Avatar
Jiaz Jiaz is offline
JD Manager
 
Join Date: Mar 2009
Location: Germany
Posts: 64,650
Default

In Advanced Settings
linkgrabberframetotoponnewlinksnenabled , disable this

In case you have Trayicon enabled
Brin mainframe to top ...setup to your needs
__________________
JD-Dev & Server-Admin
Reply With Quote
  #3  
Old 13.06.2012, 18:16
raztoki's Avatar
raztoki raztoki is offline
English Supporter
 
Join Date: Apr 2010
Location: Australia
Posts: 16,155
Default

Attached Thumbnails
Snippy0001.jpg  
__________________
raztoki @ jDownloader reporter/developer
http://svn.jdownloader.org/users/170

Don't fight the system, use it to your advantage. :]
Reply With Quote
  #4  
Old 19.11.2012, 08:43
Knersis
Guest
 
Posts: n/a
Default Auto Take Focus

Hi

Is there a way I can get JD to stop from taking focus while I'm busy adding links.

Here what I do. On a web, say there are 5 links and I want to download them. I would right click them in Chrome and then click "Copy Link Address", now I would do this for all 5 links, but by the time get to the 3rd one JD pops up and displays the LinkGrabber tab.
Now this is all fine and well, but it takes focus and pops the whole window up over my Chrome browser window, so i would need to click back into Chrome and start right clicking again.
Its annoying and the old 0.9 did not do it.

Cheers
Reply With Quote
  #5  
Old 19.11.2012, 19:37
pspzockerscene's Avatar
pspzockerscene pspzockerscene is offline
Community Manager
 
Join Date: Mar 2009
Location: Deutschland
Posts: 48,649
Default

Expert settings->Search for "grabberframe"->Disable

GreeZ pspzockerscene
__________________

Ad-free installers || Werbefreie Installer
Windows Setup<--JD2 BETA-->Linux Setup x86 || Linux Setup x64 || Mac Setup
-----=>Support Chat<=-----
Spoiler:

A users' JD crashes and the first thing to ask is:
Quote:
Originally Posted by Jiaz View Post
Do you have Nero installed?
That's true James
Quote:
Originally Posted by James
Die Leute verstehen einfach nicht dass nur weil man mit einer Waffe auch auf Menschen schießen kann dass ein Schützenver​ein kein Ort für Amoklaufide​en ist
Reply With Quote
  #6  
Old 20.11.2012, 07:32
Knersis
Guest
 
Posts: n/a
Default

I found this on likgrabberframetotoponnewlinksenabled, my check box was not checked.
Reply With Quote
  #7  
Old 22.11.2012, 19:12
JWalkerMR JWalkerMR is offline
DSL User
 
Join Date: May 2011
Posts: 38
Default same Problem

Hi,

i've got the same problem, using firefox.

Changing then value of GraphicalUserInterfaceSettings.linkgrabberframetotoponnewlinksenbaled doesn't change the behavior of JD2, either if "true" or "false".
Reply With Quote
  #8  
Old 22.11.2012, 21:50
Knersis
Guest
 
Posts: n/a
Default

Yip, no change. This thread is not solved for me as it does not fix the problem. I have also not been able to find anything else to change.
Reply With Quote
  #9  
Old 22.11.2012, 22:47
editestowy's Avatar
editestowy editestowy is offline
Polish Supporter
 
Join Date: May 2009
Location: PL
Posts: 3,029
Default

http://board.jdownloader.org/showthread.php?t=40852
Reply With Quote
  #10  
Old 23.11.2012, 07:52
Knersis
Guest
 
Posts: n/a
Default

Awesome, now it works for me. Did as follows from the other thread and this one.

Set this disabled
Settings > Advanced Settings > GraphicalUserInterfaceSettings.linkgrabberframetotoponnewlinksenabled

AND

Light Tray > Show JDownloader if new Links were grabbed > Only when Mainframe is minimized.

That way it will popup when minimized but not if already showing.
Reply With Quote
  #11  
Old 24.11.2012, 19:39
Topken Topken is offline
Fibre Channel User
 
Join Date: Oct 2010
Posts: 118
Default

For those Firefox users try using a firefox addon like "Copy Links" It allows you to grab mulitple links behind text at one time so you dont have to grab each link separately.
Reply With Quote
  #12  
Old 24.11.2012, 21:51
Knersis
Guest
 
Posts: n/a
Default

Is there something similiar in Chrome?
Reply With Quote
  #13  
Old 24.11.2012, 22:14
Topken Topken is offline
Fibre Channel User
 
Join Date: Oct 2010
Posts: 118
Default

I dont know those of you using Chrome can take a look and see.
Reply With Quote
  #14  
Old 13.03.2013, 23:08
jorbjo
Guest
 
Posts: n/a
Angry JD 2 is stealing focus

I have JD 2 running and downloading files.

I have disabled linkgrabberframetotoponnewlinksenabled

I copy some text that I want to paste into notepad

JD 2 is stealing focus and moves to the top even when the clipboard contents is not a url.

When the above setting is disabled JD should never move to top what ever is copied to the clipboard.
Reply With Quote
  #15  
Old 14.03.2013, 00:43
ReXTaR's Avatar
ReXTaR ReXTaR is offline
LoRD SLaYeR ReXTaR
 
Join Date: Mar 2012
Posts: 694
Default

So you say that you disabled, where you did? in advanced options?because light tray appears that option available to choose from a list, not to enable or disable ... the option to say "Bring to front the main window to add new links, I have selected in: neverand works well, plus I have disabled the linkgrabber ...
Reply With Quote
  #16  
Old 14.03.2013, 03:29
raztoki's Avatar
raztoki raztoki is offline
English Supporter
 
Join Date: Apr 2010
Location: Australia
Posts: 16,155
Default

seems to be the original author your current question, I have merged all common threads into this one. See my first reply it indicates the BOTH settings you need to define in order to disable this behaviour. Please search forum before making posts about the same thing. Thankyou
__________________
raztoki @ jDownloader reporter/developer
http://svn.jdownloader.org/users/170

Don't fight the system, use it to your advantage. :]
Reply With Quote
  #17  
Old 07.06.2013, 09:15
coalado's Avatar
coalado coalado is offline
JD Manager
 
Join Date: Feb 2009
Posts: 1,981
Default

Soo... let's start to fix this.



There are 2 options to change this focus behaviour one in the advanced settings GraphicalUserInterfaceSettings.linkgrabberframetotoponnewlinksenabled and one in the Tray Settings.... That's bad. I will change this to have one option
__________________
Reply With Quote
  #18  
Old 07.06.2013, 17:52
coalado's Avatar
coalado coalado is offline
JD Manager
 
Join Date: Feb 2009
Posts: 1,981
Default

PLease use AdvancedConfig -> getWindowFocusActionWhenNewLinksAreAdded in the next update..

There are several options on what happens when new links were added:
  • NOTHING -->Taskbar Icon flashing only
  • REQUEST_FOCUS_IF_MAXIMIZED --> popup linkgrabber if frame is maximized - else taskbar flashing
  • REQUEST_FOCUS_IF_MAXIMIZED_OR_ICONIFIED --> popup linkgrabber if frame is not in tray - else taskbar flashing
  • ALWAYS_REQUEST_FOCUS --> popup linkgrabber always


To avoid the Taskbar flashing, use AdvancedConfig->TaskBarFlashEnabled
__________________
Reply With Quote
  #19  
Old 10.06.2013, 17:34
bici-boci bici-boci is offline
JD Legend
 
Join Date: Mar 2009
Posts: 753
Default

Quote:
Originally Posted by coalado View Post
PLease use AdvancedConfig -> getWindowFocusActionWhenNewLinksAreAdded in the next update..

There are several options on what happens when new links were added:
  • NOTHING -->Taskbar Icon flashing only
  • REQUEST_FOCUS_IF_MAXIMIZED --> popup linkgrabber if frame is maximized - else taskbar flashing
  • REQUEST_FOCUS_IF_MAXIMIZED_OR_ICONIFIED --> popup linkgrabber if frame is not in tray - else taskbar flashing
  • ALWAYS_REQUEST_FOCUS --> popup linkgrabber always
After update I found the following settings, filtering for "focus" :

GraphicalUserInterfaceSettings.focustriggerforcaptchadialogs
-Action that will be performed when the Linkgrabber adds new links.

NEVER
MAINFRAME_IS_MAXIMIZED
MAINFRAME_IS_MAXIMIZED_OR_ICONIFIED
MAINFRAME_IS_MAXIMIZED_OR_ICONIFIED_OR_TOTRAY

GraphicalUserInterfaceSettings.windowsrequestfocusonactivationenabled
-Set to true if you want JDownloader to steal focus when the window pops up

I set NEVER and disabled for the above settings, disabled again the Tray Icon, but when I copy a link, JD2 steals focus and shows Linkgrabber with the link.

What is the proper setting ?
In previous versions I had no problems with focus.

Another question: what is the relation between "focustriggerforcaptchadialogs" in the setting name and "Linkgrabber adds new links" in description ?
Reply With Quote
  #20  
Old 11.06.2013, 06:23
bici-boci bici-boci is offline
JD Legend
 
Join Date: Mar 2009
Posts: 753
Default JD2 steals focus, no visible activity, using XP SP3

The Jun 10 version
in every 200 sec tries to steal focus. JD2 is in background, there is no visible activity, downloadlist and linkgrabber is empty.
The old, not updated version in other folder woks without this problem. as before.

Edit:

"Tray Icon" is disabled.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

All times are GMT +2. The time now is 18:33.
Provided By AppWork GmbH | Privacy | Imprint
Parts of the Design are used from Kirsch designed by Andrew & Austin
Powered by vBulletin® Version 3.8.10 Beta 1
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.