JDownloader Community - Appwork GmbH
 

Closed Thread
 
Thread Tools Display Modes
  #1  
Old 09.01.2014, 23:44
frosty69
Guest
 
Posts: n/a
Default Saving to Package name directory

Not sure why or what happened or if I changed something, but all my packages now are being save to the jdownloader directory instead of creating a sub folder with the package name.

How do I change it so that a new sub directory is created with the package/files name?

Thanks
  #2  
Old 10.01.2014, 00:59
Lram32's Avatar
Lram32 Lram32 is offline
Spanish Supporter
 
Join Date: Jul 2012
Location: Dark side of the moon
Posts: 9,908
Default

Hi,

Check if you have enabled the default rule "create subfolder by packagename" in settings > packagizer
__________________
» Setup JD2 / Instalador de JD2 «
Spoiler:

Installer for Windows XP/Vista/Seven/Eight
|| JD2 x86 - x64 (Beta) ||

Installer for Mac
|| JD2 (Beta) ||

Installers for Linux
|| JD2 (Beta) x86 || <---> || JD2 (Beta) x64 ||

How to Create a Log
-» Click Here «-


¿Cómo crear un registro?
-» Click Aquí «-


Support Chat / Chat de Soporte
-» Click Here / Click Aquí «-


  #3  
Old 10.01.2014, 03:22
NotesTracker NotesTracker is offline
Ultra Loader
 
Join Date: Dec 2011
Location: Melbourne, Australia
Posts: 45
Default

I suffered from this problem too. After quite a few months of using JD2 without this problem it seems to have started happening (perhaps due to a recent update?) during the last month or so.

The default rule "create subfolder by packagename" does not seem to be working properly. I tried to edit this rule, but it's locked so I unselected/deactivated it and created a new one in its place.

My new packagizer rule at first had in the Download Directory field:
<jd:packagename>

However this puts all the downloads on the C: system drive which I do not want because I strive to keep it as compact as possible for speedy backup/recovery reasons.

Therefore I changed the Download Directory field to point to a non-system drive, for example:
D:\JD2_downloads\<jd:packagename>

I would request an enhancement, that a new Dynamic Variable be created that holds the name of the designated downloads folder. It would be very nice if the the Download Directory field could look like this:
<jd:download_directory>\<jd:packagename>
Then you would not have to edit this field whenever you change the base downloads directory.

Last edited by NotesTracker; 10.01.2014 at 03:34.
  #4  
Old 10.01.2014, 03:28
frosty69
Guest
 
Posts: n/a
Default

I checked and this was set to false so I set it to True. Odd possibly an update modified it as it was working. I will test to make sure it works now and report back.

"enabled" : true, THIS WAS SET TO FALSE
"name" : "Create Subfolder by Packagename",
"downloadDestination" : "<jd:packagename>",
"priority" : null,
"packageName" : null,
"rename" : null,
"moveto" : null,
"autoExtractionEnabled" : null,
"autoAddEnabled" : null,
"linkEnabled" : null,
"autoStartEnabled" : null,
"chunks" : 0,
"filename" : null,
"order" : 0,
"autoForcedStartEnabled" : null,
"valid" : true,
"matchAlwaysFilter" : {
"enabled" : true
}

---------------------------------------------------

Still having same problem even though I changed the setting. New downloads start and go in same directory and does not create a sub directory???

Last edited by Lram32; 11.01.2014 at 15:52. Reason: merged posts
  #5  
Old 11.01.2014, 15:00
Lram32's Avatar
Lram32 Lram32 is offline
Spanish Supporter
 
Join Date: Jul 2012
Location: Dark side of the moon
Posts: 9,908
Default

Please try with this:
Do right click in the package(s) → properties → set download directory
JD2 will show a window, there check the option "subfolder by package"

Kindest regards,
__________________
» Setup JD2 / Instalador de JD2 «
Spoiler:

Installer for Windows XP/Vista/Seven/Eight
|| JD2 x86 - x64 (Beta) ||

Installer for Mac
|| JD2 (Beta) ||

Installers for Linux
|| JD2 (Beta) x86 || <---> || JD2 (Beta) x64 ||

How to Create a Log
-» Click Here «-


¿Cómo crear un registro?
-» Click Aquí «-


Support Chat / Chat de Soporte
-» Click Here / Click Aquí «-


  #6  
Old 11.01.2014, 15:46
frosty69
Guest
 
Posts: n/a
Default

Quote:
Originally Posted by Lram32 View Post
Please try with this:
Do right click in the package(s) → properties → set download directory
JD2 will show a window, there check the option "subfolder by package"

Kindest regards,
I tried this and it created the sub-directory.

Is there a problem with the global setting that I would have to do this manually?

Thanks
  #7  
Old 11.01.2014, 15:57
Lram32's Avatar
Lram32 Lram32 is offline
Spanish Supporter
 
Join Date: Jul 2012
Location: Dark side of the moon
Posts: 9,908
Default

I suppose you have a corrupted file into the folder cfg, because the default rule of the packagizer works fine here.

Please close JD2 and delete the files (they are into the folder CFG):

org.jdownloader.controlling.packagizer.PackagizerSettings.json
org.jdownloader.controlling.packagizer.PackagizerSettings.rulelist.json
ExtTable_PackagizerFilterTable.json

Greetings,

P.S.: This will delete the rules that you have created at the packagizer, so make a backup of the files before to delete them.
__________________
» Setup JD2 / Instalador de JD2 «
Spoiler:

Installer for Windows XP/Vista/Seven/Eight
|| JD2 x86 - x64 (Beta) ||

Installer for Mac
|| JD2 (Beta) ||

Installers for Linux
|| JD2 (Beta) x86 || <---> || JD2 (Beta) x64 ||

How to Create a Log
-» Click Here «-


¿Cómo crear un registro?
-» Click Aquí «-


Support Chat / Chat de Soporte
-» Click Here / Click Aquí «-


  #8  
Old 11.01.2014, 18:12
frosty69
Guest
 
Posts: n/a
Smile

Quote:
Originally Posted by Lram32 View Post
I suppose you have a corrupted file into the folder cfg, because the default rule of the packagizer works fine here.

Please close JD2 and delete the files (they are into the folder CFG):

org.jdownloader.controlling.packagizer.PackagizerSettings.json
org.jdownloader.controlling.packagizer.PackagizerSettings.rulelist.json
ExtTable_PackagizerFilterTable.json

Greetings,

P.S.: This will delete the rules that you have created at the packagizer, so make a backup of the files before to delete them.
Thanks that has fixed the problem.
  #9  
Old 11.01.2014, 18:19
Lram32's Avatar
Lram32 Lram32 is offline
Spanish Supporter
 
Join Date: Jul 2012
Location: Dark side of the moon
Posts: 9,908
Default

Thanks for the feedback.
__________________
» Setup JD2 / Instalador de JD2 «
Spoiler:

Installer for Windows XP/Vista/Seven/Eight
|| JD2 x86 - x64 (Beta) ||

Installer for Mac
|| JD2 (Beta) ||

Installers for Linux
|| JD2 (Beta) x86 || <---> || JD2 (Beta) x64 ||

How to Create a Log
-» Click Here «-


¿Cómo crear un registro?
-» Click Aquí «-


Support Chat / Chat de Soporte
-» Click Here / Click Aquí «-


Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

All times are GMT +2. The time now is 01:24.
Provided By AppWork GmbH | Privacy | Imprint
Parts of the Design are used from Kirsch designed by Andrew & Austin
Powered by vBulletin® Version 3.8.10 Beta 1
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.