JDownloader Community - Appwork GmbH
 

Reply
 
Thread Tools Display Modes
  #1  
Old 29.11.2011, 00:40
jmorlan jmorlan is offline
JD Alpha
 
Join Date: Nov 2011
Posts: 22
Default Firefox 8.0.1 issue

I normally use the Flashgot plugin to enable JDownloader, but after upgrading to Firefox 8.0.1 it no longer worked as expected. I tried enabling the Flashgot interface within the current JDownloader but Firefox refused saying that this version of Flashgot is incompatible with Firefox 8.0.1.

However I was able to update Flashgot within Firefox to a version which is apparently compatible, but it no longer launches JDownloader when I right click links and download via Flashgot. Instead nothing happens. I have to open JDownloader manually.

Please advise.

Last edited by Jiaz; 29.11.2011 at 17:39.
Reply With Quote
  #2  
Old 29.11.2011, 17:39
Jiaz's Avatar
Jiaz Jiaz is offline
JD Manager
 
Join Date: Mar 2009
Location: Germany
Posts: 66,134
Default

Go to Flashgot site and download new version/wait for update.
We are not the developers of Flashgot!

Make sure the Settings of Flashgot are correct. Maybe have to resetup Flashgot for Jdownloader
__________________
JD-Dev & Server-Admin
Reply With Quote
  #3  
Old 30.11.2011, 03:34
jmorlan jmorlan is offline
JD Alpha
 
Join Date: Nov 2011
Posts: 22
Default

Thanks. I am now running Flashgot 1.3.5 rc1. The current release is 1.3.4. Both work only as long as JDownloader is launched first. Neither will launch JDownload as in the past.

The Flashgot settings are correct.

I guess I'll try posting in the Flashgot forum.

Thanks.
Reply With Quote
  #4  
Old 30.11.2011, 09:23
bici-boci bici-boci is offline
JD Legend
 
Join Date: Mar 2009
Posts: 753
Default

Quote:
Originally Posted by jmorlan View Post
Thanks. I am now running Flashgot 1.3.5 rc1. The current release is 1.3.4. Both work only as long as JDownloader is launched first. Neither will launch JDownload as in the past.

The Flashgot settings are correct.

I guess I'll try posting in the Flashgot forum.

Thanks.
Flashgot 1.3.4. works here with Firefox 8.0.1

Does your flashgot.dmsopts.JDownloader.path setting in about:config point to the folder where JD is installed ?
Reply With Quote
  #5  
Old 02.12.2011, 08:40
jmorlan jmorlan is offline
JD Alpha
 
Join Date: Nov 2011
Posts: 22
Default

It's configured like this, which should be correct.

flashgot.dmsopts.JDownloader.path;C:\Program Files\JDownloader\JDownloader.jar

In disgust I removed Flashgot and JDownloader. Re-installed JD nightly, then installed FG and it still didn't work. I tried the FG forum and the only advice I got there was a link to somebody else who had the exact same problem which was never resolved.

I've decided to forget about Flashgot and just use JD on its own and launch it at Windows Start. Unfortunately it seems to open the GUI when I do that instead of sitting quietly in the System Tray where I want it.

What's the best way to silently start JD at boot?

Thanks.
Reply With Quote
  #6  
Old 02.12.2011, 09:00
bici-boci bici-boci is offline
JD Legend
 
Join Date: Mar 2009
Posts: 753
Default

You could try JD Light Tray addon with its start minimized option.
Reply With Quote
  #7  
Old 02.12.2011, 09:03
raztoki's Avatar
raztoki raztoki is offline
English Supporter
 
Join Date: Apr 2010
Location: Australia
Posts: 16,233
Default

windows place shortcut into start > programs > startup
unix/linux crontab jd.sh
__________________
raztoki @ jDownloader reporter/developer
http://svn.jdownloader.org/users/170

Don't fight the system, use it to your advantage. :]
Reply With Quote
  #8  
Old 02.12.2011, 20:05
jmorlan jmorlan is offline
JD Alpha
 
Join Date: Nov 2011
Posts: 22
Default

Quote:
Originally Posted by bici-boci View Post
You could try JD Light Tray addon with its start minimized option.
Thanks. The trouble is that the "start minimized" option doesn't work very elegantly. First it loads a system tray icon, then the GUI opens for a split second and then it closes back to the system tray.

I've place a shortcut in the Windows startup folder, but I'd really like to get rid of that annoying split second GUI display if possible.
Reply With Quote
  #9  
Old 03.12.2011, 08:55
remi
Guest
 
Posts: n/a
Default

If you don't want to see that window I would just close my eyes and if that isn't possible switch off the screen very briefly.
Reply With Quote
  #10  
Old 03.12.2011, 21:56
jmorlan jmorlan is offline
JD Alpha
 
Join Date: Nov 2011
Posts: 22
Default

Quote:
Originally Posted by Jiaz View Post
Go to Flashgot site and download new version/wait for update.
We are not the developers of Flashgot!

Make sure the Settings of Flashgot are correct. Maybe have to resetup Flashgot for Jdownloader
Thanks. According to the Flashgot logs, FG thought that JD was already running and that's why it failed to launch under certain circumstances. Here is what I did to fix the issue.

1. Completely removed both FG and JD.
2. Installed the latest nightly build of JD.
3. Went into about:config in Firefox and set all of the legacy "user set" FG entries which remained after the uninstall to "reset"
4. Restarted Firefox to ensure all the FG config entries were gone.
5. Installed the latest release of FG.
6. Allowed FG to auto-detect JD.

Now all works as expected. Perhaps this will help somebody as it appears this issue has come up before, although evidently it is rare. Why this fixed the problem, and why FG may have thought JD was already running, I cannot say. But I suspect it was a bad FG "user set" configuration setting which remained after uninstalling and reinstalling FG in Firefox.

Last edited by jmorlan; 03.12.2011 at 21:58.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

All times are GMT +2. The time now is 21:28.
Provided By AppWork GmbH | Privacy | Imprint
Parts of the Design are used from Kirsch designed by Andrew & Austin
Powered by vBulletin® Version 3.8.10 Beta 1
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.