JDownloader Community - Appwork GmbH
 

Reply
 
Thread Tools Display Modes
  #1  
Old 11.03.2012, 17:15
twitz00
Guest
 
Posts: n/a
Default Updates will not install

I am using the Mac OS and have recently reinstalled my Jdownloader. Downloaded the "jDownloader_Java 1_5.dmg" and was immediately prompted to upgrade to v0.8.821. Once that is installed, another prompt comes up saying "1464 update(s) available. Install now?".

After the updates are downloaded, jDownloader tries to restart to install but never succeeds. I have tried countless times to install the updates but the programme never restarts on its own. What should I do?

Last edited by Jiaz; 11.03.2012 at 17:27.
Reply With Quote
  #2  
Old 11.03.2012, 17:26
Jiaz's Avatar
Jiaz Jiaz is offline
JD Manager
 
Join Date: Mar 2009
Location: Germany
Posts: 66,134
Default

close jd
rightclick on the app/dmg, show content
navigate till you find jdupdate.jar, start it
__________________
JD-Dev & Server-Admin
Reply With Quote
  #3  
Old 11.03.2012, 17:28
raztoki's Avatar
raztoki raztoki is offline
English Supporter
 
Join Date: Apr 2010
Location: Australia
Posts: 16,281
Default

the installers do not have the latest plugins, so you need to update parts of the program and mainly the plugins. But you should only ever have to update once, assuming you are installing the latest installer.. Sorry I'm not a Mac user so I'm not that experienced with this realm. There are some problems with apple version/distro of Java many have indicated issues with one of the previous releases of 1.6 though those reports have reduced, so I assume apple have fixed the cause of these problems. reference search 'mac spinning'
__________________
raztoki @ jDownloader reporter/developer
http://svn.jdownloader.org/users/170

Don't fight the system, use it to your advantage. :]
Reply With Quote
  #4  
Old 12.03.2012, 15:04
twitz00
Guest
 
Posts: n/a
Default

Thanks for the replies.

I have located the file jdupdate.jar from Contents>Resources>Java but got the following error message after double-clicking: "The JAVA JAR file "jdupdate.jar" could not be launched. Check the Console for possible error messages."

From the looks of things, the latest jDownloader updates require something from Java that the Mac OS version does not support?

One point that I realised that I have missed out is that I have been using jDownloader for a few years and only reinstalled it recently because the latest update files (updated within the past week?) created a plugin error and was unable to download anything. As a result, I figured that I should try to reinstall the programme but that did not help.
Reply With Quote
  #5  
Old 12.03.2012, 15:46
Jiaz's Avatar
Jiaz Jiaz is offline
JD Manager
 
Join Date: Mar 2009
Location: Germany
Posts: 66,134
Default

what java version do you have?
please make sure you download the version from our homepage jdownloader.org
__________________
JD-Dev & Server-Admin
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

All times are GMT +2. The time now is 23:28.
Provided By AppWork GmbH | Privacy | Imprint
Parts of the Design are used from Kirsch designed by Andrew & Austin
Powered by vBulletin® Version 3.8.10 Beta 1
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.