JDownloader Community - Appwork GmbH
 

Reply
 
Thread Tools Display Modes
  #1  
Old 18.11.2009, 21:51
stone80a
Guest
 
Posts: n/a
Default Mac keeps asking "Accept incoming network connections" for jDownloader

Every time I start jDownloader, Mac's firewall keeps asking "Do you want the application "jDownloader.app" to accept incoming network connections?

I keep answering yes, but it reappears all the time. Did anyone find a way to overcome this annoying dialogue?

Best regard

Last edited by Jiaz; 08.12.2010 at 11:17.
Reply With Quote
  #2  
Old 18.11.2009, 22:01
Jiaz's Avatar
Jiaz Jiaz is offline
JD Manager
 
Join Date: Mar 2009
Location: Germany
Posts: 59,535
Default

add java to the exclude list (dont know how to do that), but you can pm gocsp for example. hes one of our mac developer.
__________________
JD-Dev & Server-Admin
Reply With Quote
  #3  
Old 26.11.2009, 21:49
riffmaker
Guest
 
Posts: n/a
Default

I have same problem. I have Java in firewall rules, but it keeps asking anyways... Maybe I need to allow some other java binaries?

stone80a I have Java in /System/Library/Frameworks/JavaVM.framework/Versions/1.6.0/Home/bin
Just go to System preferences/Security/Firewall unlock it, click advanced, click plus button and find Java in that folder and jDownloader from applications folder... But it doesn't help for me, so there must be some other apps to allow...
Reply With Quote
  #4  
Old 26.11.2009, 22:50
Gamewalker
Guest
 
Posts: n/a
Default

What kind of firewall?
What things did you set where?

Last edited by Gamewalker; 27.11.2009 at 02:40.
Reply With Quote
  #5  
Old 27.11.2009, 18:31
riffmaker
Guest
 
Posts: n/a
Default

Quote:
Originally Posted by Gamewalker View Post
What kind of firewall?
What things did you set where?
I set in OS X Snow Leopard firewall (in System Preferences) and set jDownloader and Java to allow incoming connections
Reply With Quote
  #6  
Old 19.12.2009, 10:29
cmozuelos
Guest
 
Posts: n/a
Default

Hi,

Did someone find a solution for the recurrent "allow incoming connections" message in MacOS.

Thanks
Reply With Quote
  #7  
Old 19.02.2010, 16:01
Nicholas
Guest
 
Posts: n/a
Default

Hi you can try to use ProteMac NetMine.It’s firewall for Mac.It’s controls incoming and outgoing traffic.It's really good tool try.
Reply With Quote
  #8  
Old 13.09.2010, 23:22
thomas.miller
Guest
 
Posts: n/a
Default Same Problem !

Hi there !


I have the same problem ! On Google you will find the same problem with a bunch of applications. It seems to be happen to Apps that are not properly signed with a trusted certificate.

Terminal shows this:

codesign -vvv /Applications/jDownloader.app

/Applications/jDownloader.app: code or signature modified

I tried a workaround by signing jDownloader with my own certificates. But after you run jDownloader once, the code is modified again.

So I guess, we have to wait for a new version of jDownloader.

Or does someone know a fix ?

Best Thomas
Reply With Quote
  #9  
Old 14.09.2010, 00:42
Jiaz's Avatar
Jiaz Jiaz is offline
JD Manager
 
Join Date: Mar 2009
Location: Germany
Posts: 59,535
Default

as far as i know the app is not signed at all as we save data inside the app and therefore it will change/modify signature all the time.
it must be possible without signature as it works fine for many other mac users.
__________________
JD-Dev & Server-Admin
Reply With Quote
  #10  
Old 14.09.2010, 02:53
thomas.miller
Guest
 
Posts: n/a
Default

well, it started to be a problem when I had to un-check "block all incoming connections" in Preferences - Security - Firewall because I needed to allow exceptions for other programs. http://board.jdownloader.org/images/smilies/user/52.gif

If I "block all incoming connections" and don't allow exceptions or dont even use a firewall, then I dont have that problem.

Yet, I would would be great, if somebody has a solution.

Thx, btw
Reply With Quote
  #11  
Old 14.09.2010, 10:31
drbits's Avatar
drbits drbits is offline
JD English Support (inactive)
 
Join Date: Sep 2009
Location: Physically in Los Angeles, CA, USA
Posts: 4,437
Default

JDownloader needs to be able to listen on several ports. One of them is picked randomly each session (which is why you keep getting the question). JDownloader does not need a server opening in the firewall (for listening to messages from the internet), it needs to be allowed to listen on LOCALHOST (127.0.0.1) on any port.

You may have to tell the firewall not to accept incoming connections for java, javaw, and jdownloader. Creating the exclusion should isolate JD to just local connections.

Remember, you can turn off all firewall services from your computer. You only have to protect your computer from the internet, unless you have a virus. If you have a router with a built in firewall, then just disable the software firewall.
Reply With Quote
  #12  
Old 15.09.2010, 13:03
thomas.miller
Guest
 
Posts: n/a
Default

Thanks for your comments!
Yet I would prefer clicking this annoying popup everytime I start jD rather than disabling my firewall as I use my computer in multiple networks/hotspots.
Reply With Quote
  #13  
Old 16.09.2010, 08:58
drbits's Avatar
drbits drbits is offline
JD English Support (inactive)
 
Join Date: Sep 2009
Location: Physically in Los Angeles, CA, USA
Posts: 4,437
Default

I am sorry I did not explain that part well. The most important job of a firewall is to protect your computer from malicious acts by outsiders on the Internet.

If you have a firewall in your router, that performs the job.

Software firewalls are mostly to control which programs are allowed to listen or write to specific ports on the local machine or the Internet. These programs are designed to protect the internet from you computer, if your computer becomes infected.

Since you use several hotspots, then you need a firewall to protect your computer from external attack only. Check to see if the "Application monitoring" part of your firewall can be turned off. This should may make a significant reduction in overhead. __________________________________

Code signing should not be a problem. The Java virtual machine is signed. JDownloader is a collection of scripts that run inside the JVM and should not cause a firewall problem because of unsigned applications.
_________________________________

I know that our situations are different, because I am stuck using Windows. Yet the general rules are the same.

As I stated earlier, JDownloader opens a random (within a range) local listening port so that other Java programs can send it messages. I believe this is part of the Java library.

@ Jiaz,
Can we turn off opening the inter-process port with a -D (define) parameter?
Reply With Quote
  #14  
Old 16.09.2010, 11:23
Jiaz's Avatar
Jiaz Jiaz is offline
JD Manager
 
Join Date: Mar 2009
Location: Germany
Posts: 59,535
Default

i dont think its a good idea to disable instancemanagement, as it can cause database errors if users starts jd twice. there must be another way for this as i know our 2 mac developers dont have this kind of problem.
it should be possible to add java to exclude list so it dont ask again for every new port. if thats not possible then the firewall is xyxyxxyxyx
__________________
JD-Dev & Server-Admin
Reply With Quote
  #15  
Old 21.09.2010, 02:11
thomas.miller
Guest
 
Posts: n/a
Default to be more precisely

I use the built-in firewall on OSX 10.6.4.
My settings:
Block all incoming connections - unchecked

Allow signed software to accept incoming connections - checked
Stealth modus - checked

On the list below, I marked jdownloader with allow incoming connections.

Hopefully I got all the translations right since I use a German OSX version.


The OSX firewall is definitely pretty crappy. It is not very customizable and I dont think that Apple lets you turn of the "application monitoring part" while leaving the port blocking part intact. (Please correct me if I am wrong)

It would be great, if somebody has a brilliant idea how to solve this.

Thanks for your help. I appreciate that a lot.
Reply With Quote
  #16  
Old 21.09.2010, 05:20
drbits's Avatar
drbits drbits is offline
JD English Support (inactive)
 
Join Date: Sep 2009
Location: Physically in Los Angeles, CA, USA
Posts: 4,437
Default

What about outgoing connections?

Sorry, I am stuck in M$ville, so I cannot help much.
Reply With Quote
  #17  
Old 21.09.2010, 11:18
Jiaz's Avatar
Jiaz Jiaz is offline
JD Manager
 
Join Date: Mar 2009
Location: Germany
Posts: 59,535
Default

On the list below, I marked jdownloader with allow incoming connections.

you have to mark java to allow incomming connections. jdownloader is a java tool
__________________
JD-Dev & Server-Admin
Reply With Quote
  #18  
Old 21.09.2010, 19:35
thomas.miller
Guest
 
Posts: n/a
Default

There is no apparent way to configure the outgoing connection in the OSX firewall. BTW, it doesnt matter if I block or allow the incoming connections for jD. jD downloads just fine.
:outch: The popup is just annoying.

@Jiaz Java, you talking about the island ?
Adding java to the list doesnt work for me.
Even, as java on macs comes directly from apple, it should be automatically trusted. Thinking of that, I also checked java's signature via
Code:
codesign -vvv
. Its signature is still intact.


It would be interesting, if someone with Snow Leopard could reproduce this with the same firewall settings.

apart from that, I guess, I still have to live with it.

Best
Reply With Quote
  #19  
Old 22.09.2010, 10:43
Jiaz's Avatar
Jiaz Jiaz is offline
JD Manager
 
Join Date: Mar 2009
Location: Germany
Posts: 59,535
Default

ever tried to start asking mac support i mean its their os and their firewall?
__________________
JD-Dev & Server-Admin
Reply With Quote
  #20  
Old 23.09.2010, 00:06
BurtCokain
Guest
 
Posts: n/a
Wink

working on 10.6.3 and having same "issue",
but hey, its just one click, there are bigger problems in the world ;-)
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

All times are GMT +2. The time now is 22:57.
Provided By AppWork GmbH | Privacy | Imprint
Parts of the Design are used from Kirsch designed by Andrew & Austin
Powered by vBulletin® Version 3.8.10 Beta 1
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.