JDownloader Community - Appwork GmbH
 

Reply
 
Thread Tools Display Modes
  #1  
Old 14.08.2010, 02:20
tetetetete
Guest
 
Posts: n/a
Default Script para Router Xavi 7968

Para el que quiera probarlo , aqui les dejo el Script que yo uso con mi router Xavi 7968 de Telefonica España :

Informacion del router :
Model Number.... : Solos 4610 RD / Solos 461x CSP v1.0
Firmware Version : 3.01APT65.7968A E.25.41.33 25/Sep/2008 00:30

Code:
[[[HSRC]]]
    [[[STEP]]]
        [[[REQUEST]]]
        GET /home.html HTTP/1.1
        Host: %%%routerip%%%
        [[[/REQUEST]]]
    [[[/STEP]]]

    [[[STEP]]]
        [[[REQUEST]]]
        GET /main_menu.html HTTP/1.1
        Host: %%%routerip%%%
        [[[/REQUEST]]]
    [[[/STEP]]]

    [[[STEP]]]
        [[[REQUEST]]]
        GET /webconfig/status/overview.html HTTP/1.1
        Host: %%%routerip%%%
        Authorization: Basic %%%basicauth%%%
        [[[/REQUEST]]]
    [[[/STEP]]]

    [[[STEP]]]
        [[[REQUEST]]]
        GET /help.html HTTP/1.1
        Host: %%%routerip%%%
        [[[/REQUEST]]]
    [[[/STEP]]]

    [[[STEP]]]
        [[[REQUEST]]]
        GET /advan_menu.html HTTP/1.1
        Host: %%%routerip%%%
        [[[/REQUEST]]]
    [[[/STEP]]]

    [[[STEP]]]
        [[[REQUEST]]]
        GET /webconfig/wan/wan.html HTTP/1.1
        Host: %%%routerip%%%
        Authorization: Basic %%%basicauth%%%
        [[[/REQUEST]]]
    [[[/STEP]]]

    [[[STEP]]]
        [[[REQUEST]]]
        GET /webconfig/quick_start/constatus.html?pppName=ppp-0 HTTP/1.1
        Host: %%%routerip%%%
        [[[/REQUEST]]]
    [[[/STEP]]]

    [[[STEP]]]
        [[[REQUEST]]]
        GET /webconfig/quick_start/constatus.html?pppName=ppp-0 HTTP/1.1
        Host: %%%routerip%%%
        Authorization: Basic %%%basicauth%%%
        [[[/REQUEST]]]
    [[[/STEP]]]

    [[[STEP]]]
        [[[REQUEST]]]
        GET /webconfig/quick_start/disconnect.html/disconnect?pppName=ppp-0 HTTP/1.1
        Host: %%%routerip%%%
        Authorization: Basic %%%basicauth%%%
        [[[/REQUEST]]]
    [[[/STEP]]]

    [[[STEP]]]
        [[[REQUEST]]]
        GET /webconfig/quick_start/connect.html HTTP/1.1
        Host: %%%routerip%%%
        Authorization: Basic %%%basicauth%%%
        [[[/REQUEST]]]
    [[[/STEP]]]

    [[[STEP]]]
        [[[REQUEST]]]
        GET /webconfig/quick_start/connect.html/action_qstart_connect?qstart_pppIntf=ppp-0&qstart_pppUserName=adslppp%40telefonicanetpa&qstart_pppPassword=adslppp&submit_Connect=Connect HTTP/1.1
        Host: %%%routerip%%%
        Authorization: Basic %%%basicauth%%%
        [[[/REQUEST]]]
    [[[/STEP]]]

    [[[STEP]]]
        [[[REQUEST]]]
        GET /webconfig/quick_start/connect.html?pppName=ppp-0&ConnectSubmit=TRUE HTTP/1.1
        Host: %%%routerip%%%
        Authorization: Basic %%%basicauth%%%
        [[[/REQUEST]]]
    [[[/STEP]]]

[[[/HSRC]]]


Saludos.

Last edited by tetetetete; 14.08.2010 at 02:25. Reason: Añadir información del Router
Reply With Quote
  #2  
Old 14.08.2010, 15:17
bartok
Guest
 
Posts: n/a
Default

Hola,

Con tu permiso incluiré este enlace en mi post de reconexión para que no se pierda y otros usuarios puedan beneficiarse.

Saludos y suerte
Reply With Quote
  #3  
Old 14.08.2010, 18:30
tetetetete
Guest
 
Posts: n/a
Default Otro Script para Xavi 7968 de Telefonica

Gracias bartok por enlazarlo a tu post.

Tambien podeis probar con este otro que de momento me esta funcionando perfecto en las pruebas que he hecho en mi Xavi 7968 :

Code:
[[[HSRC]]]
    [[[STEP]]]
        [[[REQUEST]]]
        GET / HTTP/1.1
        Host: %%%routerip%%%
        [[[/REQUEST]]]
    [[[/STEP]]]

    [[[STEP]]]
        [[[REQUEST]]]
        GET /home.html HTTP/1.1
        Host: %%%routerip%%%
        [[[/REQUEST]]]
    [[[/STEP]]]

    [[[STEP]]]
        [[[REQUEST]]]
        GET /webconfig/status/overview.html HTTP/1.1
        Host: %%%routerip%%%
        Authorization: Basic %%%basicauth%%%
        [[[/REQUEST]]]
    [[[/STEP]]]

    [[[STEP]]]
        [[[REQUEST]]]
        GET /help.html HTTP/1.1
        Host: %%%routerip%%%
        [[[/REQUEST]]]
    [[[/STEP]]]

    [[[STEP]]]
        [[[REQUEST]]]
        GET /main_menu.html HTTP/1.1
        Host: %%%routerip%%%
        [[[/REQUEST]]]
    [[[/STEP]]]

    [[[STEP]]]
        [[[REQUEST]]]
        GET /admin_menu.html HTTP/1.1
        Host: %%%routerip%%%
        [[[/REQUEST]]]
    [[[/STEP]]]

    [[[STEP]]]
        [[[REQUEST]]]
        GET /webconfig/commit_reboot/commit_reboot.html HTTP/1.1
        Host: %%%routerip%%%
        Authorization: Basic %%%basicauth%%%
        [[[/REQUEST]]]
    [[[/STEP]]]

    [[[STEP]]]
        [[[REQUEST]]]
        GET /webconfig/commit_reboot/commit_reboot.html/CommitReboot?rebootfrom=RBF5&reboot=Reboot HTTP/1.1
        Host: %%%routerip%%%
        Authorization: Basic %%%basicauth%%%
        [[[/REQUEST]]]
    [[[/STEP]]]

    [[[STEP]]]
        [[[REQUEST]]]
        GET /webconfig/commit_reboot/rebootinfo.html HTTP/1.1
        Host: %%%routerip%%%
        Authorization: Basic %%%basicauth%%%
        [[[/REQUEST]]]
    [[[/STEP]]]

    [[[STEP]]]
        [[[REQUEST]]]
        GET /home.html HTTP/1.1
        Host: %%%routerip%%%
        [[[/REQUEST]]]
    [[[/STEP]]]

    [[[STEP]]]
        [[[REQUEST]]]
        GET /main_menu.html HTTP/1.1
        Host: %%%routerip%%%
        [[[/REQUEST]]]
    [[[/STEP]]]

    [[[STEP]]]
        [[[REQUEST]]]
        GET /webconfig/status/overview.html HTTP/1.1
        Host: %%%routerip%%%
        Authorization: Basic %%%basicauth%%%
        [[[/REQUEST]]]
    [[[/STEP]]]

    [[[STEP]]]
        [[[REQUEST]]]
        GET /help.html HTTP/1.1
        Host: %%%routerip%%%
        [[[/REQUEST]]]
    [[[/STEP]]]

[[[/HSRC]]]

Saludos.
Reply With Quote
  #4  
Old 15.08.2010, 01:33
bartok
Guest
 
Posts: n/a
Default

Enlazado

Saludos y suerte
Reply With Quote
  #5  
Old 30.05.2012, 23:41
nponoBegHuk
Guest
 
Posts: n/a
Default

El primer script tiene una pega, es que al desconectar y volver a conectar al instante, hay veces que se queda colgado y nunca reconecta (1 de cada 5 diría yo), lo cual es bastante molesto (a los que tengan windows vista/7 y les haya pasado sabrán a lo que me refiero).
El segundo script no suele fallar pero el reinicio de aparato completo tarda más de 1 minuto.

Si os parece, voy a compartir mi propio script con el que he conseguido reconexiones de 10 segundos máximo, de momento no me ha fallado ninguna vez. Básicamente es el mismo script que desconecta de la red y vuelve a autentificarse, con la diferencia de que la parte de la desconexión está omitida y lo único que sucede es que el router solicita nueva conexión ADSL a la central, ignorando el hecho de que ya está conectado.

Los datos de mi router son:
Model Number: Solos 4610 RD / Solos 461x CSP v1.0
Firmware Version: 3.01APT85.7968A E.25.41.64 25/Jun/2010 10:10

el script en sí queda mas o menos así:
Code:
[[[HSRC]]]
    [[[STEP]]]
        [[[REQUEST]]]
        GET /webconfig/quick_start/connect.html/action_qstart_connect?qstart_pppIntf=ppp-0&qstart_pppUserName=adslppp%40telefonicanetpa&qstart_pppPassword=adslppp&submit_Connect=Connect HTTP/1.1
        Host: %%%routerip%%%
        Authorization: Basic %%%basicauth%%%
        [[[/REQUEST]]]
    [[[/STEP]]]

    [[[STEP]]]
        [[[REQUEST]]]
        GET /webconfig/quick_start/connect.html?pppName=ppp-0&ConnectSubmit=TRUE HTTP/1.1
        Host: %%%routerip%%%
        Authorization: Basic %%%basicauth%%%
        [[[/REQUEST]]]
    [[[/STEP]]]
[[[/HSRC]]]
También es más corto

Un saludo.
Reply With Quote
  #6  
Old 06.04.2014, 02:24
Lram32's Avatar
Lram32 Lram32 is offline
Spanish Supporter
 
Join Date: Jul 2012
Location: Dark side of the moon
Posts: 9,908
Default

Hilo movido a la sección correcta > Reconexión
__________________
» Setup JD2 / Instalador de JD2 «
Spoiler:

Installer for Windows XP/Vista/Seven/Eight
|| JD2 x86 - x64 (Beta) ||

Installer for Mac
|| JD2 (Beta) ||

Installers for Linux
|| JD2 (Beta) x86 || <---> || JD2 (Beta) x64 ||

How to Create a Log
-» Click Here «-


¿Cómo crear un registro?
-» Click Aquí «-


Support Chat / Chat de Soporte
-» Click Here / Click Aquí «-


Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

All times are GMT +2. The time now is 20:42.
Provided By AppWork GmbH | Privacy | Imprint
Parts of the Design are used from Kirsch designed by Andrew & Austin
Powered by vBulletin® Version 3.8.10 Beta 1
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.